Author Topic: The 15 July 2007 build (4266) is out.  (Read 17816 times)

Michael_vlk

  • Guest
Re: The 15 July 2007 build (4266) is out.
« Reply #15 on: July 17, 2007, 07:25:06 am »
cstudent, thanks! I shall learn programming :)

Regards,
Michael from Vladivostok.

Offline cacb

  • Regular
  • ***
  • Posts: 396
Re: The 15 July 2007 build (4266) is out.
« Reply #16 on: July 17, 2007, 12:45:42 pm »
Hi,

I downloaded and installed the Ubuntu deb for the 4266 build (I use Kubuntu 7.04). But I found that my application no longer builds with this version, it fails to find <wx/wxprec.h> for example (i.e. it does not find any header files). When I remove the new 4266 package and install the older 4066 build everything works fine again.

I am building in unicode on linux and I have wx 2.8.4 installed (from http://apt.wxwidgets.org/)

Any ideas ?

Regards
cacb

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: The 15 July 2007 build (4266) is out.
« Reply #17 on: July 17, 2007, 01:23:08 pm »
Hi !

I installed wxWidgets 2.8.4 from this wiki page.

I did not try with rev 4266 but it seems that lots of Ubuntu users followed this page instructions.

Dje

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: The 15 July 2007 build (4266) is out.
« Reply #18 on: July 17, 2007, 03:13:10 pm »
Grom - подпись порадовала :).

Слава России :wink:
gcc+winXP+suse.

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: The 15 July 2007 build (4266) is out.
« Reply #19 on: July 17, 2007, 04:23:47 pm »
Grom - подпись порадовала :).

Слава России :wink:
Do you mean msdkufhilazvoueghfoehlvgoiaeugfilqvmqegfugabuvuaepiuvgfbabepeiu ?

Offline cacb

  • Regular
  • ***
  • Posts: 396
Re: The 15 July 2007 build (4266) is out.
« Reply #20 on: July 17, 2007, 06:11:28 pm »
I installed wxWidgets 2.8.4 from this wiki page.

I did not try with rev 4266 but it seems that lots of Ubuntu users followed this page instructions.
Dje

Well... last month it was announced that the wxWidgets repository is now at http://apt.wxwidgets.org/
see http://groups.google.com/group/comp.soft-sys.wxwindows/browse_thread/thread/9155ae5fa9a82873/1d076f8012ea124b?lnk=st&q=wxWidgets+new+repository&rnum=1&hl=en#1d076f8012ea124b

or if you prefer the same with a shorter link http://tinyurl.com/ypsohr

And: As stated there is no problem with compiling using C::B build 4066 without changing anything wrt. wxWidgets using wx 2.8.4 from the http://apt.wxwidgets.org/ repository. So I suspect something odd with C::B build 4266.

I am still puzzled.

cacb

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 15 July 2007 build (4266) is out.
« Reply #21 on: July 17, 2007, 06:33:48 pm »
Well, 4066 was over a month ago. I know there was talk of doing away with the precompiled headers, but I'm not sure if that is the case and if so, if it was implemented since 4066.

Offline kurapix

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: The 15 July 2007 build (4266) is out.
« Reply #22 on: July 17, 2007, 07:41:19 pm »
Must we use the official repository or the one in the wiki? (No problem with the packages ... ?)

Kurapix
Code::Blocks package building script

Offline cacb

  • Regular
  • ***
  • Posts: 396
Re: The 15 July 2007 build (4266) is out.
« Reply #23 on: July 17, 2007, 10:28:05 pm »
Well, 4066 was over a month ago. I know there was talk of doing away with the precompiled headers, but I'm not sure if that is the case and if so, if it was implemented since 4066.

Indeed 4066 is over a month ago :lol:. That is why I attempted to upgrade. But it failed to compile my code, and that is the problem. I don't want to be stuck with an old version, I can't see that I am doing anything wrong?

cacb

BrutPitt

  • Guest
Re: The 15 July 2007 build (4266) is out.
« Reply #24 on: July 28, 2007, 12:38:25 pm »
Hello everyone.

I know that is not the right place in forums to ask for help but I really need someone to help me urgent. Since yesterday I have been trying everything under Fedora 7 to run Code::Blocks. I installed it with yum, everything went well. Unfortunately for some reason Code::Blocks crashes while detecting compiler and tries to load IDE. I have a screenshot which doesn't really shows any error message to help debugging but you can see that freezes at the "tips of the day".

http://img476.imageshack.us/my.php?image=codeblockcrashingha5.png

Can anyone help me please?

Best Regards,

Stefanos

I had the same prooblem on Fedora 7...

Now... if You don't want to rebuild C::B from NightBuild SVN version... there is the build 4280 (2007-07-18 NightBuild) on the fedora site "testing" repository.
Go to http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/7/ and select your paltform subdirectory (i386, x86_64, ppc, ppc64).
(you can also to configure and to use YumExtender)

You need to upgrade also wxGTK (wxWidgets) from 2.8.3-2  -> 2.8.4-3 ... or downgrade to 2.6 version (also if you build a N.B. SVN version)
(you find wxGTK in the same directory of C::B)

Ciao, Michele