Author Topic: Remote debugging  (Read 25106 times)

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: Remote debugging
« Reply #15 on: October 26, 2007, 02:16:05 pm »
That is the probably most inefficient way to do this. wxFilename is the devil.

I'm waiting for Yiannis' commit to remove that devil. ;)
Be a part of the solution, not a part of the problem.

Offline drZymo

  • Single posting newcomer
  • *
  • Posts: 9
Re: Remote debugging
« Reply #16 on: November 05, 2007, 11:48:08 am »
http://developer.berlios.de/bugs/?func=detailbug&bug_id=12211&group_id=5358
Quote
Rev. 4584 contains the requested change.
If things don't break for other people, this bug will be closed.
2007-Oct-31 10:48
mandrav

I just downloaded build 4596 and it seems the problem is still there. Can someone tell me what the changes are?

Ooh great, I see in the revision logs:
Quote
Revision 4592  - (view) (download) - [select for diffs]
Modified Fri Nov 2 16:23:15 2007 UTC (2 days, 18 hours ago) by killerbot
File length: 9184 byte(s)
Diff to previous 4584

- revert r4584

Revision 4584 - (view) (download) - [select for diffs]
Modified Wed Oct 31 09:48:14 2007 UTC (5 days, 1 hour ago) by mandrav
File length: 9335 byte(s)
Diff to previous 3682

* Debugger no longer uses unix notation for breakpoint filenames.
So I can assume that in revisions 4592+ it is back to normal and the bug is still not solved??

Is there someplace where I can download the 4584 windows binary?
« Last Edit: November 05, 2007, 12:07:21 pm by drZymo »

Offline drZymo

  • Single posting newcomer
  • *
  • Posts: 9
Re: Remote debugging
« Reply #17 on: November 09, 2007, 09:24:09 am »
Is there noone who can reply  :( ?

Offline drZymo

  • Single posting newcomer
  • *
  • Posts: 9
Re: Remote debugging
« Reply #18 on: January 02, 2008, 11:45:00 am »
For the project here at my work it would be really nice to have the remote debugging working under Windows. So can anyone of the developers be kind enough to tell me the status of this problem?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Remote debugging
« Reply #19 on: January 02, 2008, 12:06:10 pm »
Which version of gdb do you use?
I had the same problems in W2k with gdb 6.6 on local projects (for example C::B), but it works with gdb 6.7.5.20071127 (Technical preview) from the MinGW download-site.

Offline drZymo

  • Single posting newcomer
  • *
  • Posts: 9
Re: Remote debugging
« Reply #20 on: January 02, 2008, 01:36:10 pm »
I did use a 6.6 gdb version (not the mingw compiled version though). I will build the 6.7 version with my settings. Perhaps it works. Thanks for the tip.

Offline drZymo

  • Single posting newcomer
  • *
  • Posts: 9
Re: Remote debugging
« Reply #21 on: January 02, 2008, 05:19:17 pm »
The first test seem to be working. I used a simple hello world example and I managed to remotely debug this executable using CodeBlocks under Windows and a Linux machine as target. I will further test this with a bigger application.

Anyhow, gdb 6.7.1 appears to be fixing the problem. Great :D.

Offline ffelagund

  • Single posting newcomer
  • *
  • Posts: 4
Re: Remote debugging
« Reply #22 on: May 22, 2008, 07:11:05 pm »
Hello people,
How do you configure CB for remote debugging + custom makefile? I have a little here that don't let me debug remotely and execute remotely.
For remotely execution I use an script that launches the executable in the remote machine throught ssh, but for debugging, CD is trying to debug that 'script'. Is there any way of doing both things without having to change the "executable" file (script/binary) in CB conf panel each time?

Thanks.