Author Topic: "invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping..."  (Read 19222 times)

Offline Kylotan

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Free game development libraries
A fresh installation of Code::Blocks (July 21st nightly) seems unable to find my compiler.

MinGW is installed to E:\code\cpp\mingw.
I installed the contents of the 7 packages listed here: http://wiki.codeblocks.org/index.php?title=MinGW_installation#GCC_3.4.5_manual_install

Then in Code::Blocks, I set the GCC GNU Compiler to look in "E:\code\cpp\mingw" as the compiler's installation directory. Under Search directories, for Compiler/Linker/Resource compiler, all the correct directories are there.

So what's the problem? Am I missing yet another setting? Please don't tell me to install the compiler to C:\MinGW - not everybody can go dropping new directories on the root of their C: drive.
« Last Edit: July 22, 2007, 06:44:56 pm by Kylotan »

Offline raph

  • Almost regular
  • **
  • Posts: 242
You just need to set Settings->Compiler and debugger->Toolchain executables->Compiler's installation directory to E:\code\cpp\mingw.

Offline Kylotan

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Free game development libraries
That's exactly what I said I'd done.

Offline raph

  • Almost regular
  • **
  • Posts: 242
It should work then. My mingw 3.4.5 installation is in E:\mingw
Does the file E:\code\cpp\mingw\bin\mingw32-gcc.exe exist and did you modify Toolchain executables->Program files?

Offline Kylotan

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Free game development libraries
My settings:


My directory structure:


I don't actually have gdb in there, but surely that shouldn't matter for the build stage.

Offline raph

  • Almost regular
  • **
  • Posts: 242
Content of gcc-core-*.tar.gz file is missing, please extract it, too.

Offline Kylotan

  • Multiple posting newcomer
  • *
  • Posts: 17
    • Free game development libraries
Ah yes, thanks, that fixed it! I obviously didn't extract it properly the first time, somehow.

It would be good if Code::Blocks could give better messages in these situations!

tuan

  • Guest
Hi raph, I did the same to Kylotan but I still have problem


Can you show me how to fix this problem!

Many thanks

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
It would be good if Code::Blocks could give better messages in these situations!
It does if you use a more recent version aka nightly. ;-)
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

PaulD

  • Guest
I just had the same problem after downloading the program today. I pulled up the global compiler settings and the compiler installation directory read C:\MinGW.The default install directory was C:\Program Files\CodeBlocks and MinGW was under it. I changed the compiler installation directory and it worked. There's obviously something wrong with the install program. I downloaded the Windows version (codeblocks-8.02mingw-setup.exe) from sourceforge -the link from code::block's web site.