Author Topic: The 04 July 2007 build (4219) is out.  (Read 13842 times)

Offline indigo0086

  • Almost regular
  • **
  • Posts: 150
Re: The 04 July 2007 build (4219) is out.
« Reply #15 on: July 05, 2007, 04:48:17 pm »
I went back to July 3rd build.  It seems to be counting the spaces as separate directories so "\Documents and settings" is seen as "\documents \and \settings"

it doesn't execute the code.

Offline tvaster

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: The 04 July 2007 build (4219) is out.
« Reply #16 on: July 06, 2007, 06:18:47 am »
Ok, that got me a bunch further.   (SVN 4229)

Now I have:

 g++ -DHAVE_CONFIG_H -I. -I. -I../../../src/include -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ -pthread -I../../../src/include/wxFlatNotebook/include -Ulinux -Uunix -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT popup_dlg.lo -MD -MP -MF .deps/popup_dlg.Tpo -c src/wxFlatNotebook/popup_dlg.cpp  -fPIC -DPIC -o .libs/popup_dlg.o
../../../src/include/wxFlatNotebook/include/wx/wxFlatNotebook/wxFNBDropTarget.h:75: error: invalid use of undefined type ‘struct wxDropTarget’
/usr/local/include/wx-2.8/wx/window.h:60: error: forward declaration of ‘struct wxDropTarget’
../../../src/include/wxFlatNotebook/include/wx/wxFlatNotebook/wxFNBDropTarget.h:78: error: expected identifier before ‘*’ token


wxWidgets-2.8.4     --with-X11 --enable-compat26
codeblocks             --with-X11 --enable-contrib

Thanks Tim S for help on the last one.                             

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6613
    • My Best Post
Re: The 04 July 2007 build (4219) is out.
« Reply #17 on: July 06, 2007, 06:49:07 am »
Ok, that got me a bunch further.   (SVN 4229)

Now I have:

 g++ -DHAVE_CONFIG_H -I. -I. -I../../../src/include -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ -pthread -I../../../src/include/wxFlatNotebook/include -Ulinux -Uunix -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT popup_dlg.lo -MD -MP -MF .deps/popup_dlg.Tpo -c src/wxFlatNotebook/popup_dlg.cpp  -fPIC -DPIC -o .libs/popup_dlg.o
../../../src/include/wxFlatNotebook/include/wx/wxFlatNotebook/wxFNBDropTarget.h:75: error: invalid use of undefined type ‘struct wxDropTarget’
/usr/local/include/wx-2.8/wx/window.h:60: error: forward declaration of ‘struct wxDropTarget’
../../../src/include/wxFlatNotebook/include/wx/wxFlatNotebook/wxFNBDropTarget.h:78: error: expected identifier before ‘*’ token


wxWidgets-2.8.4     --with-X11 --enable-compat26
codeblocks             --with-X11 --enable-contrib

Thanks Tim S for help on the last one.                             

I think Code::Blocks requires wxMSW or wxGTK version of wxWidgets; in other words it does not work with "--with-X11" to my knowledge. But, I am a windows person so I might be mistaken.

Per http://www.wxwidgets.org/docs/supported.htm wxX11 does not support wxDropTarget you might check the dnd.h/dnd.cpp file to confirm it.

This most likely needs to be a new thread in another group. If you wish to ask if Code::Blocks supports using wxX11 to build Code::Blocks try "Help" Group at http://forums.codeblocks.org/index.php/board,1.0.html

After you confirm it does not support using wxX11 to build C::B and you wish to work on patches for Code::Blocks I suggest posting a new thread in the "Development" at http://forums.codeblocks.org/index.php/board,7.0.html

Tim S
« Last Edit: July 06, 2007, 07:07:35 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org