Author Topic: QtCore4.dll not Found  (Read 63974 times)

kisco

  • Guest
QtCore4.dll not Found
« on: July 04, 2007, 04:49:47 pm »
Dear All,

I just installed code::blocks snv on Windows Vista platform. I tried to test it after installation and this error occurred after run command. The error reads as follows "This application has failed to start because QtCore4.dll was not found. Any idea on how to solve this error.

Thanks
« Last Edit: July 04, 2007, 04:51:45 pm by kisco »

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 8695
Re: QtCore4.dll not Found
« Reply #1 on: July 04, 2007, 07:05:30 pm »
"This application has failed to start because QtCore4.dll was not found."
Well - it tells you exactly what's the problem. Where does an executable search for libraries? In it's own path and in system-wide known path's (e.g. from the PATH environment variable). So either you copy QtCore4.dll into your applications' path or in a system-wide accessible one, such as C:\Windows\system32 (under the assumption you have installed Windows to C:\Windows).
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

kisco

  • Guest
Re: QtCore4.dll not Found
« Reply #2 on: July 05, 2007, 09:28:53 am »
Thank you very much. It worked.

regards

xlarsx

  • Guest
Re: QtCore4.dll not Found
« Reply #3 on: June 07, 2008, 08:40:50 am »
Greetings,
Remember that you've to include all the DLLs files from the QT's bin directory to your Code::Blocks' linker using:
Settings/Compiler and Debugger.../Linker Settings/Add

And for running your programs it's a good idea like MortenMacFly says to copy all those Dlls files to that directory, not only the QtCore4.dll (with Windows, of course :) )




rhmitul

  • Guest
Re: QtCore4.dll not Found
« Reply #4 on: November 06, 2011, 11:30:45 am »
It should be an interfering with Matlab that comes with QtCore.dll of older version So, just try  to move Qt folder from the user %PATH% to the launch of the system %PATH% where Matlab folder was.  Solved