Author Topic: AutoVersioning Plugin  (Read 131023 times)

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: AutoVersioning Plugin
« Reply #45 on: July 20, 2007, 06:31:59 pm »
ok i compile it but it wouldn't start
Ubuntu 7.04 my own compile version of codeblocks witg wx2.8.4

Edit:
ERROR: /home/psyhlo/.codeblocks/share/codeblocks/plugins/autoversioning.so: not loaded (missing symbols?)

[attachment deleted by admin]
« Last Edit: July 20, 2007, 06:41:08 pm by PsYhLo »

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: AutoVersioning Plugin
« Reply #46 on: July 21, 2007, 12:42:05 am »

ok i compile it but it wouldn't start

Ubuntu 7.04 my own compile version of codeblocks witg wx2.8.4



Edit:

ERROR: /home/psyhlo/.codeblocks/share/codeblocks/plugins/autoversioning.so: not loaded (missing symbols?)




Thats the problem that I reported on the first post in the unix project. This is the text that I wrote.




Edit: Some little mistake in the unix project of autoversioning-contrib.7z on the post-build steps.



This line: zip -j9 ..\..\..\devel\share\codeblocks\autoversioning.zip manifest.xml



should read: zip -j9 ../../../devel/share/codeblocks/autoversioning.zip manifest.xml



thats all.



I have already tested the plugin on ubuntu and it works fine. The tool tips are so smooth...  :D






The problem is that no autoversioning.zip with the manifest is been copied to the codeblocks directory. After changing to the correct path described above it will work just fine. Sorry for that mistake on mines.



That is if you are using the autoversioning-contrib.7z file that has the unix project. If not, then maybe you are running a version of codeblocks that is not compatible with the sdk that you are compiling to. I attached a screen shot of the plugin working on ubuntu.

[attachment deleted by admin]

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: AutoVersioning Plugin
« Reply #47 on: July 21, 2007, 09:36:51 am »
i compile your plugin after compilation of codeblocks rev 4281
and installed with Manage Plugins

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: AutoVersioning Plugin
« Reply #48 on: July 21, 2007, 08:27:55 pm »
i compile your plugin after compilation of codeblocks rev 4281
and installed with Manage Plugins

How do you compiled codeblocks?
./bootstrap
./configure
./make
./make install

or  :?:

using a compiled codeblocks to compile the sources using the cobeblocks-unix project :?:

I hadn't created a Makefile.am and the first method will not work (only project files work for now).

Also, maybe can be that your $(#CB) global variable is pointing to a directory with an old compilation that is not actual with the version of codeblocks that you are using (in the case that you are using the project file, and it should be the case since you installed it from "Manage Plugins"). So the libcodeblocks.so that you're compiling to is different from the one used by codeblocks. And thats the error while loading symbols.

But, I'm just making conclusions, the problem can be another one. :?
I compiled it again today with the actual revision 4285 and is working fine.

Steps for compiling plugins:

  1. With a precompiled version of codeblocks open the CodeBlocks-unix.cbp and compile it.
  2. Set the global variable "CB" to point the /trunk/src folder of your svn download.
  3. Then open the ContribPlugins-unix.workspace and hit "Build Workspace" from the "Build menu"
  4. Run the /trunk/src/update script that will create a folder named output with the correct binaries.
  5. And for contributed plugins like autoversioning download the correct sources, in this case AutoVersioning.7z
  6. Open the project file and hit the build button.

Important points:

  1. Install the plugin to the codeblocks that you just compiled. (else symbols error)
  2. Set the "CB"  global variable to point to the correct compilation and sources. (else symbols error)
« Last Edit: July 21, 2007, 08:44:37 pm by JGM »

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: AutoVersioning Plugin
« Reply #49 on: July 21, 2007, 08:49:13 pm »
How do you compiled codeblocks?
./bootstrap
./configure
./make
./make install
this is my way i have only one codeblocks source dir so it is compiled with right sdk version
also i used this ./configure --prefix=/usr --with-contrib-plugins=all instead of ./configure

Offline darthdespotism

  • Almost regular
  • **
  • Posts: 163
    • Coder's Nemesis
Re: AutoVersioning Plugin
« Reply #50 on: July 21, 2007, 09:08:04 pm »
I may be wrong but is it not --with-contrib=all (without plugin)?

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: AutoVersioning Plugin
« Reply #51 on: July 21, 2007, 09:30:52 pm »
type ./configure --help and will see ;)

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: AutoVersioning Plugin
« Reply #52 on: July 21, 2007, 11:58:34 pm »
this is my way i have only one codeblocks source dir so it is compiled with right sdk version
also i used this ./configure --prefix=/usr --with-contrib-plugins=all instead of ./configure

Ok, I made it like you except that in the prefix parameter I put /etc/codeblocks, but that was my choice. After compiling the plugin I got the same problem that you had.

I saw some errors in the linux project file, (what a moron I'm) well I just corrected the project file using the default unix template of codeblocks from the plugin project. Now the plugin loaded fine after compilation with the new settings!

Now you have to set the $(#CB) to point /usr/include/codeblocks or /usr/local/include/codeblocks, I think that for you is the first path.

Well here is the linux project file attached and corrected. (try it out and let me know) :)

[attachment deleted by admin]
« Last Edit: July 22, 2007, 12:02:56 am by JGM »

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: AutoVersioning Plugin
« Reply #53 on: July 22, 2007, 07:54:30 pm »
it works!
even compile process complete without any warning

it is such a good plug-in 10x keep the good work

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: AutoVersioning Plugin
« Reply #54 on: July 23, 2007, 12:59:31 am »
it works!
even compile process complete without any warning

it is such a good plug-in 10x keep the good work

Thanks! :D Is for me a pleasure to know that is useful

I will add now the option to generate a CHANGES file every time that a commit changes is executed.


Code: [Select]
Changes File

v0.3.4a
  - blah blah
  - blah blah

v0.3.3a
  - Some fixes
  - new features

Like I wrote in that post.

I think this will be useful after all, for us to keep our work organized more easily.

Well I will start working on this, it should be simple, I think :?

Offline JaredR26

  • Single posting newcomer
  • *
  • Posts: 5
Re: AutoVersioning Plugin
« Reply #55 on: July 24, 2007, 04:06:28 am »
I cannot get this to compile.  I have MinGW 5.1.3, July 22/23 nightly build of CodeBlocks, wxWidgets 2.8.4, WinXP SP2.

wxWidgets has been compiled, CodeBlocks has been compiled.

It cannot find tinyxml:
Code: [Select]
:: === AutoVersioning, default ===
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:8: tinyxml/tinyxml.h: No such file or directory
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:: In function `bool QuerySvn(const wxString&, wxString&, wxString&)':
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: `TiXmlDocument' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: (Each undeclared identifier is reported only once for each function it appears in.)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: expected `;' before "doc"
src\src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:30: error: `doc' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `TiXmlElement' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `e' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:39: error: `d' undeclared (first use this function)
:: === Build finished: 8 errors, 0 warnings ===

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: AutoVersioning Plugin
« Reply #56 on: July 24, 2007, 04:23:00 am »
You also need to check out the Code::Blocks source from SVN and build it.
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline JaredR26

  • Single posting newcomer
  • *
  • Posts: 5
Re: AutoVersioning Plugin
« Reply #57 on: July 24, 2007, 04:28:47 am »
I did, unless I missed something, still wont work.  Checked out the code from the SVN, ran the nightly pre-compiled codeblocks and compiled the SVN source.

Offline JGM

  • Lives here!
  • ****
  • Posts: 518
  • Got to practice :)
Re: AutoVersioning Plugin
« Reply #58 on: July 24, 2007, 08:04:27 am »
It cannot find tinyxml:
Code: [Select]
:: === AutoVersioning, default ===
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:8: tinyxml/tinyxml.h: No such file or directory
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:: In function `bool QuerySvn(const wxString&, wxString&, wxString&)':
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: `TiXmlDocument' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: (Each undeclared identifier is reported only once for each function it appears in.)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: expected `;' before "doc"
src\src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:30: error: `doc' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `TiXmlElement' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `e' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:39: error: `d' undeclared (first use this function)
:: === Build finished: 8 errors, 0 warnings ===

Does the $(#CB) Global variable is pointing to "codeblocks-head\trunk\src"? Else try changing this "$(#CB.INCLUDE)" to "$(#CB)\include"

If the problem keeps on, then try to specified all the steps that you made to compile the plugin, and also the file structure (the routes for the codeblocks sources). Some one else had the same problem I think, what could be :? :?:

Offline JaredR26

  • Single posting newcomer
  • *
  • Posts: 5
Re: AutoVersioning Plugin
« Reply #59 on: July 25, 2007, 09:50:29 am »
It cannot find tinyxml:
Code: [Select]
:: === AutoVersioning, default ===
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:8: tinyxml/tinyxml.h: No such file or directory
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:: In function `bool QuerySvn(const wxString&, wxString&, wxString&)':
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: `TiXmlDocument' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: (Each undeclared identifier is reported only once for each function it appears in.)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:29: error: expected `;' before "doc"
src\src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:30: error: `doc' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `TiXmlElement' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:35: error: `e' undeclared (first use this function)
src\plugins\contrib\AutoVersioning\avSvnRevision.cpp:39: error: `d' undeclared (first use this function)
:: === Build finished: 8 errors, 0 warnings ===

Does the $(#CB) Global variable is pointing to "codeblocks-head\trunk\src"? Else try changing this "$(#CB.INCLUDE)" to "$(#CB)\include"

My file structure is:
C:\Installed\CodeBlocks\
and inside that is src\, which contains everything i get from the SVN.
So the CodeBlocks source is C:\Installed\CodeBlocks\src\src and the autoversioning plugin is in that + \plugins\contrib\AutoVersioning

I tried both the AutoVersioning and the autoversioning-contrib files, both give the same error.

my cb global variable points to C:\Installed\CodeBlocks\src, but I tried pointing it to C:\Installed\CodeBlocks\src\src, and pointing the include variable to C:\Installed\CodeBlocks\src\src\include

I even tried defining a tinyxml variable pointing directly to the tinyxml folder containing the .h file.

Quote
If the problem keeps on, then try to specified all the steps that you made to compile the plugin, and also the file structure (the routes for the codeblocks sources). Some one else had the same problem I think, what could be :? :?:

I added this to the workspace file:
      <Project filename="plugins\contrib\AutoVersioning\AutoVersioning-Windows.cbp" />
and added the folder to that location (contrib).  I tried this with AutoVersioning and autoversioning-contrib.
And loaded up code blocks.  Tried compiling all workspaces and the autoversioning itself.  Code::Blocks itself and wxWidgets have been compiled successfully(0 errors).