Author Topic: Debugger executable not set problem  (Read 5206 times)

Offline Lord Yu

  • Single posting newcomer
  • *
  • Posts: 3
Debugger executable not set problem
« on: July 30, 2005, 11:22:27 am »
Hi all,

I'm unfamiliar with MinGW debugger   :(  , when I go to debug I get an debugger executable not set error, so I go to the settings/configure plugins/compiler  :?.

If it is a debugging problem should I go to the GDB debugger instead, if so what are the debugging commands?

Thanks

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Debugger executable not set problem
« Reply #1 on: July 30, 2005, 12:00:49 pm »
Go to "Settings->Compiler->Programs" and make sure "Debugger" is set to "gdb.exe".
gdb.exe must exist in the configured "Compiler's installation directory", in the "bin/" subdir.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline Orlando

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Debugger executable not set problem
« Reply #2 on: August 07, 2005, 10:12:48 pm »
Same problem here. The code compiles (MingW) but the debugger claims 'The debuger executable is not set'. Settings are ok (otherwise it wouldn`t compile). Maybe it's a problem specific to Win98.  :? 

Offline squizzz

  • Almost regular
  • **
  • Posts: 132
Re: Debugger executable not set problem
« Reply #3 on: August 08, 2005, 01:47:12 am »
Maybe it has something to do with this:

Note for Win98/ME users:
Debugging with Code::Blocks-MinGW bundle under Windows 98/ME will not work out of the box for you. This is because we 've updated the included GDB to version 6.3 which works on NT-class machines only (NT/2000/XP/2003).
All is not lost however. You can go to the MinGW site and download an older GDB version which works for Windows 98/ME. Code::Blocks will happily use it, as long as you install it in the Code::Blocks installation folder ;)

Do you use C::B with MinGW bundle?
this space is for rent

Offline Orlando

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Debugger executable not set problem
« Reply #4 on: August 08, 2005, 11:27:50 pm »
Maybe it has something to do with this:

Note for Win98/ME users:
Debugging with Code::Blocks-MinGW bundle under Windows 98/ME will not work out of the box for you. This is because we 've updated the included GDB to version 6.3 which works on NT-class machines only (NT/2000/XP/2003).
All is not lost however. You can go to the MinGW site and download an older GDB version which works for Windows 98/ME. Code::Blocks will happily use it, as long as you install it in the Code::Blocks installation folder ;)

Do you use C::B with MinGW bundle?

gdb --v shows:
GNU gdb 5.2.1

Shall I copy gdb.exe to the Code::Blocks installation folder? Sounds strange ... :?

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Debugger executable not set problem
« Reply #5 on: August 08, 2005, 11:36:32 pm »
No, copy gdb.exe where your MinGW installation is (this is, replace the gdb.exe with your own copy)

Offline Orlando

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Debugger executable not set problem
« Reply #6 on: August 09, 2005, 12:05:28 am »
No, copy gdb.exe where your MinGW installation is (this is, replace the gdb.exe with your own copy)

That's what I have now. MinGW\bin contains both
mingw32-c++.exe (3.4.2)
gdb.exe              ( 5.2.1)

Code compiles but the debugger doesn't start (see above). It seems that the path to gdb.exe is not set correctly although it's dieplayed correctly in the configuration dialog. Can I enter the path to the debugger manually in a config file?


Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Debugger executable not set problem
« Reply #7 on: August 09, 2005, 01:51:03 am »
I see...

I think it's got to do with the configuration. I'll research more about it, maybe you found a bug.

In the meantime, add the (path to your MINGW)\bin in "My PC", right click, Properties, advanced options, environment variables, system variables, PATH. (Separate with semicolons).

Offline Orlando

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Debugger executable not set problem
« Reply #8 on: August 12, 2005, 04:09:55 pm »
I think it's got to do with the configuration. I'll research more about it, maybe you found a bug.

Another observation:
1. Clean the project manually
2. Open CB and open a Project
3. Press button 'Run' (without compiling before)
4. Message Box Error "Can't find comiler executable in your search path for GNU GCC compiler"
5. Press 'ok'
6. Message Box Information "It seems that this project has not been built yet. Do you want to build in now?"
7. Press 'yes'
8. Compiling ....