Author Topic: Version 1.0-RC1 released!  (Read 41547 times)

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Version 1.0-RC1 released!
« on: July 25, 2005, 10:52:19 pm »
After quite some time (2+ months) since the last release, we 're happy to announce the availability of version 1.0-ReleaseCandidate1!
Many enhancements and bug-fixes are contained in this release.

Here are the major changes since 1.0-FinalBeta:
  • Compiler support for OpenWatcom
  • Environment variables can be set per target/project or globally. Can be used anywhere in the build process (include dirs, link dirs, output filenames, etc).
  • Improved gcc warnings/errors parsing (thanks to tiwag).
  • Various configuration enhancements.
  • Auto-hide function for message pane.
  • Editors are now notebook pages (bye-bye MDI).
  • Convenient "Start here" page with links to common tasks.
  • Find in files :)
  • Ability to add files to project recursively.
  • External dependencies can be checked against additional files (specified by user), instead of only with target's output file (very usefull for commands-only targets).
  • Optional single-instance check.
  • Fixes in Dev-C++ project files import.
  • Fixes in MSVC project files import.
  • Editor smart as-you-type indentation (auto-indent when opening/closing brace).
  • Syntax highlighting support moved to files. Currently supported are:

   - C/C++
   - Windows resources
   - HTML/XML/XSL (by rickg22)
   - Lua scripts
   - GameMonkey scripts
   - Hitach H8 ASM (by tiwag)
  User can add easily support for more languages (guide will be posted soon).
  • Many GDB debugger updates (most by kjliew)

   - GDB breakpoints on constructrs/destructors
   - Step-into can start debugging session
   - Step-out function to continue until the end of the current block {}.
  • Workspace tree now keeps its state after rebuilding.
  • Updated AStyle plugin to use astyle-1.17.0-dev (by ceniza).
  • Comment/uncomment/toggle are now 3 separate functions.
  • New project template for QT4.
  • New project template for Ogre3D.
  • Single file compile (not belonging to a project).
  • DevPaks support.

We hope you enjoy this release!

On behalf of the Code::Blocks Team,
Yiannis.
« Last Edit: July 25, 2005, 11:21:04 pm by mandrav »
Be patient!
This bug will be fixed soon...

Offline Insubordinate

  • Multiple posting newcomer
  • *
  • Posts: 12
    • Dunghill Entertainment
Re: Version 1.0-RC1 released!
« Reply #1 on: July 25, 2005, 11:35:09 pm »
Congratulations!

> Auto-hide function for message pane.

Yay! It's the first time I've tried asking for a feature in an open source program (or any program for that matter)
and here it is! What a nice feeling it gives.

>  Editor smart as-you-type indentation (auto-indent when opening/closing brace).

This one I forgot how I much I missed from VC.

Thanks a bunch, your work is greatly appreciated.
Hope I'll be able to contribute some time.

And I must say, this new forum is a joy to use.

Offline kagerato

  • Multiple posting newcomer
  • *
  • Posts: 56
    • kagerato.net
Re: Version 1.0-RC1 released!
« Reply #2 on: July 25, 2005, 11:54:56 pm »
I noticed the core binaries (codeblocks.exe and codeblocks.dll) in this release are more than twice the size of Ceniza's snapshot from a few days ago.  My guess was that they're compiled with debugging symbols, and some poking around with my hex editor seems to confirm that.

Did you build these as debugging intentionally, as habit, or something else?

In any case, it's great to see a new "official" release.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Version 1.0-RC1 released!
« Reply #3 on: July 25, 2005, 11:58:33 pm »
I noticed the core binaries (codeblocks.exe and codeblocks.dll) in this release are more than twice the size of Ceniza's snapshot from a few days ago.  My guess was that they're compiled with debugging symbols, and some poking around with my hex editor seems to confirm that.

Until 1.0 is finalized, we don't build optimized versions.
Also, ceniza's binaries are UPX'd IIRC.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Re: Version 1.0-RC1 released!
« Reply #4 on: July 26, 2005, 12:51:38 am »
Wow....great :)
Tabbed editing, auto-indentation, find in files and auto-hide for the message pane all are features I thought they were missing, I see that we share the same ideas :)

Offline darklordsatan

  • Almost regular
  • **
  • Posts: 132
    • http://eviltrend.sf.net
Re: Version 1.0-RC1 released!
« Reply #5 on: July 26, 2005, 01:31:16 am »
  • Single file compile (not belonging to a project).

Glad to see it made it.
Thanks a lot Yiannis, looking better everyday. Downloading as I type!

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Re: Version 1.0-RC1 released!
« Reply #6 on: July 26, 2005, 02:22:13 am »
It seems you forgot to put the sources in the .tar.gz package...
I was trying to compile under Linux when I got a...problem ^^

I will try using CVS...

Offline ironhead

  • Almost regular
  • **
  • Posts: 210
Re: Version 1.0-RC1 released!
« Reply #7 on: July 26, 2005, 02:24:17 am »
Excellent release guys!

Offline darklordsatan

  • Almost regular
  • **
  • Posts: 132
    • http://eviltrend.sf.net
Re: Version 1.0-RC1 released!
« Reply #8 on: July 26, 2005, 03:00:15 am »
It seems you forgot to put the sources in the .tar.gz package...
I was trying to compile under Linux when I got a...problem ^^

I just got a corrupted .tgz. Does anyone else can confirm this?

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Re: Version 1.0-RC1 released!
« Reply #9 on: July 26, 2005, 03:30:40 am »
Pff, in order to compile under Linux it's a real fight...

First, we have to use wx 2.4, since there is no Unicode support, and since wx 2.6 MUST have Unicode suppor. Ok.
Then, wx 2.4 MUST use GTK2. Ok. 10 min tu compile, having to fight with ldconfig and /usr/local/lib, I just discovered what is /etc/ld.so.conf.
The Wiki talks about a "patch" to wxGTK2; should I apply it to my freshly downloaded wxWidgets tarball? I don't know, I'm trying without this.

But the main problem is wxDockIt; the last release, which has just gone out on the 24th of July, requires at least wx2.5 ! Why am I trying to compile wxDockIt myself?  Because the included Makefile.unix in Code::Blocks's distribution doesn't compile it :( And there is no Makefile to compile it, neither with the wxDockIt distributed with Code::Blocks, nor with the official old distribution. So I tried to create my own SConstruct file (Cf SCons) to compile it, and there are errors, and errors...
I simply don't understand how a code like this could compile (from wxSockIt's dockwindow_gtk.cpp):
Code: [Select]
void wxDockWindow::addBorder() {

    // move the windows contents in by an amount

    wxSizer * sizer = GetSizer();

    wxSizerItemList& sizerList = sizer->GetChildren();

    wxwxSizerItemListNode * pNode = sizerList.GetFirst();

    wxASSERT(pNode);

    wxSizerItem * pSizerItem = pNode->GetData();

    wxASSERT(pSizerItem);

    pSizerItem->SetBorder( BORDER_SIZE );

    pSizerItem->SetFlag( pSizerItem->GetFlag() | wxALL );

    Layout();

}

I wish the Linux installation procedure is simplified in the next release, because it's nearly impossible for a poor human guy to make it work :(
« Last Edit: July 26, 2005, 03:35:35 am by Funto »

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Version 1.0-RC1 released!
« Reply #10 on: July 26, 2005, 04:22:07 am »
ARGH!

Yup, seems the .tar.gz is corrupted. You know, I think it's time to add some quality control over here. I say Yiannis give us the link to the files and we test them. Only with approval of at least 2 people he'll release the files. What do you say?

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Version 1.0-RC1 released!
« Reply #11 on: July 26, 2005, 04:34:15 am »
I dropped the sources from the homepage (don't have sourceforge access, tho). Later we can find out what went wrong.

UPDATE: The following are the MD5 checksums that Yiannis applied on the files on his computer:

CodeBlocks-1.0-RC1.exe - 1156b82a5b855a8000e72bbf977c2458
CodeBlocks-1.0-RC1_MinGW.exe - e9902ca3c900969c31b0999d61bbef88

codeblocks-1.0-RC1.tar.gz - 77a8ce9e8dd5c770cbd35031917a02c4
codeblocks-1.0-RC1_sdk.tar.gz - 435548642c41c65c61f0d557774d23a6

It appears that the checksums of the files in sourceforge ARE WRONG. PLEASE CHECK the md5 checksums on your downloads.
« Last Edit: July 26, 2005, 04:55:56 am by rickg22 »

Offline darklordsatan

  • Almost regular
  • **
  • Posts: 132
    • http://eviltrend.sf.net
Re: Version 1.0-RC1 released!
« Reply #12 on: July 26, 2005, 04:46:40 am »
I say Yiannis give us the link to the files and we test them. Only with approval of at least 2 people he'll release the files. What do you say?

Agreed. Personally, it aint a big deal, but for some newcomer that downloads the file to find out its corrupted (and then probably downloads it again), its sort of a turn off.

Quote from: Simplemachines
Warning - while you were typing a new reply has been posted. You may wish to review your post.
Hehe, cool!

I dropped the sources from the homepage (don't have sourceforge access, tho). Later we can find out what went wrong.
Do you reffer to the fact sf is down ATM, or that you arent allowed to upload/delete/modify file releases in the project (I guess its not the case)

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Version 1.0-RC1 released!
« Reply #13 on: July 26, 2005, 05:04:05 am »
7E9A86642D41FAEC9E1A92D9C8794A98  codeblocks-1.0-rc1.tar.gz <- this is the one I downloaded. The MD5 should be 77a8ce9e8dd5c770cbd35031917a02c4. IT DOESN'T MATCH! :shock:

Must be some problem at sourceforge.

About sourceforge, i meant to say that _I_ haven't been given sourceforge access. Oh well.
« Last Edit: July 26, 2005, 05:33:08 am by rickg22 »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Version 1.0-RC1 released!
« Reply #14 on: July 26, 2005, 09:06:26 am »
Sorry about the corrupt source package guys. I got disconnected at some point of the file transfer and it seems that was the problem. I 'll upload the package again.

The Wiki talks about a "patch" to wxGTK2; should I apply it to my freshly downloaded wxWidgets tarball? I don't know, I'm trying without this.

No you shouldn't needed it for Ubuntu.

But the main problem is wxDockIt;

To build CVS HEAD, you should use Makefile.unix.wx2.6. But then again, it's got some problems still and doesn't actually work :cry:
As mentioned elsewhere, my suggestion for linux currently is wxGTK-2.4.2 with CVS VERSION_1_0 branch (that's what's included in the source package).

I wish the Linux installation procedure is simplified in the next release, because it's nearly impossible for a poor human guy to make it work :(

Me too...
Don't worry, we 'll reach there at some point ;)

Yiannis.
Be patient!
This bug will be fixed soon...