Author Topic: The 21 May 2007 build is out.  (Read 30327 times)

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: The 21 May 2007 build is out.
« Reply #15 on: May 22, 2007, 06:07:59 pm »
I had the same problem with the build. Already filed it as Bug #11144.
That's not the same problem. Rick: You still have old plugin DLL's in your C::B plugin folder. Notice that these plugin have been renamed as:
debuggergdb --> debugger
compilergcc --> compiler
pluginwizard --> scriptedwizard.
Thus you only need to cleanup your C::B folder. I've closed the bug report accordingly.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: The 21 May 2007 build is out.
« Reply #16 on: May 22, 2007, 06:15:34 pm »
Ugh, does that mean i have to reinstall the sourcecode and compile from scratch? :(

OK then.  :lol:

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 21 May 2007 build is out.
« Reply #17 on: May 22, 2007, 06:24:41 pm »
No no no, I hope, you haven't done it. Anyway, it won't fix the libwxsmithlib.zip problem (and other presented here).

The easiest way is to completily remove c::b from system just before make install because there are some rubbish left causing this bug. Since make uninstall won't be usefull here too, it should be done manually.

BYO

Offline lubos

  • Almost regular
  • **
  • Posts: 131
Re: The 21 May 2007 build is out.
« Reply #18 on: May 22, 2007, 06:53:05 pm »
i exited cb normally, then started it again and it asked me to select compiler..WTF??? all my settings was removed... the only luck i had a copy of them because i was copying codeblocks to another computer(with settings from "documents and settings") however when i replaced settings with my saved ones and exited again, all was ok... im afraid to use codeblocks sometimes lol

Offline Roman

  • Multiple posting newcomer
  • *
  • Posts: 78
BUG?
« Reply #19 on: May 22, 2007, 08:56:29 pm »
Hi there!

The "debugging windows" button on debug panel does not work for me. The "Debug/debugging windows" menu entry works.
21 may win32 build

Regards
Roman

[attachment deleted by admin]
CB LSI (C::B as a Little Secret Initiative)

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 21 May 2007 build is out.
« Reply #20 on: May 22, 2007, 09:09:00 pm »
The "debugging windows" button on debug panel does not work for me. The "Debug/debugging windows" menu entry works.
21 may win32 build

Are you using wx-2.8.3 runtime dll? This issue has been fixed with wx 2.8.4 runtime dll.
Be a part of the solution, not a part of the problem.

Offline Roman

  • Multiple posting newcomer
  • *
  • Posts: 78
Re: The 21 May 2007 build is out.
« Reply #21 on: May 22, 2007, 09:15:49 pm »
Thx
CB LSI (C::B as a Little Secret Initiative)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 21 May 2007 build is out.
« Reply #22 on: May 22, 2007, 09:47:25 pm »
No no no, I hope, you haven't done it. Anyway, it won't fix the libwxsmithlib.zip problem (and other presented here).

The easiest way is to completily remove c::b from system just before make install because there are some rubbish left causing this bug. Since make uninstall won't be usefull here too, it should be done manually.

BYO
can you tell us which part we should manually delete ??

otherwise it means getting sources fresh from svn ??

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 21 May 2007 build is out.
« Reply #23 on: May 22, 2007, 10:15:08 pm »
No no no, I hope, you haven't done it. Anyway, it won't fix the libwxsmithlib.zip problem (and other presented here).

The easiest way is to completily remove c::b from system just before make install because there are some rubbish left causing this bug. Since make uninstall won't be usefull here too, it should be done manually.

BYO
can you tell us which part we should manually delete ??

otherwise it means getting sources fresh from svn ??

No, it's not about invalid sources but about files installed on system during make install. Sources are OK.

In some buggy revision, make install installed   /usr/local/share/codeblocks/plugins/libwxsmithlib.la / .so, but it should be put into /usr/local/lib/libwxsmithlib.la / .so.

Now makefiles are correct, so while make install libwxsmithlib.so is put into right location, but the old one (in  plugins directory) may still exists and that one should be removed.

Refetching source tree and rebuilding won't help here because that incorrect file will still be in directory  where plugins are put after instalation.

Code: [Select]
rm /usr/local/share/codeblocks/plugins/libwxsmithlib.*- that should fix this issue, but just to prevent such bugs for other plugins it could be better to
Code: [Select]
rm -rf /usr/local/share/codeblocksjust before make install so that all shared C::B stuff is deleted with all rubbish that could be accidentially put there.

Hope that this is clear  :)

BYO

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 21 May 2007 build is out.
« Reply #24 on: May 22, 2007, 10:32:22 pm »
thx byo, very clear. Problem solved for me ;-)

that remove all could be very interesting indeed just before make install : @Yiannis : what do you think ?

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 21 May 2007 build is out.
« Reply #25 on: May 22, 2007, 11:17:01 pm »
"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"
running Ubuntu Feisty 7.04

Confirmed. I'll look into it today. Strange it looks like wx 2.8.4 causes this to happen. But after I've checked what's the missing symbol, it's some internal data of wxChartCtrl  :?

Thanks for reporting

BYO

Jay, that's a nightmare :x. Missing symbol is _ZVT16wxPieChartPoints or _ZVT18wxBar3DChartPoints and surely many others would fit here, I don't know how it's choosen.

Because of _ZVT prefix I conclude that it's missing virtual funciton table. But since classes are correct (otherwise it woudn't compile ANY time), those tables should be fine  :? anybody has any experience with this stuff ? Maybe it's GCC's bug ?

Anyone

jmanson

  • Guest
Re: The 21 May 2007 build is out.
« Reply #26 on: May 23, 2007, 05:37:15 am »
Hello, I have Installed the Debian package on Feisty 7.04 and am trying to use the Digital Mars D compiler on the default D application project. However, Code::Blocks is unable to find my compiler although it is installed. The error message is as follows. I tried to find the settings for the compiler, but was unable to confirm what executable CB is trying to run.

"cbtest - Debug" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...
Nothing to be done.

jmanson

  • Guest
Re: The 21 May 2007 build is out.
« Reply #27 on: May 23, 2007, 05:50:27 am »
I got it working. Sorry for bothering you all.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 21 May 2007 build is out.
« Reply #28 on: May 23, 2007, 09:04:59 am »
that remove all could be very interesting indeed just before make install : @Yiannis : what do you think ?

Unfortunately there are not many things we can do about it...

Jay, that's a nightmare :x. Missing symbol is _ZVT16wxPieChartPoints or _ZVT18wxBar3DChartPoints and surely many others would fit here, I don't know how it's choosen.

Because of _ZVT prefix I conclude that it's missing virtual funciton table. But since classes are correct (otherwise it woudn't compile ANY time), those tables should be fine  :? anybody has any experience with this stuff ? Maybe it's GCC's bug ?

The problem is not that it's about a virtual function but probably because of the size of the arguments (sizeof)...
I don't have the time to look into it atm but check what args these functions take. If the number of args is different between versions or the args themselves are different, then this could be the problem.
Be patient!
This bug will be fixed soon...

Offline Miq

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 21 May 2007 build is out.
« Reply #29 on: May 25, 2007, 02:45:50 pm »
Hello, I've uploaded a portable version here.
Thank you MVP for the space! :D ...
Thank you, dear Code::Blocks team, for the best IDE ever :D
@wxLearner: do you see any possibility you could that excellent job again, this time with a more recent gcc? I'd rather like 4.2 in there... ;)