Author Topic: The 18 May 2007 build is out.  (Read 7730 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5241
The 18 May 2007 build is out.
« on: May 18, 2007, 09:01:23 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx284.7z


For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 18 May 2007 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20070518_rev3970_win32.7z
  - Linux :
   http://prdownload.berlios.de/codeblocks/CB_20070518_rev3970_Ubuntu6.10+7.04.deb (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070518_rev3970_suse100-102.i586.rpm (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070518_rev3970_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • same as yesterday but using wx2.8.4 (for wx dll : see above)

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)


Offline blend

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: The 18 May 2007 build is out.
« Reply #1 on: May 18, 2007, 10:07:20 pm »
I have the same bug as yesterday: after I clicked on the message toolbar items, C::B froze all Ubuntu :|. Is it a wxWidgets bug?

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1441
    • CenizaSOFT
Re: The 18 May 2007 build is out.
« Reply #2 on: May 18, 2007, 10:24:17 pm »
The word "toolbar" is a bit confusing there, but if it's what I think, could you please tell us if the mouse pointer changes when your Linux freezes? If that happens, then it'd be the evil drag&drop bug, which seems to be a bug in GTK.

Offline blend

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: The 18 May 2007 build is out.
« Reply #3 on: May 19, 2007, 07:47:53 am »
Yes the cursor changes and then it freezes all my Ubuntu :| : it seems be a drag&drop bug.
« Last Edit: May 19, 2007, 07:51:18 am by blend »

Offline kurapix

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: The 18 May 2007 build is out.
« Reply #4 on: May 19, 2007, 09:28:43 am »
Yeah I confirm the bug, the cursor is a cross with a half square.
I use wxwidget 2.6.3.

On Feisty the wxwidget is 2.6.3 or 2.8.1, I guess that someone should try to package the latest 2.6.x and 2.8.x builds (I'll try when I'll have more time, not now).

Kurapix
Code::Blocks package building script

Offline kai

  • Multiple posting newcomer
  • *
  • Posts: 25
Re: The 18 May 2007 build is out.
« Reply #5 on: May 19, 2007, 02:48:54 pm »

the drag&drop freezing is a known bug in wxGTK <= 2.6.3. it is fixed in the 2.8 series

OrangeCoder

  • Guest
Re: The 18 May 2007 build is out.
« Reply #6 on: May 19, 2007, 11:42:11 pm »
After Using The RC2 for a few days, I decided to install the last nightly build release of CB.
Followed the instructions as described in the forum (also read the wiki)
- uninstalled the RC2
- Installed Mingw in E:\Mingw (with the mingw-5.1.3.exe installer) (E: is my winxp disk)
- Also installed gdb in E:\Mingw ( gdb-6.3.2.exe installer)
- unpacked the latest nightly archive in E:\Codeblocks
- unpacked both wxmsw28u_gcc_cb.dll & mingwm10.dll files in E:\CODEBLOCKS
- Updated PATH (SET PATH=%PATH%;E:\CODEBLOCKS;E:\MINGW\BIN;E:\MINGW\MINGW32\BIN)

But when running codeblocks.exe it gave me this strange message:
"cannot find ressources
 Code::Blocks was configured to be installed in 'E:\Codeblocks/share/codeblocks' etc..."


Added the CODEBLOCKS_DATA_DIR=E:\CODEBLOCKS variable
or used the --prefix=E:\Codeblocks command line option
but the error message remained

wonder if i missed something... :?
Any Idea welcomed...


[attachment deleted by admin]

OrangeCoder

  • Guest
Re: The 18 May 2007 build is out.
« Reply #7 on: May 20, 2007, 01:18:23 am »
 :lol:
Finally found it...!
Used an old Izarc Beta (3.5) to extract the .7z archive ('partial' extraction bugs reported on some archives)
so some files were lacking in the share directory
updated to 3.7 and everything seems OK now

sorry for the post  :oops:
« Last Edit: May 20, 2007, 01:20:07 am by OrangeCoder »