Author Topic: The 02 May 2007 build is out.  (Read 6664 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 02 May 2007 build is out.
« on: May 02, 2007, 08:54:50 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx283.7z


For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 02 May 2007 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20070502_rev3918_win32.7z
  - Linux :
   http://prdownload.berlios.de/codeblocks/CB_20070502_rev3918_Ubuntu6.xx.deb (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070502_rev3918_suse100-102.i586.rpm
   http://prdownload.berlios.de/codeblocks/CB_20070502_rev3918_fc4+5.i586.rpm

Resolved Fixed:

  • A minor update to wxWidgets wizard's multiple library selection page
  • EnvVars plugin: fixed a bug not to be able to set envvars containing semi-colons
  • cb_share_config: Added ablity to export specific C::B config nodes only to a backup file

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)

« Last Edit: May 03, 2007, 08:08:28 am by killerbot »

Offline Xaviou

  • Regular
  • ***
  • Posts: 302
    • X@v's wxStuff
Re: The 02 May 2007 build is out.
« Reply #1 on: May 02, 2007, 09:51:15 pm »
Ubuntu 6.10 & 7.04 Amd64 .deb installer can be found here.
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: The 02 May 2007 build is out.
« Reply #2 on: May 03, 2007, 04:00:31 am »

Fresh install of Ubuntu 7.04 - and a SVN of

Code: [Select]
[email protected]:~/codeBlocksSVN/trunk$ svn update
At revision 3921.

Code: [Select]
g++ -DHAVE_CONFIG_H -I. -I. -I../../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DNO_GCC_PRAGMA -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I../../../../src/include -I../../../../src/include/wxscintilla/include -I../../../../src/include/wxFlatNotebook/include -Ulinux -Uunix -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT editsnippetframe.lo -MD -MP -MF .deps/editsnippetframe.Tpo -c editsnippetframe.cpp  -fPIC -DPIC -o .libs/editsnippetframe.o
editsnippetframe.cpp: In constructor 'EditSnippetFrame::EditSnippetFrame(wxTreeItemId, int*)':
editsnippetframe.cpp:237: error: invalid use of undefined type 'struct _GtkWidget'
/usr/include/wx-2.6/wx/defs.h:2777: error: forward declaration of 'struct _GtkWidget'
make[5]: *** [editsnippetframe.lo] Error 1
make[5]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib/codesnippets'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib/codesnippets'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src'
make: *** [all-recursive] Error 1

Any ideas on how to fix this?

Thanks

Offline kurapix

  • Multiple posting newcomer
  • *
  • Posts: 68
Re: The 02 May 2007 build is out.
« Reply #3 on: May 03, 2007, 06:44:11 am »
Ubuntu 7.04 build here.

It's my first package making, so be nice.
This package should work.

Kurapix
Code::Blocks package building script

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2180
Re: The 02 May 2007 build is out.
« Reply #4 on: May 03, 2007, 01:39:54 pm »

Fresh install of Ubuntu 7.04 - and a SVN of

Code: [Select]
[email protected]:~/codeBlocksSVN/trunk$ svn update
At revision 3921.

Code: [Select]
g++ -DHAVE_CONFIG_H -I. -I. -I../../../../src/include -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -DNO_GCC_PRAGMA -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I../../../../src/include -I../../../../src/include/wxscintilla/include -I../../../../src/include/wxFlatNotebook/include -Ulinux -Uunix -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -MT editsnippetframe.lo -MD -MP -MF .deps/editsnippetframe.Tpo -c editsnippetframe.cpp  -fPIC -DPIC -o .libs/editsnippetframe.o
editsnippetframe.cpp: In constructor 'EditSnippetFrame::EditSnippetFrame(wxTreeItemId, int*)':
editsnippetframe.cpp:237: error: invalid use of undefined type 'struct _GtkWidget'
/usr/include/wx-2.6/wx/defs.h:2777: error: forward declaration of 'struct _GtkWidget'
make[5]: *** [editsnippetframe.lo] Error 1
make[5]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib/codesnippets'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib/codesnippets'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins/contrib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dberry/codeBlocksSVN/trunk/src'
make: *** [all-recursive] Error 1

Any ideas on how to fix this?

Thanks


That code shouldn't be there. My fault.
It was an experiment on Linux that I forgot to take out when I commited from windows.

Just change the one __WXGTK__ to __OLD_FART_CANT_GET_IT_RIGHT__ and it'll work.

Fixed: SVN 3922
« Last Edit: May 03, 2007, 01:44:48 pm by Pecan »