Author Topic: C::B build problem with wxGTK-2.8.3  (Read 10415 times)

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
C::B build problem with wxGTK-2.8.3
« on: April 30, 2007, 03:59:58 am »
I can build and install fine, but the libcompiler plugin is hanging c::b at startup. (I remove from the plugins dir and it works fine)  I am not sure what is causing this problem.  Any ideas where to start ?

AND libwxsmithcontribitems is failing to load as well.

Any thoughts or direction.  Thanks.

Quote
wxGTK 2.8.3
Debian 4.0
GTK 2.10.6
C::B SVN 3898 with patches

Thanks ;)
« Last Edit: April 30, 2007, 04:07:27 am by diilbert »

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #1 on: April 30, 2007, 11:13:38 pm »
Any thoughts or suggestions ?

Offline SharkCZ

  • Almost regular
  • **
  • Posts: 127
Re: C::B build problem with wxGTK-2.8.3
« Reply #2 on: May 01, 2007, 04:37:57 pm »
I am seeing the same behaviour :-( But no idea how to solve it.
Code::Blocks package maintainer for Fedora and EPEL

Offline dk

  • Multiple posting newcomer
  • *
  • Posts: 55
    • Code::Blocks for ALT Linux Sisyphus
Re: C::B build problem with wxGTK-2.8.3
« Reply #3 on: May 01, 2007, 04:54:21 pm »
I have the same problems when building revision 3910 with wxGTK 2.8.3.
wxGTK 2.6.3 build is OK.

OS: ALT Linux Sisyphus, x86_64.
« Last Edit: May 01, 2007, 05:19:05 pm by dkirienko »
Denis Kirienko
C::B maintainer for ALT Linux distribution (http://www.sisyphus.ru/srpm/codeblocks)

Offline jarro_2783

  • Multiple posting newcomer
  • *
  • Posts: 99
    • Project Freedom
Re: C::B build problem with wxGTK-2.8.3
« Reply #4 on: May 04, 2007, 01:49:30 pm »
I have the same problem, up to revision 3930 now.
Not much use without the compiler since I can't compile anything...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #5 on: May 04, 2007, 02:25:38 pm »
As a note, I have also seen the same behaviour with wx2.8.3.
BUT it works fine with wx2.8.0.

I don't really know what's wrong. I tried to debug this and it seems it enters an infinite loop trying to get the build toolbar's combo box size.
Anyway, this might be very remotely related to wxAUI (we 're still using our bundled version of it). Just earlier I committed a related change though, so that the wxAUI from wx is used if found. Have a try with the current svn and see if this helps...
Be patient!
This bug will be fixed soon...

Offline jarro_2783

  • Multiple posting newcomer
  • *
  • Posts: 99
    • Project Freedom
Re: C::B build problem with wxGTK-2.8.3
« Reply #6 on: May 05, 2007, 02:27:39 am »
it still does it.

they're the worst bugs aren't they, something that's related to something someone else wrote and not necessarily your bug.
« Last Edit: May 05, 2007, 02:31:41 am by jarro_2783 »

Offline Vladsharp

  • Multiple posting newcomer
  • *
  • Posts: 14
    • Vladsharp.com - The Crests of Reason
Re: C::B build problem with wxGTK-2.8.3
« Reply #7 on: May 07, 2007, 10:44:30 am »
Can confirm this with r3938 as well. Using wxPython 2.8.3.0 on Gentoo (gcc-4.1.2-r2 hardened).

Good luck with fixing it!
Vladsharp.com - The Crests of Reason

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #8 on: May 10, 2007, 11:50:38 am »
Still doing it on 3949.  Is there anything debugging wise I can do to help you guys figure this out ?

Also I am not sure how to report the actually submit a report to the bug tracker since it is asking for a username/password.

Thanks.

Diilbert

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #9 on: May 10, 2007, 12:35:09 pm »
Still doing it on 3949.  Is there anything debugging wise I can do to help you guys figure this out ?

The fact that this works in all configurations except Linux/wxGTK-2.8.3, it indicates it's a bug somewhere in wxGTK code (like the infinite loop is in wxGTK code too). If I am not mistaken, this bug doesn't happen with wxGTK-2.8.4 (or so I 've been told). So anyone who could try and verify this?
Be patient!
This bug will be fixed soon...

Offline dave.berk

  • Single posting newcomer
  • *
  • Posts: 8
Re: C::B build problem with wxGTK-2.8.3
« Reply #10 on: May 10, 2007, 01:30:58 pm »
Just compiled the latest SVN. I have the same problem. Using ubuntu feisty. CB get stuck on showing the tool tip and the main screen and I have to kill it to get back to x.

Offline Deschamps

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: C::B build problem with wxGTK-2.8.3
« Reply #11 on: May 10, 2007, 01:37:58 pm »
Quote from: dave.berk
Just compiled the latest SVN. I have the same problem (..)

Against wxGTK-2.8.4-RC2 ?
Misquotations are the only quotations that are never misquoted

Offline SharkCZ

  • Almost regular
  • **
  • Posts: 127
Re: C::B build problem with wxGTK-2.8.3
« Reply #12 on: May 10, 2007, 04:06:45 pm »
From the wxGTK ChangeLog for 2.8.4
- Fix infinite loop when adding a wxStaticText control to a toolbar
Code::Blocks package maintainer for Fedora and EPEL

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #13 on: May 10, 2007, 05:51:12 pm »
From the wxGTK ChangeLog for 2.8.4
- Fix infinite loop when adding a wxStaticText control to a toolbar


So it seems what I 've been told was correct. Thanks for the info SharkCZ.
Be patient!
This bug will be fixed soon...

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #14 on: May 11, 2007, 03:50:12 am »
Where do I get wxGTK 2.8.4 from ?  I can't find it anyway.  I have tried the SVN version, but that does not compile at all.

Thanks ;)