Author Topic: C::B build problem with wxGTK-2.8.3  (Read 10600 times)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6666
    • My Best Post
Re: C::B build problem with wxGTK-2.8.3
« Reply #15 on: May 11, 2007, 05:04:20 am »
Where do I get wxGTK 2.8.4 from ?  I can't find it anyway.  I have tried the SVN version, but that does not compile at all.

Thanks ;)

Linux Users try
ftp://biolpc22.york.ac.uk/pub/2.8.4-rc2
I would suggest
ftp://biolpc22.york.ac.uk/pub/2.8.4-rc2/wxGTK-2.8.4-rc2.tar.bz2
Note: rc2 was broken for windows users.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #16 on: May 11, 2007, 11:25:30 am »
How did you find that ?  Considering it is not published on the wxWidgets website.   Just for future reference.

Thanks

Offline Deschamps

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: C::B build problem with wxGTK-2.8.3
« Reply #17 on: May 11, 2007, 02:48:38 pm »
Quote from: diilbert
How did you find that ?  Considering it is not published on the wxWidgets website.   Just for future reference.

It's the "official" wxWidgets snapshots repository that you find behind the "Daily Snapshot" link at the bottom of the http://www.wxwidgets.org/downloads/ webpage, i.e.: http://wxwindows.sourceforge.net/snapshots/ that redirects to that site, and then, going to "parent directory".

You'll find also this link at the "wxWidgets Mirror Sites" page, so don't be afraid, cos has been published on the wxWidgets site :)


« Last Edit: May 11, 2007, 04:08:40 pm by Deschamps »
Misquotations are the only quotations that are never misquoted

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #18 on: May 13, 2007, 03:13:18 am »
After building with wxGTK-2.8.4-rc2 (and several bugs in wx) I was able to get code::blocks to load, with the following errors:

Code: [Select]
---CUT---
[22:09:10.509]: ERROR: /usr/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
---CUT---
[22:09:16.235]: Initializing plugins...
[22:09:16.330]: KeyBinder failed UpdateById on[1621][Compiler]
[22:09:16.334]: KeyBinder failed UpdateById on[1303][Build options...]
[22:09:16.336]: KeyBinder failed UpdateById on[1300][_Build]
[22:09:16.338]: KeyBinder failed UpdateById on[1308][Compile current _file]
[22:09:16.341]: KeyBinder failed UpdateById on[1320][_Run]
[22:09:16.343]: KeyBinder failed UpdateById on[1319][Bui_ld and run]
[22:09:16.345]: KeyBinder failed UpdateById on[1310][Rebuil_d]
[22:09:16.347]: KeyBinder failed UpdateById on[1315][_Clean]
[22:09:16.349]: KeyBinder failed UpdateById on[1313][Build _workspace]
[22:09:16.351]: KeyBinder failed UpdateById on[1314][Reb_uild workspace]
[22:09:16.353]: KeyBinder failed UpdateById on[1316][Clean workspace]
[22:09:16.355]: KeyBinder failed UpdateById on[1321][_Abort]
[22:09:16.357]: KeyBinder failed UpdateById on[1324][_Previous error]
[22:09:16.359]: KeyBinder failed UpdateById on[1323][_Next error]
[22:09:16.361]: KeyBinder failed UpdateById on[1325][_Clear all errors]
[22:09:16.364]: KeyBinder failed UpdateById on[1620][_Errors]
[22:09:16.365]: KeyBinder failed UpdateById on[1322][Select target]
[22:09:16.368]: KeyBinder failed UpdateById on[1326][E_xport Makefile]
[22:09:16.372]: KeyBinder failed UpdateById on[1619][Compiler...]

On with the show.  This is a wxSmithContrib problem, and I am not sure where to start.

Although C::B is now usable so it is not that big of a deal.
Still only using SVN 3949

Diilbert

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2178
Re: C::B build problem with wxGTK-2.8.3
« Reply #19 on: May 13, 2007, 04:30:28 am »
After building with wxGTK-2.8.4-rc2 (and several bugs in wx) I was able to get code::blocks to load, with the following errors:

Code: [Select]
---CUT---
[22:09:10.509]: ERROR: /usr/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
---CUT---
[22:09:16.235]: Initializing plugins...
[22:09:16.330]: KeyBinder failed UpdateById on[1621][Compiler]
[22:09:16.334]: KeyBinder failed UpdateById on[1303][Build options...]
[22:09:16.336]: KeyBinder failed UpdateById on[1300][_Build]
[22:09:16.338]: KeyBinder failed UpdateById on[1308][Compile current _file]
[22:09:16.341]: KeyBinder failed UpdateById on[1320][_Run]
[22:09:16.343]: KeyBinder failed UpdateById on[1319][Bui_ld and run]
[22:09:16.345]: KeyBinder failed UpdateById on[1310][Rebuil_d]
[22:09:16.347]: KeyBinder failed UpdateById on[1315][_Clean]
[22:09:16.349]: KeyBinder failed UpdateById on[1313][Build _workspace]
[22:09:16.351]: KeyBinder failed UpdateById on[1314][Reb_uild workspace]
[22:09:16.353]: KeyBinder failed UpdateById on[1316][Clean workspace]
[22:09:16.355]: KeyBinder failed UpdateById on[1321][_Abort]
[22:09:16.357]: KeyBinder failed UpdateById on[1324][_Previous error]
[22:09:16.359]: KeyBinder failed UpdateById on[1323][_Next error]
[22:09:16.361]: KeyBinder failed UpdateById on[1325][_Clear all errors]
[22:09:16.364]: KeyBinder failed UpdateById on[1620][_Errors]
[22:09:16.365]: KeyBinder failed UpdateById on[1322][Select target]
[22:09:16.368]: KeyBinder failed UpdateById on[1326][E_xport Makefile]
[22:09:16.372]: KeyBinder failed UpdateById on[1619][Compiler...]

On with the show.  This is a wxSmithContrib problem, and I am not sure where to start.

Although C::B is now usable so it is not that big of a deal.
Still only using SVN 3949

Diilbert

The KeyBinder messages just means that you should really delete your cbKeybinder10.ini file in the .codeblocks directory.

Or just resave the current key definitions.

Yours must contain some very old key definitions.
« Last Edit: May 13, 2007, 04:24:58 pm by Pecan »

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #20 on: May 13, 2007, 01:59:22 pm »
Any ideas about the wxsmithcontrib issue ?

::EDIT::
I guess that fixed the wxsmithcontrib issue as well.

Thanks a bunch.  It is nice to finally have a running SVN version of code::Blocks with 2.8.4 ;)
« Last Edit: May 13, 2007, 02:01:42 pm by diilbert »