Author Topic: C::B build problem with wxGTK-2.8.3  (Read 10392 times)

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
C::B build problem with wxGTK-2.8.3
« on: April 30, 2007, 03:59:58 am »
I can build and install fine, but the libcompiler plugin is hanging c::b at startup. (I remove from the plugins dir and it works fine)  I am not sure what is causing this problem.  Any ideas where to start ?

AND libwxsmithcontribitems is failing to load as well.

Any thoughts or direction.  Thanks.

Quote
wxGTK 2.8.3
Debian 4.0
GTK 2.10.6
C::B SVN 3898 with patches

Thanks ;)
« Last Edit: April 30, 2007, 04:07:27 am by diilbert »

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #1 on: April 30, 2007, 11:13:38 pm »
Any thoughts or suggestions ?

Offline SharkCZ

  • Almost regular
  • **
  • Posts: 127
Re: C::B build problem with wxGTK-2.8.3
« Reply #2 on: May 01, 2007, 04:37:57 pm »
I am seeing the same behaviour :-( But no idea how to solve it.
Code::Blocks package maintainer for Fedora and EPEL

Offline dk

  • Multiple posting newcomer
  • *
  • Posts: 55
    • Code::Blocks for ALT Linux Sisyphus
Re: C::B build problem with wxGTK-2.8.3
« Reply #3 on: May 01, 2007, 04:54:21 pm »
I have the same problems when building revision 3910 with wxGTK 2.8.3.
wxGTK 2.6.3 build is OK.

OS: ALT Linux Sisyphus, x86_64.
« Last Edit: May 01, 2007, 05:19:05 pm by dkirienko »
Denis Kirienko
C::B maintainer for ALT Linux distribution (http://www.sisyphus.ru/srpm/codeblocks)

Offline jarro_2783

  • Multiple posting newcomer
  • *
  • Posts: 99
    • Project Freedom
Re: C::B build problem with wxGTK-2.8.3
« Reply #4 on: May 04, 2007, 01:49:30 pm »
I have the same problem, up to revision 3930 now.
Not much use without the compiler since I can't compile anything...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #5 on: May 04, 2007, 02:25:38 pm »
As a note, I have also seen the same behaviour with wx2.8.3.
BUT it works fine with wx2.8.0.

I don't really know what's wrong. I tried to debug this and it seems it enters an infinite loop trying to get the build toolbar's combo box size.
Anyway, this might be very remotely related to wxAUI (we 're still using our bundled version of it). Just earlier I committed a related change though, so that the wxAUI from wx is used if found. Have a try with the current svn and see if this helps...
Be patient!
This bug will be fixed soon...

Offline jarro_2783

  • Multiple posting newcomer
  • *
  • Posts: 99
    • Project Freedom
Re: C::B build problem with wxGTK-2.8.3
« Reply #6 on: May 05, 2007, 02:27:39 am »
it still does it.

they're the worst bugs aren't they, something that's related to something someone else wrote and not necessarily your bug.
« Last Edit: May 05, 2007, 02:31:41 am by jarro_2783 »

Offline Vladsharp

  • Multiple posting newcomer
  • *
  • Posts: 14
    • Vladsharp.com - The Crests of Reason
Re: C::B build problem with wxGTK-2.8.3
« Reply #7 on: May 07, 2007, 10:44:30 am »
Can confirm this with r3938 as well. Using wxPython 2.8.3.0 on Gentoo (gcc-4.1.2-r2 hardened).

Good luck with fixing it!
Vladsharp.com - The Crests of Reason

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #8 on: May 10, 2007, 11:50:38 am »
Still doing it on 3949.  Is there anything debugging wise I can do to help you guys figure this out ?

Also I am not sure how to report the actually submit a report to the bug tracker since it is asking for a username/password.

Thanks.

Diilbert

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #9 on: May 10, 2007, 12:35:09 pm »
Still doing it on 3949.  Is there anything debugging wise I can do to help you guys figure this out ?

The fact that this works in all configurations except Linux/wxGTK-2.8.3, it indicates it's a bug somewhere in wxGTK code (like the infinite loop is in wxGTK code too). If I am not mistaken, this bug doesn't happen with wxGTK-2.8.4 (or so I 've been told). So anyone who could try and verify this?
Be patient!
This bug will be fixed soon...

Offline dave.berk

  • Single posting newcomer
  • *
  • Posts: 8
Re: C::B build problem with wxGTK-2.8.3
« Reply #10 on: May 10, 2007, 01:30:58 pm »
Just compiled the latest SVN. I have the same problem. Using ubuntu feisty. CB get stuck on showing the tool tip and the main screen and I have to kill it to get back to x.

Offline Deschamps

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: C::B build problem with wxGTK-2.8.3
« Reply #11 on: May 10, 2007, 01:37:58 pm »
Quote from: dave.berk
Just compiled the latest SVN. I have the same problem (..)

Against wxGTK-2.8.4-RC2 ?
Misquotations are the only quotations that are never misquoted

Offline SharkCZ

  • Almost regular
  • **
  • Posts: 127
Re: C::B build problem with wxGTK-2.8.3
« Reply #12 on: May 10, 2007, 04:06:45 pm »
From the wxGTK ChangeLog for 2.8.4
- Fix infinite loop when adding a wxStaticText control to a toolbar
Code::Blocks package maintainer for Fedora and EPEL

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: C::B build problem with wxGTK-2.8.3
« Reply #13 on: May 10, 2007, 05:51:12 pm »
From the wxGTK ChangeLog for 2.8.4
- Fix infinite loop when adding a wxStaticText control to a toolbar


So it seems what I 've been told was correct. Thanks for the info SharkCZ.
Be patient!
This bug will be fixed soon...

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #14 on: May 11, 2007, 03:50:12 am »
Where do I get wxGTK 2.8.4 from ?  I can't find it anyway.  I have tried the SVN version, but that does not compile at all.

Thanks ;)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6610
    • My Best Post
Re: C::B build problem with wxGTK-2.8.3
« Reply #15 on: May 11, 2007, 05:04:20 am »
Where do I get wxGTK 2.8.4 from ?  I can't find it anyway.  I have tried the SVN version, but that does not compile at all.

Thanks ;)

Linux Users try
ftp://biolpc22.york.ac.uk/pub/2.8.4-rc2
I would suggest
ftp://biolpc22.york.ac.uk/pub/2.8.4-rc2/wxGTK-2.8.4-rc2.tar.bz2
Note: rc2 was broken for windows users.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #16 on: May 11, 2007, 11:25:30 am »
How did you find that ?  Considering it is not published on the wxWidgets website.   Just for future reference.

Thanks

Offline Deschamps

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: C::B build problem with wxGTK-2.8.3
« Reply #17 on: May 11, 2007, 02:48:38 pm »
Quote from: diilbert
How did you find that ?  Considering it is not published on the wxWidgets website.   Just for future reference.

It's the "official" wxWidgets snapshots repository that you find behind the "Daily Snapshot" link at the bottom of the http://www.wxwidgets.org/downloads/ webpage, i.e.: http://wxwindows.sourceforge.net/snapshots/ that redirects to that site, and then, going to "parent directory".

You'll find also this link at the "wxWidgets Mirror Sites" page, so don't be afraid, cos has been published on the wxWidgets site :)


« Last Edit: May 11, 2007, 04:08:40 pm by Deschamps »
Misquotations are the only quotations that are never misquoted

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #18 on: May 13, 2007, 03:13:18 am »
After building with wxGTK-2.8.4-rc2 (and several bugs in wx) I was able to get code::blocks to load, with the following errors:

Code: [Select]
---CUT---
[22:09:10.509]: ERROR: /usr/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
---CUT---
[22:09:16.235]: Initializing plugins...
[22:09:16.330]: KeyBinder failed UpdateById on[1621][Compiler]
[22:09:16.334]: KeyBinder failed UpdateById on[1303][Build options...]
[22:09:16.336]: KeyBinder failed UpdateById on[1300][_Build]
[22:09:16.338]: KeyBinder failed UpdateById on[1308][Compile current _file]
[22:09:16.341]: KeyBinder failed UpdateById on[1320][_Run]
[22:09:16.343]: KeyBinder failed UpdateById on[1319][Bui_ld and run]
[22:09:16.345]: KeyBinder failed UpdateById on[1310][Rebuil_d]
[22:09:16.347]: KeyBinder failed UpdateById on[1315][_Clean]
[22:09:16.349]: KeyBinder failed UpdateById on[1313][Build _workspace]
[22:09:16.351]: KeyBinder failed UpdateById on[1314][Reb_uild workspace]
[22:09:16.353]: KeyBinder failed UpdateById on[1316][Clean workspace]
[22:09:16.355]: KeyBinder failed UpdateById on[1321][_Abort]
[22:09:16.357]: KeyBinder failed UpdateById on[1324][_Previous error]
[22:09:16.359]: KeyBinder failed UpdateById on[1323][_Next error]
[22:09:16.361]: KeyBinder failed UpdateById on[1325][_Clear all errors]
[22:09:16.364]: KeyBinder failed UpdateById on[1620][_Errors]
[22:09:16.365]: KeyBinder failed UpdateById on[1322][Select target]
[22:09:16.368]: KeyBinder failed UpdateById on[1326][E_xport Makefile]
[22:09:16.372]: KeyBinder failed UpdateById on[1619][Compiler...]

On with the show.  This is a wxSmithContrib problem, and I am not sure where to start.

Although C::B is now usable so it is not that big of a deal.
Still only using SVN 3949

Diilbert

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2165
Re: C::B build problem with wxGTK-2.8.3
« Reply #19 on: May 13, 2007, 04:30:28 am »
After building with wxGTK-2.8.4-rc2 (and several bugs in wx) I was able to get code::blocks to load, with the following errors:

Code: [Select]
---CUT---
[22:09:10.509]: ERROR: /usr/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
---CUT---
[22:09:16.235]: Initializing plugins...
[22:09:16.330]: KeyBinder failed UpdateById on[1621][Compiler]
[22:09:16.334]: KeyBinder failed UpdateById on[1303][Build options...]
[22:09:16.336]: KeyBinder failed UpdateById on[1300][_Build]
[22:09:16.338]: KeyBinder failed UpdateById on[1308][Compile current _file]
[22:09:16.341]: KeyBinder failed UpdateById on[1320][_Run]
[22:09:16.343]: KeyBinder failed UpdateById on[1319][Bui_ld and run]
[22:09:16.345]: KeyBinder failed UpdateById on[1310][Rebuil_d]
[22:09:16.347]: KeyBinder failed UpdateById on[1315][_Clean]
[22:09:16.349]: KeyBinder failed UpdateById on[1313][Build _workspace]
[22:09:16.351]: KeyBinder failed UpdateById on[1314][Reb_uild workspace]
[22:09:16.353]: KeyBinder failed UpdateById on[1316][Clean workspace]
[22:09:16.355]: KeyBinder failed UpdateById on[1321][_Abort]
[22:09:16.357]: KeyBinder failed UpdateById on[1324][_Previous error]
[22:09:16.359]: KeyBinder failed UpdateById on[1323][_Next error]
[22:09:16.361]: KeyBinder failed UpdateById on[1325][_Clear all errors]
[22:09:16.364]: KeyBinder failed UpdateById on[1620][_Errors]
[22:09:16.365]: KeyBinder failed UpdateById on[1322][Select target]
[22:09:16.368]: KeyBinder failed UpdateById on[1326][E_xport Makefile]
[22:09:16.372]: KeyBinder failed UpdateById on[1619][Compiler...]

On with the show.  This is a wxSmithContrib problem, and I am not sure where to start.

Although C::B is now usable so it is not that big of a deal.
Still only using SVN 3949

Diilbert

The KeyBinder messages just means that you should really delete your cbKeybinder10.ini file in the .codeblocks directory.

Or just resave the current key definitions.

Yours must contain some very old key definitions.
« Last Edit: May 13, 2007, 04:24:58 pm by Pecan »

Offline diilbert

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: C::B build problem with wxGTK-2.8.3
« Reply #20 on: May 13, 2007, 01:59:22 pm »
Any ideas about the wxsmithcontrib issue ?

::EDIT::
I guess that fixed the wxsmithcontrib issue as well.

Thanks a bunch.  It is nice to finally have a running SVN version of code::Blocks with 2.8.4 ;)
« Last Edit: May 13, 2007, 02:01:42 pm by diilbert »