Author Topic: The 26 April 2007 build is out.  (Read 12833 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5215
The 26 April 2007 build is out.
« on: April 26, 2007, 10:21:42 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx283.7z


For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 26 April 2007 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20070426_rev3893_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20070426_rev3893_Ubuntu6.xx.deb
         http://prdownload.berlios.de/codeblocks/CB_20070426_rev3893_suse100-102.i586.rpm (not yet)
         http://prdownload.berlios.de/codeblocks/CB_20070426_rev3893_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • Fixed "invalid manifest" message when loading wxSmith and wxSmithMime
    plugins
  • Fixed: Enable/Disable of couple of File menu items
  • CodeSnippets - correct Makefile.am per daniel2000

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)

« Last Edit: April 27, 2007, 07:45:36 am by killerbot »

Offline Xaviou

  • Regular
  • ***
  • Posts: 308
    • X@v's wxStuff
Re: The 26 April 2007 build is out.
« Reply #1 on: April 26, 2007, 10:38:38 pm »
Ubuntu 6.10 & 7.04 amd64 package can be found here.
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline k2dave

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 26 April 2007 build is out.
« Reply #2 on: April 27, 2007, 02:47:56 am »
On my xp machine, the editor settings dialog is too big, and even though the dialog seems sizeable by dragging the mouse, I can't resize.
I currently use nightly 3849 & it runs correctly, so I'm assuming this is due to the 2.8.3 switch?

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 26 April 2007 build is out.
« Reply #3 on: April 27, 2007, 04:34:14 am »
Ubuntu 7.04 32-bit build here.

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: The 26 April 2007 build is out.
« Reply #4 on: April 27, 2007, 09:16:44 am »
Quote
ERROR: SDK version mismatch for wxSmithMime (1.11.10). Expecting 1.11.11
ERROR: SDK version mismatch for wxSmith (1.11.10). Expecting 1.11.11
SVN 3895 Ubuntu 7.04 wx2.6.3 clean build

Offline mroek

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 26 April 2007 build is out.
« Reply #5 on: April 27, 2007, 09:18:51 am »
Still no joy opening debugger windows (nothing happens). Is this bug related to the new wx ? On versions previous to wx 2.8 this problem doesn't exist.

Offline line

  • Single posting newcomer
  • *
  • Posts: 7
Re: The 26 April 2007 build is out.
« Reply #6 on: April 27, 2007, 09:21:10 am »
Maybe it's me, but I'm pretty sure you shouldn't be able to do this:

That's two toolbars that are gone because I pushed them off the right side of the screen. And I can't get them back.

neo2190

  • Guest
Re: The 26 April 2007 build is out.
« Reply #7 on: April 27, 2007, 09:24:19 am »
codeblocks in ubuntu 7.04 it does not come installed wxsmith, nor it comes within plugings to have if it they can return to put. thank you very much

Offline Volgovod

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 26 April 2007 build is out.
« Reply #8 on: April 27, 2007, 09:51:34 am »
codeblocks in ubuntu 7.04 it does not come installed wxsmith, nor it comes within plugings to have if it they can return to put. thank you very much

The same problem:

Starting, all OK:

Code: [Select]
Manager initialized
Scanning for lexers in /usr/share/codeblocks/lexers/...
Found 27 lexers
Configured 0 tools
Scanning for plugins in /home/myname/.codeblocks/share/codeblocks/plugins...
Found 0 plugins
Scanning for plugins in /usr/share/codeblocks/plugins...
Found 23 plugins
Loading: FilesExtensionHandler CB_Koders CodeSnippets ClassWizard EnvVars wxSmithContribItems cbDragScroll SymTab Profiler ScriptedWizard ToDoList Autosave HelpPlugin CodeCompletion AStylePlugin Debugger Compiler CodeStat cbKeyBinder RegExTestbed BYOGames lib_finder Exporter
Running startup script
Script/function 'edit_startup_script.script' registered under menu 'Settings/-Edit startup script'

Creating new project:

File -> New -> Project... -> wxWidgets project -> Go -> Next -> wxWidgets 2.8.x -> Next -> Project Title: Test -> Next -> Next -> wxSmith -> Next

The following dialog pop ups:

Script Information
wxSmith plugin is not loaded, can not continue

Ubuntu 7.04 i386, Code::Blocks SVN 3893 (CB_20070426_rev3893_Ubuntu6.xx.deb)

Offline wxLearner

  • Multiple posting newcomer
  • *
  • Posts: 71
Re: The 26 April 2007 build is out.
« Reply #9 on: April 27, 2007, 10:31:31 am »
On my xp machine, the editor settings dialog is too big, and even though the dialog seems sizeable by dragging the mouse, I can't resize.
I currently use nightly 3849 & it runs correctly, so I'm assuming this is due to the 2.8.3 switch?
Yes, it is a strange issue. As stated here with wx-2.8.0 it's ok.
I've made a test with wx-2.8.4-rc1 now; the minimal size is too big with it also.

cb_mo

  • Guest
Re: The 26 April 2007 build is out.
« Reply #10 on: April 27, 2007, 03:54:00 pm »
Not sure if this is an on-going issue but it's the same for the 25th and 26th April builds.  When I create a new C/C++ source/header file and try to add it to the active project using the create new file from template dialog, I find checking the boxes to add the file to the current project does nothing.  The file's created OK and I can add the file to the project manually via the Projects sidebar but the wizard doesn't add them at all.  I thought it might have been a panel update bug, but restarting Code Blocks shows the files have not been added.

I'm presuming there's a problem with the code for the method AddFileToTargets or the conditional check routine (Wizard.GetFileAddToProject) both of which are called from the wizard script. Anyone know a fix for this (other than the manual approach)?

julv

  • Guest
Re: The 26 April 2007 build is out.
« Reply #11 on: April 27, 2007, 04:28:01 pm »
I have a (minor) problem with copy/paste...
by default, it seems that Ctrv-C, Ctrl-V, Ctrl-X were assigned to "cut LINE", "copy line", "paste line"... I went to the editor configuration> keyboard shortcut>Edit submenu. there, i could check that the item Cut/copy/paste add no associated shortcut.
In description, they are described as "Cut current line", "copy current line", "paste before current line"
if i start putting a new shortcut for "cut", i press Ctrl-X, it says it is affected to... "cut" !! however, after applying, it is properly added to "current shortcut" list, and works as expected...

Anyway, there basically seems to be a confusion somewhere between cut/copy/paste and cut line/copy line/paste before line...

(i looked for *keybinder* file, couldn't find any). I first saw the problem with 24th april release, i didn't have t with previous (much older) release.

And congrats for the app in general, it is really great.

Offline danielking

  • Single posting newcomer
  • *
  • Posts: 7
Re: The 26 April 2007 build is out.
« Reply #12 on: April 27, 2007, 04:45:02 pm »
I have a (minor) problem with copy/paste...
by default, it seems that Ctrv-C, Ctrl-V, Ctrl-X were assigned to "cut LINE", "copy line", "paste line"... I went to the editor configuration> keyboard shortcut>Edit submenu. there, i could check that the item Cut/copy/paste add no associated shortcut.
In description, they are described as "Cut current line", "copy current line", "paste before current line"
if i start putting a new shortcut for "cut", i press Ctrl-X, it says it is affected to... "cut" !! however, after applying, it is properly added to "current shortcut" list, and works as expected...

Anyway, there basically seems to be a confusion somewhere between cut/copy/paste and cut line/copy line/paste before line...

(i looked for *keybinder* file, couldn't find any). I first saw the problem with 24th april release, i didn't have t with previous (much older) release.

And congrats for the app in general, it is really great.

This file is in "C:\Documents and Settings\USERNAME\local settings\Application Data\codeblocks".

Offline danielking

  • Single posting newcomer
  • *
  • Posts: 7
Re: The 26 April 2007 build is out.
« Reply #13 on: April 27, 2007, 04:50:57 pm »
The debugging window still cannot be open in today's release. This problem started from yestoday's release on my laptop, and also on my desktop pc.
Today I installed Vista on my laptop with it's recovery dvd, try to find if it's the problem of my windows system. But the probleam is still there. Why?

I mean the windows of watches, breakpointers, call stack etc.

Offline Wavesonics

  • Multiple posting newcomer
  • *
  • Posts: 43
Re: The 26 April 2007 build is out.
« Reply #14 on: April 29, 2007, 09:53:58 pm »
Ok, I have encountered a rather critical bug that just started cropping up.

As soon as I click the Build Target drop down to select a different built target it flickers then the whole box goes away completely with absolutely no way of getting it back!

Is there a log file or something I should upload?