Author Topic: The 19 April 2007 build is out.  (Read 19565 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
The 19 April 2007 build is out.
« on: April 19, 2007, 10:37:58 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2.7z

To fix the menu alignment bug introduced in wx 2.6.3 [windows only bug] we have patched wx ourselves, and that results in the following alternative dll : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2AndCbPatch_version3.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26_gcc_cb_wx2.6.3p2.7z

The 19 April 2007 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20070419_rev3876_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20070419_rev3876_Ubuntu6.xx.deb
         http://prdownload.berlios.de/codeblocks/CB_20070419_rev3876_suse100-102.i586.rpm (not yet)
         http://prdownload.berlios.de/codeblocks/CB_20070419_rev3876_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • wxSmith: Added "UseNamesInXml" argument for wxsFlagsProperty
  • wxSmith: Switched to check boxes in flags property instead of Yes/No combo (it's much easier to use)
  • Applied patch by stahta01 which makes wxSmithContribItems.cbp more standard
  • wxSmith: fixed bug in flags property
  • Added property for internal wxChart's styles
  • Fixed linux build for wxSmithContribItems

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • menu items with icon not correctly aligned (since wx263) (is fixed with our special wx263/wx28 dll)

« Last Edit: April 20, 2007, 08:04:53 am by killerbot »

Offline Xaviou

  • Regular
  • ***
  • Posts: 311
    • X@v's wxStuff
Re: The 19 April 2007 build is out.
« Reply #1 on: April 19, 2007, 10:58:36 pm »
Ubuntu 6.10 Amd64 .deb installer can be found here.

The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

neo2190

  • Guest
Re: The 19 April 2007 build is out.
« Reply #2 on: April 20, 2007, 09:43:02 am »
Error Codeblocks ubuntu

ERROR: Invalid manifest file for: wxSmithMime
ERROR: Invalid manifest file for: wxSmith

Offline hollingsworthd

  • Single posting newcomer
  • *
  • Posts: 7
Re: The 19 April 2007 build is out.
« Reply #3 on: April 20, 2007, 10:34:51 am »
Error Codeblocks ubuntu

ERROR: Invalid manifest file for: wxSmithMime
ERROR: Invalid manifest file for: wxSmith

I get this error too on the .deb of this 3876 rev

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 19 April 2007 build is out.
« Reply #4 on: April 20, 2007, 12:08:56 pm »
You can find the suse nightly here: http://thetuxkeeper.phoetron.de/CB_20070419_rev3876_suse100-102.i586.rpm

Couldn't login to berlios, so couldn't add the package to the project files.
Nightly builds for openSUSE

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 19 April 2007 build is out.
« Reply #5 on: April 20, 2007, 12:44:41 pm »
Hello,

Same question than yesterday (but with this nightly build) :
The Abort toolbar button is always disabled even in debugging mode whereas the command "Stop debugger" in menu Debug is enabled.

Is it a bug?

Thanks in advance and have a nice day.

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 19 April 2007 build is out.
« Reply #6 on: April 20, 2007, 12:55:13 pm »
I can't reproduce this bug.

Can you provide us more details?
Be a part of the solution, not a part of the problem.

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 19 April 2007 build is out.
« Reply #7 on: April 20, 2007, 01:41:19 pm »
I think you've deleted your thread. ;)

The button, you referred, belongs to Compiler toolbar not Debugger related toolbar.  :)
« Last Edit: April 20, 2007, 01:50:11 pm by Biplab »
Be a part of the solution, not a part of the problem.

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 19 April 2007 build is out.
« Reply #8 on: April 20, 2007, 01:46:21 pm »
You are absolutely right.

Sorry, shame on me  :oops:

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 19 April 2007 build is out.
« Reply #9 on: April 20, 2007, 01:49:31 pm »
I was about to leave the lab and checked the forum once and read your post. :lol:
Be a part of the solution, not a part of the problem.

Offline MoonKid

  • Almost regular
  • **
  • Posts: 180
Re: The 19 April 2007 build is out.
« Reply #10 on: April 20, 2007, 07:22:18 pm »
What is about my disapeard compiler-toolbar.

How can I get it back?

It is activated in the view-menu but I think it is outside the right-screen-side.
It means x of the toolbar is bigger than max-x of the screen. Understand?

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
Re: The 19 April 2007 build is out.
« Reply #11 on: April 20, 2007, 11:05:05 pm »
deleting your layout, or switch back to default layout, or in worst case start with a new default.conf ...

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: The 19 April 2007 build is out.
« Reply #12 on: April 21, 2007, 04:08:54 am »
How I can remove wxSmith Panels, Forms or Dialogs from project? And how I can put them to special folder no to the root folder of the project!? :shock:
gcc+winXP+suse.

Squiddle

  • Guest
Re: The 19 April 2007 build is out.
« Reply #13 on: April 21, 2007, 09:17:25 am »
Do you think the ubuntu6.xx debs are likely to work with 7.04?
I'll try anyway, and report what happens...

EDIT: berlios.de seems to be 'down' now, so I cannot yet get the ubuntu debs to try with... Anybody know what's going on?
« Last Edit: April 21, 2007, 11:58:13 am by Squiddle »

Offline lubos

  • Almost regular
  • **
  • Posts: 131
Re: The 19 April 2007 build is out.
« Reply #14 on: April 21, 2007, 12:09:48 pm »
could it be possible to minimize codeblocks to tray icon?

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 19 April 2007 build is out.
« Reply #15 on: April 21, 2007, 02:37:47 pm »
Do you think the ubuntu6.xx debs are likely to work with 7.04?
I'll try anyway, and report what happens...

EDIT: berlios.de seems to be 'down' now, so I cannot yet get the ubuntu debs to try with... Anybody know what's going on?


Yes they do work with 7.04. I have a Feisty specific build available too. You can download it from here. I'll be uploading a new revision sometime this weekend.

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 19 April 2007 build is out.
« Reply #16 on: April 21, 2007, 02:44:09 pm »
How I can remove wxSmith Panels, Forms or Dialogs from project? And how I can put them to special folder no to the root folder of the project!? :shock:

Easiest way - just remove or rename .wxs files for those resources and they won't appear again. I assume that special folder is the one where .wxs files are kept. Currently it could be done only by manually edit .cbp file, find entries with .wxs files and change their path.

Please fill feature request if you want those things to be supported in GUI.

BYO

felipedrl

  • Guest
Re: The 19 April 2007 build is out.
« Reply #17 on: April 23, 2007, 03:27:53 am »
Hi,

First I wanna thank you for the amazing development and support. Ive been using codeblock for a while but Im recently new to nightly builds. Ive download the ubuntu feisty that cstudent uploaded. Let me ask you a couple of questions. 

1) To update the build, could I just overwrite it with another .deb?
2) When trying to use wxsmith I experience some refreshing problems. Im using wxWidgets 2.6.0 and  I would like to know if someone has experienced this refreshing issues and how to solve it. The description is as follows:

As soon as I create a new wxSmith project, no matter Frame or Dialog, the widgets doesnt appear, just the black squares around them. When I try to add some new widget, it is refreshed and all the widgets appear. But when I click and select some widget all of them disappear again, until I add another one.   

Thanks in advance.

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 19 April 2007 build is out.
« Reply #18 on: April 23, 2007, 04:06:41 am »
To answer your first question, you can update Codeblocks by just installing a newer .deb with the usual:

Code: [Select]
sudo dpkg -i new_version_here.deb

Offline san

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: The 19 April 2007 build is out.
« Reply #19 on: April 23, 2007, 12:55:40 pm »
Do you think the ubuntu6.xx debs are likely to work with 7.04?
I'll try anyway, and report what happens...

EDIT: berlios.de seems to be 'down' now, so I cannot yet get the ubuntu debs to try with... Anybody know what's going on?

I use it since the betas on 7.04.. there are sometimes special packages posted for this version but the 6.xx works

suhaizal

  • Guest
Re: The 19 April 2007 build is out.
« Reply #20 on: April 23, 2007, 05:02:47 pm »
Before this I've used the 1.0rc2 but, then decided to give the nightly builds a try, especially after reading about all of the new features and upgrades. :D
I've installed the 19th April build, but when running console application, nothing gets run. I'm using C::B on Windows XP sp2. Everything compiles ok (as what the build logs says), but can't seem to run the apps from within C::B.
I've already set the Target to console and set the option to Pause after execution, but nothing seems to work. Thanks in advance.

Offline Phoenix

  • Multiple posting newcomer
  • *
  • Posts: 38
Re: The 19 April 2007 build is out.
« Reply #21 on: April 23, 2007, 05:44:59 pm »
Hello,

I have tried this nightly and I have noticed one strange thing. It seams that CTRL+V (past) seams to be pasting copied text not at current position, but it is inserting a line above current line and then inserts the text in this line. SHIFT+INSERT and right click->past works without any problems. Any ideas if this is version related problem or do I have some sort of setting problem on two different computers?

Using:
Windows XP Pro
wx290 cvs
C::B 3876

Regards,
Peter

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2214
Re: The 19 April 2007 build is out.
« Reply #22 on: April 23, 2007, 06:27:04 pm »
Hello,

I have tried this nightly and I have noticed one strange thing. It seams that CTRL+V (past) seams to be pasting copied text not at current position, but it is inserting a line above current line and then inserts the text in this line. SHIFT+INSERT and right click->past works without any problems. Any ideas if this is version related problem or do I have some sort of setting problem on two different computers?

Using:
Windows XP Pro
wx290 cvs
C::B 3876

Regards,
Peter

Delete cbKeyBinder10.ini file in you home directory. The menu structure has changed.


Offline Phoenix

  • Multiple posting newcomer
  • *
  • Posts: 38
Re: The 19 April 2007 build is out.
« Reply #23 on: April 23, 2007, 06:32:04 pm »
Thanks, it worked.  :lol:

Hello,

I have tried this nightly and I have noticed one strange thing. It seams that CTRL+V (past) seams to be pasting copied text not at current position, but it is inserting a line above current line and then inserts the text in this line. SHIFT+INSERT and right click->past works without any problems. Any ideas if this is version related problem or do I have some sort of setting problem on two different computers?

Using:
Windows XP Pro
wx290 cvs
C::B 3876

Regards,
Peter

Delete cbKeyBinder10.ini file in you home directory. The menu structure has changed.



Offline alerce

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 19 April 2007 build is out.
« Reply #24 on: April 25, 2007, 03:19:11 am »
Hi, I have recently downloaded Code::Blocks, and I'm trying it for the first times.
I downloaded this nightly build, and it sees very nice.
I'm used to Visual C++, but recnetly I've to work with MinGW, so I was using Dev-C++ and his debugger isn't very good, and I was atracted by Code::Blocks essentially for user keywords highlighting, and code completion besides the debugger.

After this long introduction, I get to the point.
I'm having a lot of problems with the autocompletion. Sometimes it doesn't show anything, and when it shows the options, it shows not all of them, and shows some that shouldn't be there.

For example, when I have two classes A and B with a lot of functions both.
I write
A x;
x. //now should come autocompletion
But autocompletion shows me only some of the A functions, and shows me some of B functions. :S

Furthermore, when it doesnt show the function I want, and I write it by hand, the IDE can't show me the functions argument list either.

Is autocompletion still a uncomplete developed feature? Or am I doing something wrong?
Thanks for comments.
I find the IDE really nice, but with this problems, I'm thinking I can't switch all my projects to it and have to wait until it's completely developed.

Offline TDragon

  • Lives here!
  • ****
  • Posts: 943
    • TDM-GCC
Re: The 19 April 2007 build is out.
« Reply #25 on: April 25, 2007, 03:25:55 am »
Is autocompletion still a uncomplete developed feature?
Yes, the code completion plugin is known to have unresolved issues.

Quote
Or am I doing something wrong?
Maybe so. It would be very helpful if you could post a sample of something that works incorrectly.

Quote
I find the IDE really nice, but with this problems, I'm thinking I can't switch all my projects to it and have to wait until it's completely developed.
I've found that, even with the code completion plugin entirely disabled, Code::Blocks' benefits as an IDE far outweigh this small deficit.
https://jmeubank.github.io/tdm-gcc/ - TDM-GCC compiler suite for Windows (GCC 9.2.0 2020-03-08, 32/64-bit, no extra DLLs)

Offline alerce

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 19 April 2007 build is out.
« Reply #26 on: April 25, 2007, 03:50:25 am »
Thanks for the fast answer.
It's hard to post an example, because I'm trying with big projects.
With small examples I can't reproduce some of the problems, but an easy bug that I've readen about(searching for help) and reproduced is in a new proyect write:
class AAA{
   int a;
};
int main(){
   AAA a;
   a. //and autocomplete doesn't work, even if you now change AAA a for AAA b.
}

Sure it's a good IDE, searching for features I need and reading a lot of good comments about it is that I came to it, and decided to download it.
But I'm really used that function arguments are always shown, and when code-completion didn't works, the function arguments arem't shown. It's specially useful for standard library functions.
I'm in the middle of a proyect, so I wanted to spent the time geting used to a new evironment only if it has a lot of benefits for me.

I'm not criticizing Code::Blocks, I'm very happy it has an active developement. It sees really nice. The Settings section is self-explaining and very nice and customizable. I think you will get an excellent and powerfull IDE.
Good Luck.

Offline TDragon

  • Lives here!
  • ****
  • Posts: 943
    • TDM-GCC
Re: The 19 April 2007 build is out.
« Reply #27 on: April 25, 2007, 03:23:34 pm »
class AAA{
   int a;
};
int main(){
   AAA a;
   a. //and autocomplete doesn't work, even if you now change AAA a for AAA b.
}
Now there's an interesting bug. Change "AAA a;" to "AAA b;" and put the opening curly brace for main() on a new line, and everything works. But I guess it's hard luck for people who like to put their curly braces on the same line as their headers.

At any rate, I've never run across this bug of showing some of the members of a class along with the members of another class. Also, function argument hints (call-tips) works fairly well (though if the auto-complete list is still open when a left-paren is typed, the call-tip won't show up until you delete the left-paren and retype it).
https://jmeubank.github.io/tdm-gcc/ - TDM-GCC compiler suite for Windows (GCC 9.2.0 2020-03-08, 32/64-bit, no extra DLLs)