Author Topic: "Start here" page background defaults to black again?  (Read 10535 times)

Offline ouch

  • Almost regular
  • **
  • Posts: 221
"Start here" page background defaults to black again?
« on: September 26, 2013, 12:59:39 am »
I recall this happened before and it was actually a bug so I am reporting it here just in case it is again.

Running on win 7 64bit, codeblocks svn 8367, wxWidgets 2.8 svn 74860, compiled with tdm mingw 4.7.1.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5220
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: "Start here" page background defaults to black again?
« Reply #1 on: September 26, 2013, 01:56:01 am »
As I know, the background color can be customized now, see this commit:
Code: [Select]
Revision: 9361
Author: mortenmacfly
Date: 2013-9-20 18:12:59
Message:
* applied patch #3426: Allow modify "start here page" background colour
-------------------------------
M(T ) : /trunk/src/src/startherepage.cpp

If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5220
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: "Start here" page background defaults to black again?
« Reply #2 on: September 29, 2013, 09:52:59 am »
Hi, I just see the same issue, I get the start page's background color as blue, previously the background color is white.
I just check my WinXP color setting, see the image below:

Now, C::B has set the blue color as the start page's (default) background, I think that was not correct. In my XP, when you open any browser to view a html, the background color is white, When you open a windows explorer, the background is also white.

So, is it possible to set the default start page's background to white? Or the background color of the "Window Text" in the above screen shot. Thanks.

EDIT: the suggest color is: wxSYS_COLOUR_WINDOW    
which means: Window background, see http://docs.wxwidgets.org/2.8/wx_wxsystemsettings.html

EDIT2:
The font color should set default to wxSYS_COLOUR_WINDOWTEXT (Text in windows), I can't find the default color for the link text. ;)
« Last Edit: September 29, 2013, 10:05:53 am by ollydbg »
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11818
    • Travis build status
Re: "Start here" page background defaults to black again?
« Reply #3 on: September 29, 2013, 11:52:38 am »
Both issues should have been fixed in trunk.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5220
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: "Start here" page background defaults to black again?
« Reply #4 on: September 29, 2013, 12:06:00 pm »
Both issues should have been fixed in trunk.
I see the two commits, thanks!
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline ouch

  • Almost regular
  • **
  • Posts: 221
Re: "Start here" page background defaults to black again?
« Reply #5 on: October 02, 2013, 12:52:58 am »
Yep that fixed it for me too. I also checked the background color setting and that works as well.