Author Topic: Beta 4 Editor Problem  (Read 12457 times)

Offline eoneuk

  • Multiple posting newcomer
  • *
  • Posts: 18
    • http://
Beta 4 Editor Problem
« on: January 05, 2005, 01:49:49 pm »
I just downloaded and installed Beta 4 on Windows 98 SE.  CodeBlocks starts and creates a default project, but the editor page does not appear so that the source code (main.cpp) can be viewed.  There is a message that says main.cpp cannot be loaded although it appears in the tree view on the project window. Beta 3 version worked fine for me.

Thanks for any help
Ed

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Beta 4 Editor Problem
« Reply #1 on: January 05, 2005, 02:59:47 pm »
Hmm, win98se... I haven't tested it there. We 'll have to see what's wrong.
Can you post the exact message that says the file cannot be loaded? I need to see the full filename it tries to load, in order to help you...
Be patient!
This bug will be fixed soon...

Offline eoneuk

  • Multiple posting newcomer
  • *
  • Posts: 18
    • http://
Beta 4 Editor Problem
« Reply #2 on: January 05, 2005, 03:42:09 pm »
[09:26:17.230]: Failed to open 'C:\CodeBlocks\programs\main.cpp' is the error message that appears under the Code::Blocks Debug Tab.  The file actually does exist in that directory. I also tried using the default directory of My Documents with the same result. The same thing happens whether I create a console program or a windows program.

Ed

Offline eoneuk

  • Multiple posting newcomer
  • *
  • Posts: 18
    • http://
Beta 4 Editor Problem
« Reply #3 on: January 06, 2005, 01:34:33 pm »
It appears to be an editor problem.  If I create a project, the project and default source code are listed in the management window. But I cannot open the editor window to view the source file. However, I can compile and run the project.  Maybe this info will help.

Ed

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Beta 4 Editor Problem
« Reply #4 on: January 06, 2005, 02:16:04 pm »
Yes, it seems to be a bug which appears only under win98. I got another bug-report like this. I will investigate further and come up with a solution.
Thanks a lot.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline Insubordinate

  • Multiple posting newcomer
  • *
  • Posts: 12
    • Dunghill Entertainment
Beta 4 Editor Problem
« Reply #5 on: January 11, 2005, 04:46:08 pm »
I've got a similar problem in Windows XP.  When ever I open a project or just a .cpp or .h file it says that the file can't be found.  It does open it though, and I'm able to edit it. But it's still a little annoying having to click that error message away everytime.

Other than that. Thanks for a great IDE! My favourite so far!

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Beta 4 Editor Problem
« Reply #6 on: January 11, 2005, 08:29:57 pm »
Can you post the exact message you 're getting?
Be patient!
This bug will be fixed soon...

Offline Insubordinate

  • Multiple posting newcomer
  • *
  • Posts: 12
    • Dunghill Entertainment
Beta 4 Editor Problem
« Reply #7 on: January 12, 2005, 12:53:48 am »
Ok, it's in danish though:
"Windows kan ikke finde 'C:\Projects\Apps\FartED\src\app.cpp'. Kontroller, at du skrev navnet korrekt, og forsøg derefter igen. Hvis du vil søge efter en fil, skal du klikke på knappen Start og derefter klikke på Søg."

Which basically just says that Windows couldn't find the specified file.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Beta 4 Editor Problem
« Reply #8 on: January 12, 2005, 09:05:05 am »
OK, this is a different problem than the one mentioned above in this thread. I assume you 're not opening the file from inside codeblocks but from explorer (or something like it). This has to do with DDE. I 'll check it out.

Thanks,
Yiannis.
Be patient!
This bug will be fixed soon...

Offline Insubordinate

  • Multiple posting newcomer
  • *
  • Posts: 12
    • Dunghill Entertainment
Beta 4 Editor Problem
« Reply #9 on: January 12, 2005, 05:20:12 pm »
Yes,  it's when opening from explorer. Once Code::Blocks is running there's no problem opening files, within or from outside Code::Blocks.

Looking forward to the next release!

Josef Planeta

  • Guest
Same problem on W98SE
« Reply #10 on: January 14, 2005, 01:16:07 pm »
Hi,
I can confirm same kind of problems with editing of files. When create project, add files - tree of the project shows files, but noone can be edited.

MOREOVER: I am NOT able to even open any file in editor. And when create new file, e.g. 1.c , file is created, but not opened in C::B for editation.

Use W98SE, Czech.  I will test at home on W98

Hope that will help-IDE is so far very *good*

Josef

Josef Planeta

  • Guest
NO edit problems with C::B beta2 on Win98SE
« Reply #11 on: January 14, 2005, 01:32:40 pm »
Just add information, that beta2 has NO problems to edit files on Win98SE. Hope that help to squeeze the bug :-)

Josef

Anonymous

  • Guest
Beta 4 Editor Problem
« Reply #12 on: January 18, 2005, 12:24:41 pm »
Hi,

errors also occure under win2000 if i try to open a source file inside or outside the ide. please get things working because the dev cpp ide is to buggy to use it and the class browser dont work that good. i hope those things (and the code completion) work in this ide as well as it seems...

maynard

Anonymous

  • Guest
Beta 4 Editor Problem
« Reply #13 on: January 18, 2005, 03:17:44 pm »
Yes, I wish to join to >maynard - please fix editor problems ASAP. Beta 2 version was OK and I suppose that *many* developers will then wish to test this *GREAT* IDE in real programmers life - to find other bugs.
Please keep good work.... :-)

Josef

Anonymous

  • Guest
Beta 4 Editor Problem
« Reply #14 on: January 19, 2005, 08:36:00 am »
Same on WinXP when one double-clicks on a ".workspace" file.