Author Topic: Code::Blocks CVS-bin snapshot  (Read 30004 times)

sethjackson

  • Guest
Re: Code::Blocks CVS-bin snapshot
« Reply #30 on: November 28, 2005, 02:32:15 am »
I'm not Ceniza  :lol: but maybe you could try the beta of 7-zip.

http://7-zip.org/

The 32 bit version.
« Last Edit: November 28, 2005, 02:49:57 am by Seth Jackson »

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: Code::Blocks CVS-bin snapshot
« Reply #31 on: November 28, 2005, 02:37:24 am »
I just tried 7-Zip Beta and it works fine :)

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2177
Re: Code::Blocks CVS-bin snapshot
« Reply #32 on: November 28, 2005, 03:06:09 am »
Well ok, I'll keep working on it, but I just downloaded 7-zip 4.30 beta and tried
testing your archive with both the gui and command line on xp. I still get
"unsupported archive".
Code: [Select]
E:\User\Downloads\_Pending\CodeBlocks\Beta>c:\usr\bin\7-zip\7z l CodeBlocksSVN20
051126.7z

7-Zip 4.30 beta  Copyright (c) 1999-2005 Igor Pavlov  2005-11-18

Error: CodeBlocksSVN20051126.7z is not supported archive

Errors: 1
E:\User\Downloads\_Pending\CodeBlocks\Beta>
When I try "Edit" it shows garbage file names etc.

The other archive by "theron??" extracts ok, but its not as up to date.

Thanks for the help tho,
Pecan


[EDIT]
I used a different downloader, and it extracted just fine.
Sorry for the false alarm.

« Last Edit: November 28, 2005, 03:31:07 am by Pecan »

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2177
Re: Code::Blocks CVS-bin snapshot
« Reply #33 on: November 28, 2005, 03:29:06 am »
Its ok, I just used another downloader and it works fine.

Sorry for the false alarm.

Thanks
Pecan

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: Code::Blocks CVS-bin snapshot
« Reply #34 on: December 24, 2005, 09:29:12 pm »
Ok, new binary snapshot compiled with GCC 4.1.0 is in the way :)

It's revision 1587, which includes new rickg22's toy.

Merry SVN Binary Snapshot Christmas.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Code::Blocks CVS-bin snapshot
« Reply #35 on: December 25, 2005, 05:24:50 pm »
Ok, new binary snapshot compiled with GCC 4.1.0 is in the way :)

It's revision 1587, which includes new rickg22's toy.

Merry SVN Binary Snapshot Christmas.

Hello,

I have just now downloaded CodeBlocksSVN20051224.7z from your webpage, but I could not extract it. I use 7zip 4.32 and until now it worked fine for Therion compressed archives. I get the following error:

Quote
CodeBlocksSVN20051224.7z is not supported archive

Best wishes,
Michael

Offline grunerite

  • Multiple posting newcomer
  • *
  • Posts: 41
Re: Code::Blocks CVS-bin snapshot
« Reply #36 on: December 26, 2005, 04:07:47 am »
Hello,

I have just now downloaded CodeBlocksSVN20051224.7z from your webpage, but I could not extract it. I use 7zip 4.32 and until now it worked fine for Therion compressed archives. I get the following error:
I just downloaded it 15 minutes ago, used 7zip 4.32, and it extracted very nicely. Perhaps you had a bad download.

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: Code::Blocks CVS-bin snapshot
« Reply #37 on: December 26, 2005, 04:33:25 am »
I bet it was a bad download. That's why I'm providng a .md5 file too, so you can check if it's correct.

You can test if your download is right using md5sum. Here's a Windows binary.

Just run md5sum CodeBlocksSVNXXXXXXXX.7z and compare the result with the one in the site (of course you must replace all the X with the date of the binary snapshot you got).

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Code::Blocks CVS-bin snapshot
« Reply #38 on: December 27, 2005, 12:22:35 am »
I bet it was a bad download. That's why I'm providng a .md5 file too, so you can check if it's correct.

You can test if your download is right using md5sum. Here's a Windows binary.

Just run md5sum CodeBlocksSVNXXXXXXXX.7z and compare the result with the one in the site (of course you must replace all the X with the date of the binary snapshot you got).

Yes, bet won :D. As I am in my parents' home and my father's computer has a slow modem, I have used DAP to speed up the download (and reduce the costs :wink:). Normally, it worked fine, but not this time :?. I have tried with IE and I could decompress the SVN binary snapshot without problems.

Thank you and you all for your help.

Michael

PS.: Thank you for md5sum :).

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Code::Blocks CVS-bin snapshot
« Reply #39 on: December 27, 2005, 01:25:50 am »
Hello,

I have downloaded and installed CodeBlocksSVN20051224.7z and the wxWidgets-2.6.2_DLLs_20051012.7z, but the Management projects looks not so nice :). See also attachment. If I remember there was a topic about this issue, but I thought it was solved, because I have never had such an issue before with RC2 and Therion's binary snapshots :?. Anyway, I have tried several times closing and re-opening C::B, but it seems that I got this issue just the first time, then all was fine. Hmmm, I do not know if this is a bug in C::B or not :?. Has someone else got such a problem?

Michael


[attachment deleted by admin]

Offline klight

  • Multiple posting newcomer
  • *
  • Posts: 24
Re: Code::Blocks CVS-bin snapshot
« Reply #40 on: December 27, 2005, 03:48:10 am »
Has someone else got such a problem?

I have had this happen several times.  Usually the first time after installing a binary update.  If you open and close a project several times it fixes itself and doesn't seem to come back.  (This is what I've done in the past and it seems to fix it... or was it a close/open after compiling a project?)  I haven't had it happen for the last 3 or four Therion updates so I made the assumption it was fixed.  I also couldn't reliably reproduce it, but I didn't try too hard either.

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: Code::Blocks CVS-bin snapshot
« Reply #41 on: December 27, 2005, 05:16:33 am »
It happens for me every time I run a new snapshot and only happens the first time. I wonder if it's also a problem with wxWidgets 2.6.2...

Offline grunerite

  • Multiple posting newcomer
  • *
  • Posts: 41
Re: Code::Blocks CVS-bin snapshot
« Reply #42 on: December 27, 2005, 05:38:03 am »
I do believe it is related to a configuration file Code::Blocks is placing in the users Application Data directory (default.conf). When you first run, this file does not exist (or is for an old revision), but gets saved when you terminate C::B the first time. Perphaps C::B reads this file on startup, but if it isn't there or correct the first time it starts up, it has problems. Just a guess.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5187
Re: Code::Blocks CVS-bin snapshot
« Reply #43 on: December 27, 2005, 09:46:19 am »
I posted a thread about this problem, and I am still suffering from it (thread title was something like : projectmanager looks weird).

Sometimes it happened, sometimes not. Very strange.
I did not find a a good way of reproduction yet. When you don't expect it, it happens, and when you want to see it again, it is suddenly gone.
Might indeed have something to do with default.conf, or with CRC (layout crc is another such problem : debug bar gone, ...)

Lieven

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Code::Blocks CVS-bin snapshot
« Reply #44 on: December 27, 2005, 04:05:12 pm »
Strange issue, indeed :?. I never had it and C::B always run smoothly since RC1. Just yesterday night, I got such a view after starting a fresh SVN binary snapshot installation. It could be a C::B configuration problem or may be some default value(s) that get overriden when C::B is re-started (the first time I usually modify some default settings, e.g., Editor, Debugger, Code Completion)? Or as Ceniza wonders, a possible wxWidgets 2.6.2 "bug(s)".

Michael