Author Topic: The 05 March 2007 build is out.  (Read 17252 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 05 March 2007 build is out.
« on: March 05, 2007, 08:30:23 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2.7z

To fix the menu alignment bug introduced in wx 2.6.3 [windows only bug] we have patched wx ourselves, and that results in the following alternative dll : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2AndCbPatch_version3.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26_gcc_cb_wx2.6.3p2.7z

The 05 March 2007 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20070305_rev3665_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20070305_rev3665_Ubuntu6.xx.deb
         http://prdownload.berlios.de/codeblocks/CB_20070305_rev3665_suse100-102.i586.rpm
         http://prdownload.berlios.de/codeblocks/CB_20070305_rev3665_fc4+5.i586.rpm


Resolved Fixed:

  • Fixed crash (in few cases) while closing project options dialog (On behalf of Martin)

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • menu items with icon not correctly aligned (since wx263) (is fixed with our special wx263/wx28 dll)

« Last Edit: March 06, 2007, 11:25:49 pm by killerbot »

Offline indigo0086

  • Almost regular
  • **
  • Posts: 150
Re: The 05 March 2007 build is out.
« Reply #1 on: March 06, 2007, 06:44:35 am »
I noticed if you set the sash size to 0 in the dock options then any window you overlap with it get's "stuck in the borders.  Like if you have a black window open then the black parts of the window show up on the borders.  You have to resize the window or set the sash to greater than 0.

Offline dr snuggles

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: The 05 March 2007 build is out.
« Reply #2 on: March 06, 2007, 11:09:27 am »
Bugs:
1) Only the first time after unpacking, running and closing this release, I get an error (memory not found blabla, same as you get when a pointer is pointing wrong)

2) Problem with adding files not from the same folder to a project, though not sure if this is a bug or just inconsistent of Code::blocks:
a. Add file Q from folder X
b. Add file from folder Y
c. Add file Z from folder X
d. Open file Z from the Management -> project tree
In the opened tab, the file name \X\Z is displayed, instead of Z. The path \X could be very long thus wasting space in the tab browser. Opening file Q is correctly displayed as Q (not \X\Q).
e. Remove all files from folder Y
f. Open file Z from the Management -> project tree
In the opened tab, the file name Z is displayed as it should.

3) CPU usage while moving the mouse or typing text is still 100%, just as in the other builds. It's not super annoying, but when will this problem be addressed?

4) Usability issues: Lots of basic things can be improved. Should these also be addressed in this stage of development? Can I also address them in this thread?

Overall thoughts about Code::Blocks: Very, very nice piece of equipment.
« Last Edit: March 06, 2007, 11:19:29 am by dr snuggles »

Offline Marenz

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: The 05 March 2007 build is out.
« Reply #3 on: March 06, 2007, 01:57:49 pm »
I get the crash reporter on Setting -> Editor (and most other Dialogs)
i am on amd64. I build it myself.

this is the report:
<?xml version="1.0" encoding="utf-8"?>
<report version="1.0" kind="exception">
  <system description="Linux 2.6.18-3-amd64 x86_64"/>
  <modules>
    <module path="/usr/local/bin/codeblocks" address="00400000" size="001ae000"/>
  </modules>
  <stack>
    <frame level="2" function="wxStackWalker::Walk(unsigned long)" offset="0000002b"/>
    <frame level="3" function="wxDebugReport::AddContext(wxDebugReport::Context)" offset="00000a60"/>
    <frame level="4"/>
    <frame level="5" function="wxFatalSignalHandler" offset="0000001c"/>
    <frame level="6"/>
    <frame level="7" function="CCOptionsDlg::CCOptionsDlg(wxWindow*, NativeParser*)" offset="00000473"/>
    <frame level="8" function="CodeCompletion::GetConfigurationPanel(wxWindow*)" offset="00000038"/>
    <frame level="9" function="PluginManager::GetConfigurationPanels(int, wxWindow*, ConfigurationPanelsArray&amp;)" offset="000000cc"/>
    <frame level="10" function="EditorConfigurationDlg::AddPluginPanels()" offset="000000c3"/>
    <frame level="11" function="EditorConfigurationDlg::EditorConfigurationDlg(wxWindow*)" offset="00001d16"/>
    <frame level="12" function="EditorManager::Configure()" offset="00000039"/>
    <frame level="13" function="wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&amp;, wxEvtHandler*, wxEvent&amp;)" offset="0000007f"/>
    <frame level="14" function="wxEventHashTable::HandleEvent(wxEvent&amp;, wxEvtHandler*)" offset="0000009e"/>
    <frame level="15" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="000000b9"/>
    <frame level="16" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="17" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="18" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="19" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="20" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="21" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="22" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="23" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="24" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="25" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="26" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="27" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="28" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="29" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="30" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="31" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="00000050"/>
    <frame level="32"/>
    <frame level="33" function="g_closure_invoke" offset="00000109"/>
    <frame level="34"/>
    <frame level="35" function="g_signal_emit_valist" offset="00000855"/>
    <frame level="36" function="g_signal_emit" offset="00000083"/>
    <frame level="37" function="gtk_widget_activate" offset="0000006a"/>
    <frame level="38" function="gtk_menu_shell_activate_item" offset="00000100"/>
    <frame level="39"/>
    <frame level="40" function="_gtk_marshal_BOOLEAN__BOXED" offset="0000005d"/>
    <frame level="41" function="g_closure_invoke" offset="00000109"/>
    <frame level="42"/>
    <frame level="43" function="g_signal_emit_valist" offset="0000061e"/>
    <frame level="44" function="g_signal_emit" offset="00000083"/>
    <frame level="45"/>
    <frame level="46" function="gtk_propagate_event" offset="000000ae"/>
    <frame level="47" function="gtk_main_do_event" offset="00000357"/>
    <frame level="48"/>
    <frame level="49" function="g_main_context_dispatch" offset="000001b3"/>
    <frame level="50"/>
    <frame level="51" function="g_main_loop_run" offset="000001a6"/>
    <frame level="52" function="gtk_main" offset="000000a2"/>
    <frame level="53" function="wxEventLoop::Run()" offset="00000051"/>
    <frame level="54" function="wxAppBase::MainLoop()" offset="0000004b"/>
    <frame level="55"/>
    <frame level="56" function="wxEntry(int&amp;, wchar_t**)" offset="0000004c"/>
    <frame level="57" function="EditorBase::CreateContextSubMenu(int)" offset="000003b2"/>
  </stack>
</report>



--Ano

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 05 March 2007 build is out.
« Reply #4 on: March 06, 2007, 02:18:16 pm »
In the "Start here" panel, this version 3665 is dated 2007-02-10. It is nearly one month ago, but seems to correct bugs detected far more recently?

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 05 March 2007 build is out.
« Reply #5 on: March 06, 2007, 02:35:51 pm »
Did you compile C::B on your own? It may happen if svn.exe is not in PATH.
Be a part of the solution, not a part of the problem.

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 05 March 2007 build is out.
« Reply #6 on: March 06, 2007, 03:48:23 pm »
I get the crash reporter on Setting -> Editor (and most other Dialogs)
i am on amd64. I build it myself.

...

--Ano


Have you run update.bat (update.sh) after compiling ? This is required to update resource files.

BYO

Offline Silverling

  • Multiple posting newcomer
  • *
  • Posts: 18
Directory management
« Reply #7 on: March 06, 2007, 04:47:33 pm »
My project has grown quite a bit and now I am starting to organize stuff, putting files in (virtual) folders and stuff, but what I really needed is _real_ folders. How do I move objects around on the project explorer and in the file system at the same time? So far, what I do is remove the file from the project, move the file manually and the add it to the project again. How can I automate this process?

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 05 March 2007 build is out.
« Reply #8 on: March 06, 2007, 05:26:45 pm »
Did you compile C::B on your own? It may happen if svn.exe is not in PATH.

No, i did not compile CB on my own, and i don't know if i have svn.exe.

Offline Marenz

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: The 05 March 2007 build is out.
« Reply #9 on: March 06, 2007, 06:03:06 pm »

..

Have you run update.bat (update.sh) after compiling ? This is required to update resource files.

BYO

No i haven't ..
I just did...
cp failes 3 times:


revocer:/home/suprano/c++/codeblocks/trunk/src# ./update
Creating output directory tree
Compressing core UI resources
Compressing plugins UI resources
Packing core UI bitmaps
Packing plugins UI bitmaps
Copying files
cp: Aufruf von stat für „devel/codeblocks“ nicht möglich: Datei oder Verzeichnis nicht gefunden
cp: Aufruf von stat für „devel/*.so“ nicht möglich: Datei oder Verzeichnis nicht gefunden
cp: Aufruf von stat für „devel/share/codeblocks/plugins/*.so“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Stripping debug info from output tree
Creating launch-scripts


Datei oder Verzeichnis nicht gefunden == Dir/File not Found

i did make && make install after that.. but still crashes...
(do i need to do ./configure again then?)
this is debian btw


--Ano

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: The 05 March 2007 build is out.
« Reply #10 on: March 06, 2007, 06:25:41 pm »
revocer:/home/suprano/c++/codeblocks/trunk/src# ./update
If you really have a "#" in the path then this surely is the culprit. Please remove any # and $ from the path.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 05 March 2007 build is out.
« Reply #11 on: March 06, 2007, 07:26:50 pm »
No i haven't ..
I just did...
cp failes 3 times:


revocer:/home/suprano/c++/codeblocks/trunk/src# ./update
Creating output directory tree
Compressing core UI resources
Compressing plugins UI resources
Packing core UI bitmaps
Packing plugins UI bitmaps
Copying files
cp: Aufruf von stat für „devel/codeblocks“ nicht möglich: Datei oder Verzeichnis nicht gefunden
cp: Aufruf von stat für „devel/*.so“ nicht möglich: Datei oder Verzeichnis nicht gefunden
cp: Aufruf von stat für „devel/share/codeblocks/plugins/*.so“ nicht möglich: Datei oder Verzeichnis nicht gefunden
Stripping debug info from output tree
Creating launch-scripts


Datei oder Verzeichnis nicht gefunden == Dir/File not Found

i did make && make install after that.. but still crashes...
(do i need to do ./configure again then?)
this is debian btw


--Ano

Hmm, I assume you used ./configure make make install, so all files sohuld be updated automatically (in that case, ./update will try to put files in wrong directories). I've no idea what's wrong. IT really looks like code and xrc files are out of sync  :?. Have you tried make uninstall && make clean ?

BYO

Offline nenin

  • Multiple posting newcomer
  • *
  • Posts: 95
Re: The 05 March 2007 build is out.
« Reply #12 on: March 06, 2007, 07:59:49 pm »
I got an odd behavior with 2 last builds with gcc 4.1.2- during debugging sesssion attempt to add watch may lead to lost connection with gdb. svn 3627 works OK.

Offline Marenz

  • Multiple posting newcomer
  • *
  • Posts: 37
Re: The 05 March 2007 build is out.
« Reply #13 on: March 06, 2007, 09:28:48 pm »
Doh!
after
make uninstall && make clean && ./configure && make && make install
all was fine. It works again :)

TY !



[Edit]
MortenMacFly , the # was ofcourse part of my Promt

--Ano
« Last Edit: March 06, 2007, 09:47:21 pm by Suprano »

Offline Xaviou

  • Regular
  • ***
  • Posts: 302
    • X@v's wxStuff
Re: The 05 March 2007 build is out.
« Reply #14 on: March 06, 2007, 11:02:13 pm »
Ubuntu 6.10 Amd64 .deb installer is here.
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/