Author Topic: Side bar gone  (Read 4894 times)

Razor

  • Guest
Side bar gone
« on: July 11, 2005, 01:43:38 pm »
Well, call me an idiot, but a resized the side bar on the left till it completely dissapeared. Now I can't get it back! I originally did this because the whole bar had moved up such that I couldn't see the open files part of it. And I believe that happened because I tried to open a file (from windows) which was on the network.

The thing where the bar moves up so you can't see the open files window has happened before, and you can fix it by going into view and toggling some things. But I remembered wrong, and now I have no side bar. The worst thing is, it's saved somewhere and I can't just re-open codeblocks. It's totally gone!

I can forgive little problems like these in a program as good as this one, but I kinda need my side bar back, and it's an insane thing to reinstall over.

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Side bar gone
« Reply #1 on: July 11, 2005, 01:51:23 pm »
remove this registry tree
Code: [Select]
HKEY_CURRENT_USER\Software\Code::Blocks\Code::Blocks v1.0\main_frame
with all subtree items from your registry and restart CodeBlocks.

then the standard settings for displaying all panes are reinitialized.

Razor

  • Guest
Side bar gone
« Reply #2 on: July 11, 2005, 02:05:49 pm »
Worked perfectly! Thanks alot.

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Side bar gone
« Reply #3 on: July 11, 2005, 02:15:43 pm »
you'r welcome ;-)

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Side bar gone
« Reply #4 on: July 11, 2005, 05:35:36 pm »
Wait, shouldn't there be a measure to prevent this from happening?

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Side bar gone
« Reply #5 on: July 11, 2005, 05:48:27 pm »
this behaviour is already patched in cvs by you rick ! ( even if you didn't know it maybe )

it was induced by the bug, that the message-pane-height was reduced by 3 every time when restarting CB.
when the height was lower than 3 or already 1, then it happened, that the settings were completely messed, when the
rollover to -2 happened.
i got this a several times, investigated from how it was coming and wrote my bug-submission afterwards.
i needed the above registry hack a few times during testing this bug...

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Side bar gone
« Reply #6 on: July 11, 2005, 05:54:58 pm »
cool :D I feel like an involuntary hero :P