Author Topic: The 26 february 2007 build is out.  (Read 28000 times)

Online stahta01

  • Lives here!
  • ****
  • Posts: 6720
    • My Best Post
Re: The 26 february 2007 build is out.
« Reply #15 on: February 28, 2007, 01:15:37 am »
I have the same problem with Windows Vista and MinGW v3.4.5.  MinGW is installed to 'C:\MinGW' using there installer MinGW v5.1.3.exe. Is there any solution?

Have you tried adding the following to your complier "Additional Paths", Note 3.4.5 may not be what you are using so may need to change it.
Code: [Select]
c:\MinGW\libexec\gcc\mingw32\3.4.5
c:\MinGW\mingw32\bin

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 26 february 2007 build is out.
« Reply #16 on: February 28, 2007, 01:24:24 am »
Have you tried adding the following to your complier "Additional Paths", Note 3.4.5 may not be what you are using so may need to change it.
Code: [Select]
c:\MinGW\libexec\gcc\mingw32\3.4.5
c:\MinGW\mingw32\bin
Yes I did that already, and it gets me further, but it forgets all its includes and errors for stdio.h, string, and just about every other thing it can think of.  :shock:
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #17 on: February 28, 2007, 02:46:33 am »
Yes I did that already, and it gets me further, but it forgets all its includes and errors for stdio.h, string, and just about every other thing it can think of.  :shock:

Following article may be helpful. :)
Quote
http://aarongiles.com/?p=199
or
Quote
http://www.blitzbasic.com/Community/posts.php?topic=67297
« Last Edit: February 28, 2007, 02:48:29 am by Biplab »
Be a part of the solution, not a part of the problem.

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 26 february 2007 build is out.
« Reply #18 on: February 28, 2007, 04:54:10 am »
Following article may be helpful. :)
Quote
http://aarongiles.com/?p=199
or
Quote
http://www.blitzbasic.com/Community/posts.php?topic=67297

Well I have tried both and the same result.

Code: [Select]
:: === wxFlatNotebook, Release ===
C:\MinGW\include\stdio.h:26: stddef.h: No such file or directory
C:\MinGW\include\stdio.h:28: stdarg.h: No such file or directory
C:\MinGW\include\stdio.h:198: error: `size_t' has not been declared
C:\MinGW\include\stdio.h:198: error: ISO C++ forbids declaration of `parameter' with no type
...
C:\MinGW\include\stdio.h:213: error: `__gnuc_va_list' has not been declared
C:\MinGW\include\stdio.h:213: error: ISO C++ forbids declaration of `parameter' with no type
...
C:\MinGW\include\stdio.h:297: error: expected constructor, destructor, or type conversion before "fread"
C:\MinGW\include\stdio.h:298: error: expected constructor, destructor, or type conversion before "fwrite"
:: More errors follow but not being shown.
:: Edit the max errors limit in compiler options...
:: === Build finished: 50 errors, 0 warnings ===

So I started adding the include directories and then more weird results. I got it to compile now, but I can't link.
I added these to the Global Compiler Settings->Directories
Code: [Select]
C:\MinGW\include
C:\MinGW\include\c++\3.4.5
C:\MinGW\include\c++\3.4.5\mingw32
C:\MinGW\lib\gcc\mingw32\3.4.5\include
Added this to Global Compiler Settings->Programs->Additional Paths
Code: [Select]
C:\MinGW\libexec\gcc\mingw32\3.4.5
The error I get is:
Quote
Linking dynamic library: ..\..\..\..\bin\wxmsw28um_flatnotebook_gcc.dll
ld: dllcrt2.o: No such file: No such file or directory

Any other ideas?

Should I start a new thread?
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #19 on: February 28, 2007, 05:57:57 am »
Sorry, I don't have Vista and so I can't help you much. But if I get any interesting links, I'll inform you.

AFAIK, MinGW+Vista doesn't work properly. :)
Be a part of the solution, not a part of the problem.

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #20 on: February 28, 2007, 09:59:51 am »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.

As i said earlier, i think more of a menu problem than a wxSmith problem.
The laptop i use has only 512MB of RAM, which means only 50-100MB left for CB. That surely explains partially why CB crashes more easily on it than on other computers.

I'm trying your suggestion.

EDIT: with keybinder plugin disabled, CB crashed. It makes sense, as in all my tests, both yersterday and today, i only used the mouse, NEVER the keyboard.
Currently testing other plugin disabled.
« Last Edit: February 28, 2007, 10:17:18 am by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #21 on: February 28, 2007, 10:22:05 am »
Edit 1: Removed crash log. It was due to codeblocks.dll mismatch.

If I get any crash log, I'll post it.



@Mandrav

While attaching any file (I tried uploading *.7z files) I'm getting the following error.
Quote
An Error Has Occurred!
Cannot access attachments upload path!



Edit 2: I faced crash finally. This time I've recompiled all the plugins. I've logged two crashes. Both of them are pointing to wxSmith.

I'm posting a portion of one log.

Quote
#2  0x061b271f in wxsItemFactory::ItemMapT_wxImplementation_HashTable::GetNode
    (this=0x6241b78, [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
        bucket = 0
        node = (
    wxsItemFactory::ItemMapT_wxImplementation_HashTable::Node *) 0x77c2c2e3
#3  0x0617ac6c in wxsItemFactory::ItemMapT::find (this=0x6241b78,    [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
No locals.
#4  0x060c6f2f in wxsItemFactory::~wxsItemFactory (this=0x623ee30)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.cpp:115
        it = {<wxsItemFactory::ItemMapT_wxImplementation_HashTable::Iterator> =
{m_node = 0x1, m_ht = 0x0}, <No data fields>}
#5  0x0618cc04 in wxsRegisterItem<wxsStaticBitmap>::~wxsRegisterItem (    this=0x623ee30)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:28
No locals.
#6  0x0604e0a2 in __static_initialization_and_destruction_0 (__initialize_p=0,    __priority=65535)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:28
No locals.
#7  0x0604e110 in global destructors keyed to _ZN116_GLOBAL__N_C__DevTools_CBSou
rce_src_plugins_contrib_wxSmith_wxwidgets_defitems_wxsstaticbitmap.cpp_BC39A452_
140AEB783RegE ()
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:103
No locals.

Full log can be downloaded from-

http://www.fileden.com/files/4628/CrashLog_CB_r3648.7z

Regards,

Biplab
« Last Edit: February 28, 2007, 10:47:27 am by Biplab »
Be a part of the solution, not a part of the problem.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 26 february 2007 build is out.
« Reply #22 on: February 28, 2007, 11:56:32 am »
@Mandrav

While attaching any file (I tried uploading *.7z files) I'm getting the following error.
Quote
An Error Has Occurred!
Cannot access attachments upload path!

Thanks for notifying me, should be fixed now.
Be patient!
This bug will be fixed soon...

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 26 february 2007 build is out.
« Reply #23 on: February 28, 2007, 08:05:39 pm »
Edit 2: I faced crash finally. This time I've recompiled all the plugins. I've logged two crashes. Both of them are pointing to wxSmith.

I'm posting a portion of one log.

Quote
#2  0x061b271f in wxsItemFactory::ItemMapT_wxImplementation_HashTable::GetNode
    (this=0x6241b78, [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
        bucket = 0
        node = (
    wxsItemFactory::ItemMapT_wxImplementation_HashTable::Node *) 0x77c2c2e3
#3  0x0617ac6c in wxsItemFactory::ItemMapT::find (this=0x6241b78,    [email protected])
    at ...

Jay, looks like some wxString which has been killed but is still used inside  hash table... it may take a while before I'll fix it. The most strange thing here is that crash happen occasionally ...  :?

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #24 on: March 01, 2007, 10:02:53 am »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.

After lots of test and a finger-ache:
  • With keybinder plugin disabled => CB continues to crash (I used only the mouse)
  • With wxSmith also disabled => Impossible to crash CB
« Last Edit: March 01, 2007, 10:38:25 am by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #25 on: March 02, 2007, 11:04:56 am »
I downloaded and installed nightly build of 1 mars 2007.
I launched it then exited immediately => exactly the same crash with same instruction address. This time without clicking on any menu item (except for exiting), nor even wxSmith!