Author Topic: The 26 february 2007 build is out.  (Read 28009 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5209
The 26 february 2007 build is out.
« on: February 27, 2007, 09:47:56 am »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2.7z

To fix the menu alignment bug introduced in wx 2.6.3 [windows only bug] we have patched wx ourselves, and that results in the following alternative dll : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2AndCbPatch_version3.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26_gcc_cb_wx2.6.3p2.7z

The 26 February 2007 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20070226_rev3645_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20070226_rev3645_Ubuntu6.xx.deb
         http://prdownload.berlios.de/codeblocks/CB_20070226_rev3645_suse100-102.i586.rpm (not yet)
         http://prdownload.berlios.de/codeblocks/CB_20070226_rev3645_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • wxWidgets Wizard:
    * Wizard now supports creation of wxDialog / wxFrame based app.
    * Wizard now supports wxFormBuilder to be selected as 3rd-Party GUI Builder alongwith wxDialog / wxFrame option.
    * PCH include header has been reverted to wx_pch.h and PCH Pre-Processor definition is changed to WX_PRECOMP
    * EVT_CLOSE has been added in all templates to ensure proper exit

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • menu items with icon not correctly aligned (since wx263) (is fixed with our special wx263/wx28 dll)

« Last Edit: February 27, 2007, 09:06:34 pm by killerbot »

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #1 on: February 27, 2007, 10:28:42 am »
On XP Pro, i installed this build, opened CB then immediately clicked on all options in the wxSmith menu => nothing happened (apart from my frustration and a CB crash)

Is it normal? Should not this options be greyed at the beginning?

Offline Jewe

  • Multiple posting newcomer
  • *
  • Posts: 70
    • Fit Trainer
Re: The 26 february 2007 build is out.
« Reply #2 on: February 27, 2007, 03:26:34 pm »
RSS feed not updated.?
or is it just my browser that has the problem?  :lol:
Last version was 2007-02-21

cheers,

Jeffrey
Anything curved in the hardware can be straighten with software :D
OS: Vista64 + Debian(to play with)
Compiler: mingw IDE: Code::Blocks Nightly WX: 2.8.0

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5209
Re: The 26 february 2007 build is out.
« Reply #3 on: February 27, 2007, 04:09:13 pm »
nope, because I normally do this from home. But due to moving on the forum, I could not post yesterday evening and as such no link where the rss entry could point to. Will be updated this evening.

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #4 on: February 27, 2007, 04:36:24 pm »
On XP Pro, i installed this build, opened CB then immediately clicked on all options in the wxSmith menu => nothing happened (apart from my frustration and a CB crash)

Is it normal? Should not this options be greyed at the beginning?

I reproduced the crash: if you click several times on the wxSmith options, then File|Quit, CB exits with the message box (personnal translation)
[...] memory cannot be "read".
Click OK to exit the program.


Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 26 february 2007 build is out.
« Reply #5 on: February 27, 2007, 04:50:49 pm »
On XP Pro, i installed this build, opened CB then immediately clicked on all options in the wxSmith menu => nothing happened (apart from my frustration and a CB crash)

Is it normal? Should not this options be greyed at the beginning?

I couldn't make it happen :? Can you provide some more info ? CPU speed, do you use "fixed" wxWidgets lib, post codeblocks.RPT file (it's crash report placed in same dir where codeblocks.exe)

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #6 on: February 27, 2007, 05:15:50 pm »
On XP Pro, i installed this build, opened CB then immediately clicked on all options in the wxSmith menu => nothing happened (apart from my frustration and a CB crash)

Is it normal? Should not this options be greyed at the beginning?

I couldn't make it happen :? Can you provide some more info ? CPU speed, do you use "fixed" wxWidgets lib, post codeblocks.RPT file (it's crash report placed in same dir where codeblocks.exe)
CPU Speed: 2GHz
No lib, no .RPT: i just installed, opened CB, used the menu without any CB response, then Quit => Crash

The message box appeared after CB windows disappeared: maybe that's why there wasn't any rpt file.

For the first crash, i had clicked 4 times on the wxSmith options, and all 3 were chosen at least one time.
For the second, i had clicked 20 or 30 times randomly and quickly on the wxSmith options.

Finally, i didn't try on clicking on other options than wxSmith: maybe a menu problem? will try

EDIT: Another crash.
I clicked not so quickly a dozen times on the wxSmith options.
I confirm, no rpt file.
The message box says (personnal translation):

[Title]codeblocks.exe - Application error
The instruction at "0x61a031a6" use memory address "0x02400eac". Memory cannot be "read".
Click on OK to terminate the program.


The 2 addresses above are the real ones on the message box.
« Last Edit: February 27, 2007, 05:44:21 pm by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #7 on: February 27, 2007, 05:28:59 pm »
I don't want to add more confusion to this problem.

I did notice this problem. But NOT with wxSmith. I was working with compiler plugin and found in some cases it's showing similar problem.

So my guess, it could be some other part which is causing the problem.

I can remember one instance when the compilation stopped due to some errors and I was shutting C::B down and it threw that message. Will try to gather more information on that. :)
Be a part of the solution, not a part of the problem.

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #8 on: February 27, 2007, 06:03:57 pm »
I now reproduce it easily on XP Pro.

1) open CB
2) 6 times:
  • Click on wxSmith|Add wxPanel   [No response expected]
  • Click on wxSmith|Configure wxSmith for current project   [No response expected]
3) Click on File|Quit
4) If no crash message, try again steps 1 to 3, with a greater value at step 2: 7, 8, 9, 10, 11, 12
If it crashes at a given value, you have to increases the loop value to crash again CB.

The dialogbox always says
[Title]codeblocks.exe - Application error
The instruction at "0x61a031a6" use memory address "0x02400eac". Memory cannot be "read".
Click on OK to terminate the program.


The instruction address is always the same.
The memory address is either "0x02400eac" or a number not far away.
« Last Edit: February 27, 2007, 06:06:54 pm by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline Xaviou

  • Regular
  • ***
  • Posts: 307
    • X@v's wxStuff
Re: The 26 february 2007 build is out.
« Reply #9 on: February 27, 2007, 06:35:27 pm »
Hi all.
I tried to make an Ubuntu 6.10 Amd64 package.

Can someone try it, and give feedback, please.

You can find it here.

[Edit] Link wasn't working : updated. :?
« Last Edit: February 28, 2007, 01:46:16 pm by Xaviou »
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9524
Re: The 26 february 2007 build is out.
« Reply #10 on: February 27, 2007, 07:36:40 pm »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 26 february 2007 build is out.
« Reply #11 on: February 28, 2007, 12:13:09 am »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.

The only thing that comes into my mind is invalid order of destruction of static object instances. wxSmith uses both static global member variables and static variables in function. But if that the cause, it will be compiler's fault :(

Offline watt

  • Multiple posting newcomer
  • *
  • Posts: 26
Re: The 26 february 2007 build is out.
« Reply #12 on: February 28, 2007, 12:34:23 am »
Hi!


How i can resolve this problem ...

Compiling: main.cpp
mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

Online stahta01

  • Lives here!
  • ****
  • Posts: 6727
    • My Best Post
Re: The 26 february 2007 build is out.
« Reply #13 on: February 28, 2007, 12:57:47 am »
Hi!


How i can resolve this problem ...

Compiling: main.cpp
mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

Install and Setup minGW right.
What OS?
What mingGW?
How was it installed? Unpacked files? Used exe? Which files?
What is the directory path minGW was installed in? C:\minGW or where else?
Tim S
« Last Edit: February 28, 2007, 01:01:59 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 26 february 2007 build is out.
« Reply #14 on: February 28, 2007, 01:02:51 am »
Hi!


How i can resolve this problem ...

Compiling: main.cpp
mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings
I have the same problem with Windows Vista and MinGW v3.4.5.  MinGW is installed to 'C:\MinGW' using there installer MinGW v5.1.3.exe. Is there any solution?

I think I am about done with Vista for a while. It won't work with VNC (RealVNC free, UltraVNC, or TightVNC) either. It just keeps getting in my way. It is also just so different I should just switch to Linux for good now. Microsoft is out of there mind! Sorry my rant is over.
« Last Edit: February 28, 2007, 01:05:34 am by RJP Computing »
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Online stahta01

  • Lives here!
  • ****
  • Posts: 6727
    • My Best Post
Re: The 26 february 2007 build is out.
« Reply #15 on: February 28, 2007, 01:15:37 am »
I have the same problem with Windows Vista and MinGW v3.4.5.  MinGW is installed to 'C:\MinGW' using there installer MinGW v5.1.3.exe. Is there any solution?

Have you tried adding the following to your complier "Additional Paths", Note 3.4.5 may not be what you are using so may need to change it.
Code: [Select]
c:\MinGW\libexec\gcc\mingw32\3.4.5
c:\MinGW\mingw32\bin

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 26 february 2007 build is out.
« Reply #16 on: February 28, 2007, 01:24:24 am »
Have you tried adding the following to your complier "Additional Paths", Note 3.4.5 may not be what you are using so may need to change it.
Code: [Select]
c:\MinGW\libexec\gcc\mingw32\3.4.5
c:\MinGW\mingw32\bin
Yes I did that already, and it gets me further, but it forgets all its includes and errors for stdio.h, string, and just about every other thing it can think of.  :shock:
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #17 on: February 28, 2007, 02:46:33 am »
Yes I did that already, and it gets me further, but it forgets all its includes and errors for stdio.h, string, and just about every other thing it can think of.  :shock:

Following article may be helpful. :)
Quote
http://aarongiles.com/?p=199
or
Quote
http://www.blitzbasic.com/Community/posts.php?topic=67297
« Last Edit: February 28, 2007, 02:48:29 am by Biplab »
Be a part of the solution, not a part of the problem.

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 26 february 2007 build is out.
« Reply #18 on: February 28, 2007, 04:54:10 am »
Following article may be helpful. :)
Quote
http://aarongiles.com/?p=199
or
Quote
http://www.blitzbasic.com/Community/posts.php?topic=67297

Well I have tried both and the same result.

Code: [Select]
:: === wxFlatNotebook, Release ===
C:\MinGW\include\stdio.h:26: stddef.h: No such file or directory
C:\MinGW\include\stdio.h:28: stdarg.h: No such file or directory
C:\MinGW\include\stdio.h:198: error: `size_t' has not been declared
C:\MinGW\include\stdio.h:198: error: ISO C++ forbids declaration of `parameter' with no type
...
C:\MinGW\include\stdio.h:213: error: `__gnuc_va_list' has not been declared
C:\MinGW\include\stdio.h:213: error: ISO C++ forbids declaration of `parameter' with no type
...
C:\MinGW\include\stdio.h:297: error: expected constructor, destructor, or type conversion before "fread"
C:\MinGW\include\stdio.h:298: error: expected constructor, destructor, or type conversion before "fwrite"
:: More errors follow but not being shown.
:: Edit the max errors limit in compiler options...
:: === Build finished: 50 errors, 0 warnings ===

So I started adding the include directories and then more weird results. I got it to compile now, but I can't link.
I added these to the Global Compiler Settings->Directories
Code: [Select]
C:\MinGW\include
C:\MinGW\include\c++\3.4.5
C:\MinGW\include\c++\3.4.5\mingw32
C:\MinGW\lib\gcc\mingw32\3.4.5\include
Added this to Global Compiler Settings->Programs->Additional Paths
Code: [Select]
C:\MinGW\libexec\gcc\mingw32\3.4.5
The error I get is:
Quote
Linking dynamic library: ..\..\..\..\bin\wxmsw28um_flatnotebook_gcc.dll
ld: dllcrt2.o: No such file: No such file or directory

Any other ideas?

Should I start a new thread?
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #19 on: February 28, 2007, 05:57:57 am »
Sorry, I don't have Vista and so I can't help you much. But if I get any interesting links, I'll inform you.

AFAIK, MinGW+Vista doesn't work properly. :)
Be a part of the solution, not a part of the problem.

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #20 on: February 28, 2007, 09:59:51 am »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.

As i said earlier, i think more of a menu problem than a wxSmith problem.
The laptop i use has only 512MB of RAM, which means only 50-100MB left for CB. That surely explains partially why CB crashes more easily on it than on other computers.

I'm trying your suggestion.

EDIT: with keybinder plugin disabled, CB crashed. It makes sense, as in all my tests, both yersterday and today, i only used the mouse, NEVER the keyboard.
Currently testing other plugin disabled.
« Last Edit: February 28, 2007, 10:17:18 am by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 26 february 2007 build is out.
« Reply #21 on: February 28, 2007, 10:22:05 am »
Edit 1: Removed crash log. It was due to codeblocks.dll mismatch.

If I get any crash log, I'll post it.



@Mandrav

While attaching any file (I tried uploading *.7z files) I'm getting the following error.
Quote
An Error Has Occurred!
Cannot access attachments upload path!



Edit 2: I faced crash finally. This time I've recompiled all the plugins. I've logged two crashes. Both of them are pointing to wxSmith.

I'm posting a portion of one log.

Quote
#2  0x061b271f in wxsItemFactory::ItemMapT_wxImplementation_HashTable::GetNode
    (this=0x6241b78, [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
        bucket = 0
        node = (
    wxsItemFactory::ItemMapT_wxImplementation_HashTable::Node *) 0x77c2c2e3
#3  0x0617ac6c in wxsItemFactory::ItemMapT::find (this=0x6241b78,    [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
No locals.
#4  0x060c6f2f in wxsItemFactory::~wxsItemFactory (this=0x623ee30)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.cpp:115
        it = {<wxsItemFactory::ItemMapT_wxImplementation_HashTable::Iterator> =
{m_node = 0x1, m_ht = 0x0}, <No data fields>}
#5  0x0618cc04 in wxsRegisterItem<wxsStaticBitmap>::~wxsRegisterItem (    this=0x623ee30)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:28
No locals.
#6  0x0604e0a2 in __static_initialization_and_destruction_0 (__initialize_p=0,    __priority=65535)
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:28
No locals.
#7  0x0604e110 in global destructors keyed to _ZN116_GLOBAL__N_C__DevTools_CBSou
rce_src_plugins_contrib_wxSmith_wxwidgets_defitems_wxsstaticbitmap.cpp_BC39A452_
140AEB783RegE ()
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/defitems/wxsstaticbitmap.cpp:103
No locals.

Full log can be downloaded from-

http://www.fileden.com/files/4628/CrashLog_CB_r3648.7z

Regards,

Biplab
« Last Edit: February 28, 2007, 10:47:27 am by Biplab »
Be a part of the solution, not a part of the problem.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 26 february 2007 build is out.
« Reply #22 on: February 28, 2007, 11:56:32 am »
@Mandrav

While attaching any file (I tried uploading *.7z files) I'm getting the following error.
Quote
An Error Has Occurred!
Cannot access attachments upload path!

Thanks for notifying me, should be fixed now.
Be patient!
This bug will be fixed soon...

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 26 february 2007 build is out.
« Reply #23 on: February 28, 2007, 08:05:39 pm »
Edit 2: I faced crash finally. This time I've recompiled all the plugins. I've logged two crashes. Both of them are pointing to wxSmith.

I'm posting a portion of one log.

Quote
#2  0x061b271f in wxsItemFactory::ItemMapT_wxImplementation_HashTable::GetNode
    (this=0x6241b78, [email protected])
    at C:/DevTools/CBSource/src/plugins/contrib/wxSmith/wxwidgets/wxsitemfactory.h:73
        bucket = 0
        node = (
    wxsItemFactory::ItemMapT_wxImplementation_HashTable::Node *) 0x77c2c2e3
#3  0x0617ac6c in wxsItemFactory::ItemMapT::find (this=0x6241b78,    [email protected])
    at ...

Jay, looks like some wxString which has been killed but is still used inside  hash table... it may take a while before I'll fix it. The most strange thing here is that crash happen occasionally ...  :?

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #24 on: March 01, 2007, 10:02:53 am »
I now reproduce it easily on XP Pro.
Sorry, I couldn't. I really tried as you have described with all those steps but no crash. (Anyway - I'm kind of nuts now ;-)).
Could you try to disabled plugins step-by-step (e.g. starting with the keybinder plugin) and see if at some points the crash disappears?
It sounds really strange anyway! Because actually (if I look at the wxSmith code) her really happens just *nothing* whenever you click such a menu item. So I'm pretty sure that wxSmith is not the issue.
With regards, Morten.

After lots of test and a finger-ache:
  • With keybinder plugin disabled => CB continues to crash (I used only the mouse)
  • With wxSmith also disabled => Impossible to crash CB
« Last Edit: March 01, 2007, 10:38:25 am by ascxaxsvcbsxbbqvcxqsbcvxs »

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 26 february 2007 build is out.
« Reply #25 on: March 02, 2007, 11:04:56 am »
I downloaded and installed nightly build of 1 mars 2007.
I launched it then exited immediately => exactly the same crash with same instruction address. This time without clicking on any menu item (except for exiting), nor even wxSmith!