Author Topic: Problems compiling with minigw/standard install.  (Read 6610 times)

Offline glenneaux

  • Single posting newcomer
  • *
  • Posts: 3
Problems compiling with minigw/standard install.
« on: March 19, 2007, 07:47:46 am »
Hey everyone

I've installed code::blocks with minigw and i'm under the impression that i can create a windows console program and should just be able to compile/run the stock code provided by code::blocks, this however is not the case.

The first problem i run into is:

Switching to target: default
Compiling: main.cpp
mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory

I've mucked around and gotten past this point and end up running into the problem of not being able to find iostream. Once i point the compiler at that file i then get heaps of other errors.

now my point is I don't think i should be jumping through these hoops and assume somethings been missed along the way...

I'm running Windows Vista 64bit but dont think this should affect whats going on but i wouldnt be suprised.


If anyone's got any pointers or can help at all i'd really appreciate it.

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Problems compiling with minigw/standard install.
« Reply #1 on: March 19, 2007, 08:20:01 am »
I'm running Windows Vista 64bit but dont think this should affect whats going on but i wouldnt be suprised.
Yes, this does affect things. Vista just isn't compatible with anything...

I don't remember what you have to do (I think it was one path to add somewhere, or set an environment variable) but you'll find it by searching the forum for "Vista" - there are a few topics on that very problem.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline glenneaux

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problems compiling with minigw/standard install.
« Reply #2 on: March 19, 2007, 10:13:39 am »
ah ok.

Didnt realise my problems were vista related.

Having said that I haven't had any problems running anything else with 64bit vista.

Offline glenneaux

  • Single posting newcomer
  • *
  • Posts: 3
Re: Problems compiling with minigw/standard install.
« Reply #3 on: March 19, 2007, 10:20:43 am »
I looked around and foudn this:

http://forums.codeblocks.org/index.php/topic,4692.0.html

The last post has my problem, but like i said in my original post i make it to code::blocks can see that program but then i get more problems....

attatched is the log...



[attachment deleted by admin]