Author Topic: link errors  (Read 10223 times)

tksuoran

  • Guest
Re: link errors
« Reply #15 on: August 30, 2005, 08:48:20 am »
I'm having the same problem with gcc 4. It looks like gcc 4 really wants those virtual destructors. I get lots of warnings that they are missing, and then linking fails.

Offline zieQ

  • Almost regular
  • **
  • Posts: 155
Re: link errors
« Reply #16 on: August 30, 2005, 09:57:53 am »
I think that, in the C++ standard, virtual destructors are not mandatory. It seems to be a bug from gcc4.
Anyway, it's a good habit to use virtual destructors, so IMHO we should change all the offending destructors in C::B!

Link5225

  • Guest
Re: link errors
« Reply #17 on: October 19, 2005, 01:27:40 am »
Any progress on this yet?  I use Fedora Core 4 with gcc 4.0, and I'd really like to try out Code::Blocks.  I've been running into a few problems trying to compile gcc 3.4 from source, so I'd rather just be able to compile with 4.0.  Is there any easy way to fix this?

EDIT:  Okay, turns out it does work if I use wxWidgets 2.6.2 and the CVS version of C::B (downloaded at night on Oct 18, whatever version that might be).  From there I just followed the instructions on the wiki, including the bootstrapping and everything shown at the bottom.  Hopefully whatever was fixed to get rid of the 'undefined reference to vtable' errors will be included in the actual release sometime soon.
« Last Edit: October 20, 2005, 02:58:53 am by Link5225 »