Author Topic: Showing symbols in the call stack window.  (Read 2157 times)

Offline orefa

  • Multiple posting newcomer
  • *
  • Posts: 102
Showing symbols in the call stack window.
« on: February 16, 2007, 03:32:18 am »
The call stack debugging window shows Addresses but not Function, File and Line information. Debug is on, I can step, set breakpoints, everything works fine except the call stack window. Any idea?


EDIT: Build 2007 Feb 14, Windows 2000, gcc.
« Last Edit: February 16, 2007, 03:40:10 am by orefa »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6636
    • My Best Post
Re: Showing symbols in the call stack window.
« Reply #1 on: February 16, 2007, 03:44:39 am »
I don't use the debugger so this could be wrong/obvious etc.

But, the posts on debug always asked if you have -g option set.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline orefa

  • Multiple posting newcomer
  • *
  • Posts: 102
Re: Showing symbols in the call stack window.
« Reply #2 on: February 16, 2007, 03:53:24 am »
Yes, debug is on and I have symbols elsewhere. I have also added the literal -g in "other options" in addition to setting the check box in the build options to be sure (but it disappears, probably because there is a GUI option to set it instead).

Offline orefa

  • Multiple posting newcomer
  • *
  • Posts: 102
Re: Showing symbols in the call stack window.
« Reply #3 on: February 16, 2007, 05:11:41 pm »
Hum, symbols now appear...  once in a while. I didn't change anything but I set breakpoints at different locations. In some places I can get the info, in others I cannot. It acts as though the debugger does not always have access to symbols so it is probably a GDB problem rather than a CB problem.