Author Topic: The 03 february 2007 build is out.  (Read 17272 times)

Offline steveth45

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: The 03 february 2007 build is out.
« Reply #15 on: February 05, 2007, 12:13:24 pm »
I turned off the 3D desktop (Xgl) and, strangely enough, that fixed the problem with the selection box.  It wasn't very stable with 3D applications, anyways.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5234
Re: The 03 february 2007 build is out.
« Reply #16 on: February 05, 2007, 12:31:49 pm »
I turned off the 3D desktop (Xgl) and, strangely enough, that fixed the problem with the selection box.  It wasn't very stable with 3D applications, anyways.

I am still linux newbie. So a few questions :
a) how can I check I have the 3D desktop (to be honest nothing really looks 3D)
b) how can I turn it off in case it was turned on



Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 03 february 2007 build is out.
« Reply #17 on: February 05, 2007, 12:36:10 pm »
I turned off the 3D desktop (Xgl) and, strangely enough, that fixed the problem with the selection box.  It wasn't very stable with 3D applications, anyways.

I am still linux newbie. So a few questions :
a) how can I check I have the 3D desktop (to be honest nothing really looks 3D)
b) how can I turn it off in case it was turned on

Are you using OpenSUSE?? If yes then I'll restart my PC in Linux to tell you how you can run it. ;)

I've tried running XGL. But my PC doesn't have appropriate Graphics card to run it.  :(
Be a part of the solution, not a part of the problem.

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5234
Re: The 03 february 2007 build is out.
« Reply #18 on: February 05, 2007, 01:28:57 pm »
OpenSuse 10.2 (64 bit)

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 03 february 2007 build is out.
« Reply #19 on: February 05, 2007, 02:22:04 pm »
@Killerbot, I'm very sorry.  :oops:  I'm now out of lab. So no access to my Linux PC. Will post it tomorrow.
Be a part of the solution, not a part of the problem.

Offline Charon

  • Multiple posting newcomer
  • *
  • Posts: 49
  • fnord
    • charon - where mental illness meets chronic nonsense
Re: The 03 february 2007 build is out.
« Reply #20 on: February 05, 2007, 08:24:22 pm »
@killerbot : some linux-distribution now run AIGLX by default (which in itself just provides the 3D-funktionality) but don't use a compositing window-manager. i don't know if SuSE10.2 is one of these distributions, but it might be. if you don't see any fancy 3D-effects like wobbly windows etc. you might still have AIGLX activated.

try
vi /etx/X11/xorg.conf
and look out for the line
Option         "AIGLX" "true"

set it to false, restart your x-server and see if it works.


good luck
Markus
hi, i am a signature virus. please copy me into your sig!
Wish list : no root-node for workspaces, open files and symbols; world domination

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 03 february 2007 build is out.
« Reply #21 on: February 05, 2007, 08:46:36 pm »
without activating aiglx by hand (adding the line charon wrote), it's deactivated (suse prefers xgl, since novell developed it).
xgl should be visible in the process tree since it is its own xserver on top of the real xserver. if pstree | grep -i xgl shows a xgl process xgl is activated, if not your not using the 3d-specials. ;)

but to be sure, also look if aiglx is activated too.  :)
Nightly builds for openSUSE

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5234
Re: The 03 february 2007 build is out.
« Reply #22 on: February 05, 2007, 09:23:54 pm »
none of them show up in the pstree

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 03 february 2007 build is out.
« Reply #23 on: February 06, 2007, 07:25:32 am »
Goto Computer > Control Center > Desktop Effects. Now a Window will pop-up. Try changing some settings there. In my PC all the options in this window are disabled. So can't help further.
Be a part of the solution, not a part of the problem.

Offline steveth45

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: The 03 february 2007 build is out.
« Reply #24 on: February 06, 2007, 09:23:19 am »
I turned off the 3D desktop (Xgl) and, strangely enough, that fixed the problem with the selection box.  It wasn't very stable with 3D applications, anyways.

Umm, false alarm.  For some reason, it did work after I turned off the 3D desktop, but now I am seeing the problem again.  Maybe it worked because I had just rebooted or something.  Anyways, Xgl is not the cause of the problem, it is something else SUSE related.  I did download a bunch of updates the other day, and I don't remember seeing the problem before then, so possibly one of the updates triggered the problem, or that's another red herring.  Continue with your 3D desktops, just don't try to run OpenGL things full screen, or if you do, make sure to save everything in case X crashes.

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 03 february 2007 build is out.
« Reply #25 on: February 06, 2007, 10:40:45 am »
Same here. I tested it with rev3562 and the build target combo didn't disappear, then installed the current nightly and had the same problem.
Now I switched back to rev3562 and have the problem, too  :shock:
Nightly builds for openSUSE