Author Topic: Code::Blocks closes after compiling project  (Read 3105 times)

Offline RKovach

  • Single posting newcomer
  • *
  • Posts: 3
Code::Blocks closes after compiling project
« on: June 21, 2005, 07:26:48 pm »
Perhaps I am the only one with this problem as I can't seem to find any reference to it. I have wxWidgets 2.4.2, compiled on Fedora Core 3 using --with-gtk --enable-gtk2 and no unicode support enabled. I am using Code::Blocks 1.0 final beta. Everything in the default directories.

Everything built and Code::Blocks runs fine, but when I compile a project (wxWidgets or console) then try to compile again, Code::Blocks closes. No error, just closes. From that point on anytime I try to compile the project, Code:Blocks closes. If I "clean" or "rebuild" it will once again compile until the next error.

Any ideas?

Thanks...Randy

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Code::Blocks closes after compiling project
« Reply #1 on: June 21, 2005, 11:04:00 pm »
Read this thread.
It has been fixed in CVS.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline RKovach

  • Single posting newcomer
  • *
  • Posts: 3
Code::Blocks closes after compiling project
« Reply #2 on: June 22, 2005, 02:17:43 am »
Thank you. I just got the CVS and compiled. Now at least it gives me an error. When I re-compile I get a dialog that says:

Something has gone wrong inside Code::Blocks and it will terminate immediately.
We are sorry for the inconvenience...

then at the command prompt:

output/run.sh: line 5: 14654 Aborted                 $APP_DIR/codeblocks.exe [email protected]

Thanks...Randy

Offline RKovach

  • Single posting newcomer
  • *
  • Posts: 3
Code::Blocks closes after compiling project
« Reply #3 on: June 22, 2005, 09:47:36 pm »
I just applied the patch ([ 1224472 ] regcomp errors) to the 1.0 Final Beta code and it solves the problem! I am now up and running.

Thank you. :D

Randy