Author Topic: Newbie trouble PLEASE help...  (Read 2024 times)

Nierd

  • Guest
Newbie trouble PLEASE help...
« on: April 24, 2008, 04:40:58 pm »
Hi all.
Really nice to have so many 'gurus' in one place.
I am at a loss for a solution to my problem....

My project involves something called 'OpenCV'. it is Intel's open source Computer Vision libraries, kinda like DIRECTX  or DIRECTSHOW.
used to be, in the carefree days of stupefying MSVS5, I would just set “Additional Include Directives” in the C/C++ pane under the project properties. Then i would go to project->properties->linker->Under the Linker tab select “Input”->Select the “Additional Dependencies”->Add the full path to each of the “.lib” files required to use OpenCV
e.g-"C:\Program Files\OpenCV\lib\cv.lib"
I had to do it in quotes....
now, no matter what I do it does not seem to be working. the best thing i did was follow Deschamps advice about writing the full path of the include directives, but since libraries and other references are involved, i get tossed out when some .h file calls on another.
what is the Code::Blocks parallel to the actions above????
Hope to be of help myself one day...
thanx.


grahamham2000

  • Guest
Re: Newbie trouble PLEASE help...
« Reply #1 on: June 08, 2008, 07:37:49 pm »
I am kind of confused, but my advice would be > Settings > Compiler and debugger...
Then from there go to the the "Linker Settings" tab
Then add the openCV libraries remember to add all of them (ml.lib highgui.lib CXTS.lib cv.lib...) (there are 8 in total)
Then you can add the cv.h (and others) files to somewhere similar to here "C:\Program Files\CodeBlocks\MinGW\include\openCV"
This should work if you are using the standard GCC compiler.