Author Topic: Serious performance issues on Ubuntu 6.10  (Read 9535 times)

Offline hendrik

  • Single posting newcomer
  • *
  • Posts: 6
Re: Serious performance issues on Ubuntu 6.10
« Reply #15 on: January 15, 2007, 08:25:05 am »
Maybe I have an solution for you. I had similar problems mentioned above; even moving the mouse over the C::B window brought increasing CPU usage.

My System is:
Ubuntu 6.10
wxWidgets 2.6.3 (manual Installation)
Code::Blocks 3455 (had also some older versions before; all plugins can be enabled)

The problem seemed to occure after configuring wxWidgets with --enable-debug-Flag. When starting and working within C::B the console showed many warnings and the CPU usage increased heavily.

After configuring wxWidgets without --enable-debug-Flag and C::B with disable-debug-Flag, C::B worked perfectly, except for the annoying copy-n'-paste-bug - C::B crashes often when pasting something. There are some threads according the copy-n'-paste-bug.

This looks like it is worth a try, although I doubt it will solve the problem for most people here. It would be rather strange for the Ubuntu wxWidgets package (which most people here will use with CodeBlocks) being compiled with debug flags enabled.

@Grom I don't think that the problems are generated by wrong or badly configured video drivers. As I mentioned before, the problem only occurs in CodeBlocks, it does not occur in any other wx application like Stanis Python Editor or wxMaxima.
« Last Edit: January 15, 2007, 08:26:54 am by hendrik »

Dunny

  • Guest
Re: Serious performance issues on Ubuntu 6.10
« Reply #16 on: January 16, 2007, 11:10:52 pm »
Just thought I'd add that I get the same problems with code::blocks (all nightly builds and/since latest "stable"). Under WinXP Pro.

1.7ghz Celeron, 512mb RAM. All plugins disabled.

C::B consumes around 10% CPU with no projects loaded, idling in the background. When any projects are loaded, CPU usage goes to 25-30% (when idling). When actually working in C::B, I get 80-90% CPU usage when typing.

D.

Offline hendrik

  • Single posting newcomer
  • *
  • Posts: 6
Re: Serious performance issues on Ubuntu 6.10
« Reply #17 on: January 22, 2007, 08:55:52 pm »
Okay, I build the wx libraries and codeblocks by myself with -O3 and no debug info on three different machines running Ubuntu 6.06 and Suse 10.1. All machines show the same serious performance penality. Looks like I'm still stucked to KDevelop then under linux.

Offline Grom

  • Almost regular
  • **
  • Posts: 206
Re: Serious performance issues on Ubuntu 6.10
« Reply #18 on: January 23, 2007, 02:50:52 am »
Try to use profiler to find out which part takes all CPU time. It is helpful with that type problems.
gcc+winXP+suse.

Offline mikeandmore

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: Serious performance issues on Ubuntu 6.10
« Reply #19 on: February 07, 2007, 04:11:22 pm »
first i'm gonna say something on the typing when NO syntax highlight
yes, it's slow in the latest svn...,the problem is that wxscintilla's scintilla version is too low, in scintilla 1.65, it did a lot of optimize...(the latest version is 1.72).
After change wxscintilla's scintilla to 1.72, CB solve the problem when NO syntax highlight.

second, when ya turn on the syntax highlight, CB is still slow...
the reason for this is still unknown,but i'm sure it's the problem of the editor lexer algorithm. now i'm trying to fix  them...