Author Topic: The 04 october 2006 build will NOT be out.  (Read 5348 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5177
The 04 october 2006 build will NOT be out.
« on: October 04, 2006, 07:34:42 pm »
no commits

Offline DmP

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 04 october 2006 build will NOT be out.
« Reply #1 on: October 05, 2006, 08:05:27 am »
Hello!

If build wx with option "#define WXWIN_COMPATIBILITY_2_4 0" in setup.h, then:
Code: [Select]
Compiling: sdk\editarrayfiledlg.cpp
sdk\editarrayfiledlg.cpp: In member function `void EditArrayFileDlg::OnAdd(wxCommandEvent&)':
sdk\editarrayfiledlg.cpp:87: error: `wxHIDE_READONLY' undeclared (first use this function)
sdk\editarrayfiledlg.cpp:87: error: (Each undeclared identifier is reported only once for each function it appears in.)
sdk\editarrayfiledlg.cpp: In member function `void EditArrayFileDlg::OnEdit(wxCommandEvent&)':
sdk\editarrayfiledlg.cpp:107: error: `wxHIDE_READONLY' undeclared (first use this function)
Process terminated with status 1 (0 minutes, 6 seconds)
3 errors, 0 warnings

CodeBlocks - last from SVN.
To fix errors, need rebuild wx?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6585
    • My Best Post
Re: The 04 october 2006 build will NOT be out.
« Reply #2 on: October 05, 2006, 10:05:52 am »
No, rebuilding wxWidgets will not make WXWIN_COMPATIBILITY_2_4=0 work. The WXWIN_COMPATIBILITY_2_4=0 means turn off compatibility mode for version 2.4 wxWidgets. The way to fix this issue is to fix Code::Blocks or to set WXWIN_COMPATIBILITY_2_4=1. The main reason to set it to zero is when the user wishes to see if the wxWidgets application will work with the next version which would be 2.7 or 2.8 depending if you mean developement branch or stable. 2.8 does not exist to my knowedge at this time.

I am going to test right now and see if I get the same errors with SVN 3008

Edit: Look at this for more info http://forums.codeblocks.org/index.php?topic=3474.msg27345

Edit: In reply to "To fix errors, need rebuild wx?", you must set WXWIN_COMPATIBILITY_2_4=1 and rebuild wx or you must edit the code in code blocks to not use wxHIDE_READONLY.

If you wish to test CB with 2.7 you must/should edit CB to not use wxHIDE_READONLY.
(Note: I am lazy and I am trying to use #define wxHIDE_READONLY 0 to set wxHIDE_READONLY=0 in the idea that I won't have to edit as many files; i am trying this in the codeblocks defines.)

And, it seems to be required that CB and wxWidgets both have to be compiled with WXWIN_COMPATIBILITY_2_4=0 if CB was compiled with it set to zero. I have to fix my installation of CB now.

Tim S
« Last Edit: October 05, 2006, 11:24:39 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline DmP

  • Single posting newcomer
  • *
  • Posts: 9
Re: The 04 october 2006 build will NOT be out.
« Reply #3 on: October 06, 2006, 07:23:10 am »

I am going to test right now and see if I get the same errors with SVN 3008

Edit: Look at this for more info http://forums.codeblocks.org/index.php?topic=3474.msg27345

Edit: In reply to "To fix errors, need rebuild wx?", you must set WXWIN_COMPATIBILITY_2_4=1 and rebuild wx or you must edit the code in code blocks to not use wxHIDE_READONLY.

Tim S


Thanks Tim.

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: The 04 october 2006 build will NOT be out.
« Reply #4 on: October 06, 2006, 10:21:22 am »
I removed all instances of wxHIDE_READONLY in 3013.

The interesting thing about it is that this constant is marked "deprecated" in 2.6+, which should actually trigger a warning, not break the build...
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: The 04 october 2006 build will NOT be out.
« Reply #5 on: October 06, 2006, 01:17:01 pm »
... and reverted that change, because the wxWidgets documentation is wrong. The documentation claims that the "open read-only" checkbox is never shown.

As Martin correctly pointed out, wxHIDE_READONLY is necessary for correct behaviour, as the "open read-only" checkbox is indeed shown, but dysfunct (which may confuse the user).
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."