Author Topic: Problems making CB for OSX from wiki instructions  (Read 19240 times)

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #30 on: September 25, 2006, 11:58:14 pm »
Would it be of any interest if I posted some (parts of) crash reports?
The report shows rather clearly the chain of events and where the crash occurs.
Or maybe some of you already have reproduced the crashes?

Post somewhere on a web page, and post the URLs ?
I get hangs and lockups, but not too many crashes...

BTW:
There should be a new zip file (rev2994) up shortly.

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #31 on: September 26, 2006, 12:00:16 am »
afb: could you release a new universal .dmg? I'm getting in the C::B Debug pane lots of "Start here link not found" all the time. Also I can't compile even the most basic program with C::B, it seems to hang while launching gcc.

Yeah, sorry about that debugging gunk - I was trying (unsuccessfully) to fix the links.

New zip file is at BerliOS/incoming, probably posted soon...

Quote
Also, I've tried to use your macport from the wiki, unfortunately it fails when applying the patches, seems they're outdated (or already applied?).

They applied to rev2994, I usually try to specify the revision

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #32 on: September 26, 2006, 12:01:14 am »
The scriptedwizard.zip should be removed from the crasher list, sorry about that.
Plugins codecompletion, keybinder, todo, and wzsmith remains.
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #33 on: September 26, 2006, 12:23:24 am »
See http://medlem.spray.se/bengtnilsson11/plugincrashes.html for crash reports.
Revision is 2995.
I see above that the patches should be applied to 2994. Could this be a problem?
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2178
Re: Problems making CB for OSX from wiki instructions
« Reply #34 on: September 26, 2006, 02:16:49 am »
See http://medlem.spray.se/bengtnilsson11/plugincrashes.html for crash reports.
Revision is 2995.
I see above that the patches should be applied to 2994. Could this be a problem?


I may be thick, but I dont see where in that crash report that says keybinder crashed.

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #35 on: September 26, 2006, 07:44:07 am »
I don't say that the keybinder crashed.
I just say that when keybinder.zip is present in share/condeblocks CB crashes at quit, and quits ok when it isn't.

But actually, "not crashing at start or quit" is apparently not a critereia of success. I tried to load a project with my "working" set of plugins, and then it crashed anyway.

But it is difficult for me who has never used CB for real to sy what is working or not.
Maybe some other Mac-owner with more experience should do this.
I think I will take a break for a while and wait for better stability.
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #36 on: September 26, 2006, 08:55:41 am »
But it is difficult for me who has never used CB for real to sy what is working or not.
Maybe some other Mac-owner with more experience should do this.
I think I will take a break for a while and wait for better stability.

Yeah, it isn't really ready for prime-time just yet - but your help is appreciated!

If you just want to use Code::Blocks on the Mac, would an X11/GTK version help?
(it's possible to build such a version with DarwinPorts, with: +puredarwin-macosx)

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #37 on: September 26, 2006, 09:07:58 am »
An X11 version of CB would be useful, absolutely.
Do you have one?
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #38 on: September 26, 2006, 09:26:33 am »
An X11 version of CB would be useful, absolutely.

I don't have a standalone version, mainly because I didn't feel like
compiling GTK+ and all of the requirements. However, it is possibly
to build one using DarwinPorts, and a local Portfile repository...

On the Wiki are the files you need, first you build "wxGTK" in
graphics/wxGTK (you need to uninstall the usual "wxWidgets")
and then you build C::B in devel/codeblocks, without wxMac.

Once set up, it's something like:
Code: [Select]
sudo port install wxGTK
sudo port install codeblocks +puredarwin-macosx

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #39 on: September 26, 2006, 10:30:31 pm »
I have a problem getting the parts for this port install:

port install graphics/wxGTK
--->  Fetching wxGTK
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-od.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-msn.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-bay13.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-od.opendarwin.org/
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-msn.opendarwin.org/
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-bay13.opendarwin.org/
Error: Target com.apple.fetch returned: fetch failed
Any suggestions?

port install wxgtk
is not behaving the same way as
cd /opt/local/var/db/dports
port install graphics/wxGTK
although I did /opt/local/bin/portindex, detecting the 3 new ports.
So am a little confused.

-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #40 on: September 26, 2006, 10:31:58 pm »
Or maybe it is because of the transition from darwinports to macports?
All f the distfiles sites in this list seems to be own.
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #41 on: September 26, 2006, 11:43:17 pm »
I have a problem getting the parts for this port install:

port install graphics/wxGTK
--->  Fetching wxGTK
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-od.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-msn.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-bay13.opendarwin.org/wxGTK/2.6.3
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-od.opendarwin.org/
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-msn.opendarwin.org/
--->  Attempting to fetch patch-soundsdl.diff from http://distfiles-bay13.opendarwin.org/
Error: Target com.apple.fetch returned: fetch failed
Any suggestions?

Sorry, that one is mine:
http://www.algonet.se/~afb/wx/patch-soundsdl.diff

Put it in a directory "files", next to your Portfile:
Code: [Select]
dports/graphics/wxGTK/Portfile
dports/graphics/wxGTK/files/patch-soundsdl.diff

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #42 on: September 27, 2006, 11:08:13 am »
Installation of wxGTK and codeblocks went without errors, but /Applications/CodeBlocks.app does not start.
Any suggestions?
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Re: Problems making CB for OSX from wiki instructions
« Reply #43 on: September 27, 2006, 12:16:35 pm »
Installation of wxGTK and codeblocks went without errors, but /Applications/CodeBlocks.app does not start.
Any suggestions?

Code: [Select]
/opt/local/bin/codeblocks --prefix=/opt/local
Perhaps over-explicit, but just making sure...

The bundle is only used for the wxMac version,
maybe I should explain this better on the Wiki.

Offline bnilsson

  • Almost regular
  • **
  • Posts: 184
Re: Problems making CB for OSX from wiki instructions
« Reply #44 on: September 27, 2006, 03:43:23 pm »
The path seems to be ok.
At normal (double click on CodeBlocks.app) the console log it says:
Error: Unable to initialize gtk, is DISPLAY set properly?

Opening a Terminal window and issuing the command 'codeblocks' at prompt gives the same answer:
mc2-p039:~ bnilsson$ codeblocks
Error: Unable to initialize gtk, is DISPLAY set properly?

Opening a X11 terminal window and issuing the command 'codeblocks' at prompt gives the usual error (X11)dialog window saying resources cannot be found, and the following is displayed repeatedly in the terminal:

(codeblocks:3581): GLib-WARNING **: poll(2) failed due to: Invalid argument.

as long as the error dialog window is open.
-- Ingnorance should not be taken for stupidity --

HW: PowerMac Dual PowerPC G5 2.3Ghz, 1GB RAM OS: MacOSX 10.4.10 Compiler: powerpc-apple-darwin8-gcc-4.0.1