Author Topic: The 19 september 2006 build is out.  (Read 15997 times)

Offline Schlumie

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: The 19 september 2006 build is out.
« Reply #15 on: September 20, 2006, 01:16:29 pm »
As far as I know, unions are not currently supported.
Should'nt it be parsed like "struct" ? Ok, the data is stored on the same memposition, but this doesnt matter for the codecompletition... so if union and struct would be be handled the same way for the code completition it would be ok ?

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2180
Re: The 19 september 2006 build is out.
« Reply #16 on: September 20, 2006, 02:06:09 pm »
if we look at the menu of Code snippets you can see effects clearly.
...<snip>...
The "corruption" seems like it's missing the menu images (which don't even exist) so it won't even show the scope menu's check mark.

I'm fairly sure that this issue is because of XRC loaded menus in the main application.

Would you turn KeyBinder off and see if the problem still exists.

Because Keybinder reWrites images and menu items, I'm always suspicious.
« Last Edit: September 20, 2006, 02:24:39 pm by Pecan »

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 19 september 2006 build is out.
« Reply #17 on: September 20, 2006, 02:31:08 pm »
Would you turn KeyBinder off and see if the problem still exists.

Because Keybinder rewrites images and menu items, I'm always suspicious.

The problem still exists; I have only compiler, debugger, file extensions handler plugins enabled.

Offline once_upon_user

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 19 september 2006 build is out.
« Reply #18 on: September 20, 2006, 03:17:24 pm »
Hello,

I'm new to Code Blocks, using it for a few days right now. I tried SVN Source that correspond  to the 19 September Built and some earlier one.
I had to compiled source from SVN because of my retired distro: Fedora Core 3. I have compiled and installed CodeBlocks and wxWidgets along the Installation guide from the CB Wiki. My system is:

kernel: 2.6.9-1.667smp #1 SMP Tue Nov 2 14:59:52 EST 2004 i686 i686 i386 GNU/Linux
wx-config --version : 2.6.3
glibc-2.3.3-74
gcc (GCC) 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)
xorg-x11: 6.8.1-12

I Use CB to work with my project which is rather big and was created in VC++ so I have imported it to CB and edit my code with CB, and
CodeBlocks runs in pretty unstable way.. I often get Segmentation Faults..  I present three situations in which I get segfault:

1. Sometimes without any particular action (during diffrent operations) I get SegFault. Most often My console(The one I used to run CB) output
 looks like this:
Xft: locking error too many file unlocks
Xft: locking error too many file unlocks
Xft: locking error too many file unlocks
Xft: locking error too many file unlocks
....
And after some time , in GDB:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -225825872 (LWP 5424)]
0x00000019 in ?? ()
(gdb) bt
#0  0x00000019 in ?? ()
#1  0x00a6842c in g_hash_table_insert () from /usr/lib/libglib-2.0.so.0
#2  0x00c53a70 in pango_context_get_base_dir () from /usr/lib/libpango-1.0.so.0
#3  0x00c54270 in pango_context_get_base_dir () from /usr/lib/libpango-1.0.so.0
#4  0x00c545b4 in pango_context_get_base_dir () from /usr/lib/libpango-1.0.so.0
#5  0x00c5495a in pango_itemize_with_base_dir () from /usr/lib/libpango-1.0.so.0
#6  0x00c5b75c in pango_layout_line_get_pixel_extents () from /usr/lib/libpango-1.0.so.0
#7  0x00c5c4f7 in pango_layout_line_get_pixel_extents () from /usr/lib/libpango-1.0.so.0
#8  0x00c5cccf in pango_layout_get_pixel_size () from /usr/lib/libpango-1.0.so.0
#9  0xf686c784 in wxWindowDC::DoGetTextExtent () from /opt/wx/2.6/lib/libwx_gtk2u-2.6.so.0
#10 0xf6989942 in wxGenericTreeCtrl::CalculateSize () from /opt/wx/2.6/lib/libwx_gtk2u-2.6.so.0
#11 0xf6989bf8 in wxGenericTreeCtrl::SetItemImage () from /opt/wx/2.6/lib/libwx_gtk2u-2.6.so.0
#12 0xf37f7316 in ClassBrowserBuilderThread::AddNodeIfNotThere (this=0x53, tree=0x9165fe0, parent={m_pItem = 0xf2acfc58}, [email protected], imgIndex=1,
    data=0xee893b00, sorted=152) at classbrowserbuilderthread.cpp:192
#13 0xf37f7e31 in ClassBrowserBuilderThread::AddNodes (this=0x8fcafc8, tree=0x9165fe0, parent={m_pItem = 0xf2acfc58}, start={_M_node = 0xf11718a0},
    tokenKindMask=-609, allowGlobals=false) at openfilestree.h:14
#14 0xf37f80fe in ClassBrowserBuilderThread::AddChildrenOf (this=0x8fcafc8, tree=0x9165fe0, parentTokenIdx=-1, tokenKindMask=-609)
    at classbrowserbuilderthread.cpp:253
#15 0xf37f8207 in ClassBrowserBuilderThread::ExpandItem (this=0x8fcafc8, item={m_pItem = 0xf2acfc58}) at token.h:91
#16 0xf37f8b66 in ClassBrowserBuilderThread::BuildTree (this=0x8fcafc8) at classbrowserbuilderthread.cpp:128
#17 0xf37f8bfb in ClassBrowserBuilderThread::Entry (this=0x8fcafc8) at classbrowserbuilderthread.cpp:85
#18 0xf68317bd in wxThreadInternal::PthreadStart () from /opt/wx/2.6/lib/libwx_gtk2u-2.6.so.0
#19 0xf683182b in wxPthreadStart () from /opt/wx/2.6/lib/libwx_gtk2u-2.6.so.0
#20 0x0092c1d5 in start_thread () from /lib/tls/libpthread.so.0
#21 0x007ad2da in clone () from /lib/tls/libc.so.6

2. Another situation when I have launched CB (another case after quitting )
I have got in console:
Starting program: /usr/local/bin/codeblocks
[Thread debugging using libthread_db enabled]
[New Thread -161216832 (LWP 5480)]
[New Thread -165549136 (LWP 5483)]
[New Thread -176038992 (LWP 5484)]
[New Thread -186528848 (LWP 5485)]
[New Thread -197018704 (LWP 5486)]
[New Thread -209982544 (LWP 5487)]
[New Thread -225899600 (LWP 5488)]
Detaching after fork from child process 5489.
Detaching after fork from child process 5491.
Detaching after fork from child process 5493.
[New Thread -236389456 (LWP 5495)]
[Thread -236389456 (zombie) exited]
[New Thread -236389456 (LWP 5496)]
[Thread -236389456 (LWP 5496) exited]
[New Thread -236389456 (LWP 5497)]
[Thread -236389456 (LWP 5497) exited]
[New Thread -236389456 (LWP 5498)]
[Thread -236389456 (LWP 5498) exited]
and Backtrace from GDB (Attachment1)

3. Another situations occured during usual way:
Console:
[Thread debugging using libthread_db enabled]
[New Thread -161216832 (LWP 11507)]
[New Thread -165549136 (LWP 11510)]
[New Thread -176038992 (LWP 11511)]
[New Thread -186528848 (LWP 11512)]
[New Thread -197018704 (LWP 11513)]
[New Thread -209982544 (LWP 11514)]
[New Thread -225825872 (LWP 11515)]
Detaching after fork from child process 11516.
Detaching after fork from child process 11518.
Detaching after fork from child process 11520.
[New Thread -238232656 (LWP 11522)]
[Thread -238232656 (zombie) exited]
[New Thread -238232656 (LWP 11523)]
[Thread -238232656 (LWP 11523) exited]
[New Thread -238232656 (LWP 11524)]
[Thread -238232656 (LWP 11524) exited]
[New Thread -238232656 (LWP 11525)]
[Thread -238232656 (LWP 11525) exited]
[New Thread -238232656 (LWP 11526)]
[Thread -238232656 (LWP 11526) exited]
[New Thread -238232656 (LWP 11527)]
[Thread -238232656 (LWP 11527) exited]
[New Thread -238232656 (LWP 11528)]
[Thread -238232656 (LWP 11528) exited]
*** glibc detected *** double free or corruption: 0x08eea1a8 ***
And GDB log (attachment2)

So, thanks in advance for any suggestions, opinions any other contribution that will allow me to use CB without SegFault

Greets




[attachment deleted by admin]

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2180
Re: The 19 september 2006 build is out.
« Reply #19 on: September 20, 2006, 04:01:38 pm »
Would you turn KeyBinder off and see if the problem still exists.

Because Keybinder rewrites images and menu items, I'm always suspicious.

The problem still exists; I have only compiler, debugger, file extensions handler plugins enabled.

I still cannot recreate the error(latest SVN). I click on codeSnippets/searchButton/Scope. The dot is there.

I then click on File/Open/cancel. I then click on Codesnippet/SearachButton/Scope. Again, the dot is there.



How do you create the error?
 
« Last Edit: September 20, 2006, 04:10:24 pm by Pecan »

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 19 september 2006 build is out.
« Reply #20 on: September 20, 2006, 05:25:22 pm »
I still cannot recreate the error(latest SVN). I click on codeSnippets/searchButton/Scope. The dot is there.

I then click on File/Open/cancel. I then click on Codesnippet/SearachButton/Scope. Again, the dot is there.

How do you create the error?
 

I just click on File and then on the Code Snippets' menu and the dot is gone. Your DPI settings are probably hiding the bug.

Someone had already reported the bug to the wxWidgets' bug list so I just added a comment, the bug number is #1542190. The bug has been on the queue for about a month now and none of the developers have commented it.

I also made a simple test application (binary / source). The binary version is linked against the monolithic dll (unicode).

In the test application first click the "Create a popup menu" button. Then click File menu to see the menu item with the image and then click "Create a popup menu" button again. On my system the popup menu appears larger and in the radio submenu the check mark is gone.

Offline eckard_klotz

  • Almost regular
  • **
  • Posts: 150
Re: The 19 september 2006 build is out.
« Reply #21 on: September 20, 2006, 08:06:21 pm »
Hello evrybody

This shoud be an answer for the question of killerbot to my posting in the topic " The 18 september 2006 build is out." where I described how to run C::B under winME.

killerbot wrote:

Quote
could you try out a nightly , rc2 is very old.
In the nightly announcements there's very often a reply from setjackson providing a link to an ansi build (which is what you need on WinMe). It is possible there might be problems with that one also, not sure.


Sorry, I didn't make it clear (I know my English is not the best one): I started with rc1 and rc2 last year, but since end of july I'm trying to use the ansi-nightlies. The last ansi-nightly I tried out today, was the one from yesterday. It seams to work also, if I don't use the "debuggergdb.dll" ,allowing to run more than one instance and disabling the loading of any file while stating.

Perhaps you have more details you want to know or you wish to ask me to do some experimental things. Don't hasitate to do so, but perhaps it may take one or two day before I can answer.

Kind Regards,
                    Eckard Klotz.

Offline griffin2000

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 19 september 2006 build is out.
« Reply #22 on: September 20, 2006, 08:11:35 pm »
As recommended in another thread I upgraded to this build...   I get the following issues:

I get no filename or line for warnings of errors in the build message window (it worked fine in RC2): e.g:
For this message in the build log:
c:/p4_perforce.z-axis.com1666_gmorgans/AGT/Internal/Tools/TestBed\.\\source/modules/TestLoopListModule.cpp:53: warning: invalid access to non-static data member 'ObjectSingle::mNode' of NULL object
I get this message with not line or file in the build message window:
warning: invalid access to non-static data member 'ObjectSingle::mNode' of NULL object

I've tried changing the build message regular expression and it makes not difference.  The default expression is:
([ \tA-Za-z0-9_:+/\.-]+):([0-9]+):[ \t]([Ww]arning:[ \t].*)

I've tried changing it to this but it makes not difference:
(.+):([0-9]+):[ \t ][Ww]arning:([ \t ].*)

Its also seems to define $make as the the minGW make executable, not matter what you define your make program as in compiler options.

Offline griffin2000

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 19 september 2006 build is out.
« Reply #23 on: September 20, 2006, 08:16:15 pm »
And there is another strange difference... I have custom tool to do a perforce check-out on a file.  In RC2 it would automatically recognise the file has changed and bring up "file has change, reload?.." dialog.  But with this build it no longer does that, I have to close and re-open the file. 

Offline griffin2000

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 19 september 2006 build is out.
« Reply #24 on: September 20, 2006, 08:26:11 pm »
I've tried changing the build message regular expression and it makes not difference.  The default expression is:
In fact if  I copy the compiler output string to the "test" window it recognizes it fine.