Author Topic: The 03 september 2006 build is out.  (Read 18141 times)

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 03 september 2006 build is out.
« Reply #15 on: September 04, 2006, 02:08:53 pm »
icons on the left pane in the dialogs in the "Setting" menu appear with black squared background (I suppose it should be white, or better transparent).

Although you don't mention the OSes you 're seeing this, I can tell you that it's known to happen in all pre-XP windows. Hopefully, it 'll get fixed too, some day...
Be patient!
This bug will be fixed soon...

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 03 september 2006 build is out.
« Reply #16 on: September 04, 2006, 04:42:24 pm »
I am sure he is on Windows 2000.
I have the same problem.

See screenshots:



Have a nice day.

Offline godcode

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 03 september 2006 build is out.
« Reply #17 on: September 04, 2006, 05:16:51 pm »
experienced that one on win98 when i changed the color quality of windows to 16 bit instead of 32 bit

Offline DrLock

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 03 september 2006 build is out.
« Reply #18 on: September 04, 2006, 05:57:21 pm »
Someone built a amd64 .deb for Ubuntu a while back, but it is very old now and is also unstable.  Would someone be willing to re-build the amd64 .deb from the latest build and post it to berliOS. I am hoping that whoever did it last time would be able to easily do it again :)

Thanks

Offline polygon7

  • Multiple posting newcomer
  • *
  • Posts: 104
    • Home site
Re: The 03 september 2006 build is out.
« Reply #19 on: September 04, 2006, 06:51:18 pm »
Hi,
I have a question regarding that icons in configuration dialogs - Why Settings->Environment->View->"Settings icon size" is disabled on Linux?
Is this option is buggy and don't work on Linux?

P.S. Imho, that icons are really too big, it should be smaller (maybe about 64x64 px).
best regards,
p7
 Free open source UML modeling tool: ArgoUML

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 03 september 2006 build is out.
« Reply #20 on: September 04, 2006, 07:09:23 pm »
icons on the left pane in the dialogs in the "Setting" menu appear with black squared background (I suppose it should be white, or better transparent).

Although you don't mention the OSes you 're seeing this, I can tell you that it's known to happen in all pre-XP windows. Hopefully, it 'll get fixed too, some day...

Scratch that and make it today ;).
Be patient!
This bug will be fixed soon...

Offline Encryptor

  • Multiple posting newcomer
  • *
  • Posts: 34
Re: The 03 september 2006 build is out.
« Reply #21 on: September 04, 2006, 07:28:01 pm »
Failed to compile Code::Blocks on Ubuntu Linux 6.06. Source downloaded from SVN.

g++ --version
g++ (GCC) 4.0.3 (Ubuntu 4.0.3-1ubuntu5)

uname -a
Linux Server 2.6.17.8 #1 SMP Sun Aug 13 22:58:48 EDT 2006 x86_64 GNU/Linux

I'm not sure what to provide, so here are several lines prior and after the error:
Code: [Select]
g++ -DHAVE_CONFIG_H -I. -I. -I. -I/home/victor/work/codeblocks/wxwidgets//lib/wx/include/gtk2-unicode-release-2.6 -I/home/victor/work/codeblocks/wxwidgets//include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA -I../../src/sdk/wxscintilla/include -I../../src/sdk/tinyxml -I../../src/sdk/scripting/include -I../../src/sdk/scripting/sqplus -I../../src/sdk/wxFlatNotebook -I../../src/sdk/propgrid/include -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -MT globals.lo -MD -MP -MF .deps/globals.Tpo -c globals.cpp  -fPIC -DPIC -o .libs/globals.o
globals.cpp: In function 'wxBitmap cbLoadBitmap(const wxString&, int)':
globals.cpp:633: error: 'UsesCommonControls6' was not declared in this scope
make[4]: *** [globals.lo] Error 1
make[4]: Leaving directory `/home/victor/downloads/codeblocks/rev2946/trunk/src/sdk'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/victor/downloads/codeblocks/rev2946/trunk/src/sdk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/victor/downloads/codeblocks/rev2946/trunk/src/sdk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/victor/downloads/codeblocks/rev2946/trunk/src'
make: *** [all-recursive] Error 1

The commands that I issued prior to getting this error
Code: [Select]
./bootstrap
export PATH=/home/victor/work/codeblocks/wxwidgets/bin:/home/victor/work/codeblocks/wxwidgets/bin:$PATH
./configure --prefix=/home/victor/work/codeblocks/rev2946 --enable-contrib
make && sudo make install

Did I do something wrong?
« Last Edit: September 04, 2006, 07:38:50 pm by Encryptor »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 03 september 2006 build is out.
« Reply #22 on: September 04, 2006, 07:41:45 pm »
Quote
Did I do something wrong?

No, it's a missing platform #ifdef.
Fixed now.

On another note, please use the other boards for such problems. The nightly builds board is for announcement of nightly builds and reporting problems with them.
Be patient!
This bug will be fixed soon...

Offline Encryptor

  • Multiple posting newcomer
  • *
  • Posts: 34
Re: The 03 september 2006 build is out.
« Reply #23 on: September 04, 2006, 07:50:35 pm »
Ok, I thought I should post here since the previous nightly builds compiled fine, it was this one (plus/minus several revisions) that didn't.
I'll post in a different sub-forum next time.
« Last Edit: September 04, 2006, 08:00:54 pm by Encryptor »

Offline Kazade

  • Multiple posting newcomer
  • *
  • Posts: 73
Re: The 03 september 2006 build is out.
« Reply #24 on: September 04, 2006, 08:14:38 pm »
Because of instabilities I have been stuck with an old build. (27th August) and can I just say that the symbols browser is fucking awesome and C::B is 10x as stable as the last build. I dunno what you did yesterday but its fixed everything for me! Thanks guys!

Offline Kazade

  • Multiple posting newcomer
  • *
  • Posts: 73
Re: The 03 september 2006 build is out.
« Reply #25 on: September 04, 2006, 10:15:04 pm »
Just one more thing, I have been using today's build for over 2 hours now on Kubuntu and I haven't experienced a single crash or bug (and it was crashing every minute or so). I cant thank you guys enough, my productivity on my game engine has doubled since using code::blocks (even when it was unstable).

One little thing though, sometimes the notebook tabs only show the top half, when I click them or change the style in settings they appear properly.

 :D :D :D :D :D :D :D :D :D :D :D :D :D :D << Happy happy me!

Offline Encryptor

  • Multiple posting newcomer
  • *
  • Posts: 34
Re: The 03 september 2006 build is out.
« Reply #26 on: September 05, 2006, 02:33:50 am »
That's strange. I always get the same error when C::B crashes. It's a about a "Cairo Font".. it might be specific to my distribution only..
Code: [Select]
codeblocks: cairo-ft-font.c:678: _cairo_ft_unscaled_font_set_scale: Assertion `error == 0' failed.It seems to crash more or less randomly. It crashed once when I tried to save a modified main.cpp. It crashed when Code completion should have displayed some methods of a class.
EDIT: I've just read another topic on the forum about this. It seems that it's a libcairo problem that not everybody has. I guess I'll wait for a newer version of libcairo.

Another question: when you select Ogre3d project, and then C::B asks you whether you have a pre-installed OGRE SDK or you have sources installed, there used to be a page that asked you for the location of the sources. It seems that page is gone now, C::B asks directly for the compiler(s). Is that on purpose? Why wouldn't it ask me for the location of the OGRE source?
« Last Edit: September 05, 2006, 02:46:05 am by Encryptor »

Offline peso

  • Multiple posting newcomer
  • *
  • Posts: 12
    • Abalone on Wikipedia
Re: The 03 september 2006 build is out.
« Reply #27 on: September 10, 2006, 11:22:09 am »
Crashing crash-dialog?

The past few days I have been using the 2006, sep 3 build instead of my RC2. Two times I have had a crash report - I suppose it happens because the nightly doesn't like RC2 for some reason. I have never had a crash in RC2.

The first time was when I was setting a path to the compiler: Settings -> Compiler -> Directories -> Linker -> Add, browse to c:\msys\1.0\local\lib, copy path, go to Directories -> Comiler, paste path, press "..." (to browse to ..\include) caused a crash

The second time was when I was trying to make a new empty project.

The errors are reproducable, unless I do something else with code blocks, after which they are not reproducable. The most strange part is that the error report titled "Woha!" continues to pop up so it is hard even to get the the task manager or to press ctrl-alt-delete. At one of the events I had almost 400 dialogs on screen before I managed to stop the process. They pop up quite fast, about 10 per second.

Is it possible that the crash report is capable of crashing? :-)

I'm running Windows XP, in an installation from 2003 - so a lot of old stuff might be it hanging around.