Author Topic: ANN: wxFormBuilder v2.0 Released!  (Read 2712 times)

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
ANN: wxFormBuilder v2.0 Released!
« on: August 16, 2006, 08:45:31 pm »
Hi everyone,

It is official, wxFormBuilder v2.0 is released.

The list of updates is very big so check out the changelog for more details.

You can download it here.

Please post comments, questions, and bugs on the wxFormBuilder Forum.
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: ANN: wxFormBuilder v2.0 Released!
« Reply #1 on: August 16, 2006, 09:28:10 pm »
This installer is not very nice. I tried to d/l the wxAdditions two times, both times the d/l failed. I did not want to continue the setup under this circumstances but I had to kill the setup using the task manager because it cannot be cancelled/closed...?! It is no good to have a setup that cannot be cancelled. This makes me think of virus/spyware or similar. I'll try later, hopefully the d/l will succeed at some point. ;-)
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: ANN: wxFormBuilder v2.0 Released!
« Reply #2 on: August 16, 2006, 10:43:13 pm »
I tried to d/l the wxAdditions two times, both times the d/l failed. I did not want to continue the setup under this circumstances but I had to kill the setup using the task manager because it cannot be cancelled/closed...?!
Well I can't reproduce this at all. It works great for me. Did you download version 2.0 not the 2.0 Alpha releases? Because the download will fail because we changed the wxAdditions package so the file doesn't exist. I also can cancel without any problem. So I don't know what to tell you. These files are all hosted on SourceForge.net so I guess if the web servers were having problems then it would create a problem for you, but no killing the process is needed if the download fails.

Also wxAdditions is not needed unless you are going to use the controls in the 'Contrib' tab. So if the download doesn't finish un-check the "Download and install wxAdditions" checkbox.

I'll try later, hopefully the d/l will succeed at some point. ;-)
With regards, Morten.
Please do try again. Please verify that you downloaded the file wxFormBuilder_v2.0.70.exe
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: ANN: wxFormBuilder v2.0 Released!
« Reply #3 on: August 16, 2006, 10:58:21 pm »
This is the error:

And this is the setup afterwards:

Notice the greyed "X" button on the top right and that I only have a "Next" button from now on.
You might be able to simulate this issue if you interrupt the download (e.g. unplug the network card) during download. As you can see - I tried again 2 times and agin: No success with the download. I'll try again tomorrow... ;-)
And yes, I am using wxFormBuilder_v2.0.70.exe.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: ANN: wxFormBuilder v2.0 Released!
« Reply #4 on: August 16, 2006, 11:32:40 pm »
Well in regards to the next button only dialog. That is because at that point in the installer the program is installed. So there is no going back without running the uninstaller. Sorry that is just the nature of INNO Setup.

It makes sense to me because all of the installation tasks are already done at that point I just display the change log at that time which is for your benefit. 'Next' is all there is left to do in the installer. Sorry that you want to quite at that point, but doing that now doesn't have any effect on the installer.

So in other words, it has already put all it information and files on to your system. In fact I believe you killing the installer at that point leaves the temporary files on your system without properly cleaning them up. I think that is causing your problem. It needs to get rid of the partial wxAdditions install that it downloaded. It does this as the last step. So please try to finish the installer out and that way a fresh copy from the web server can be downloaded after running the installer again. You can also just delete all the files in your temp folder too. In fact, you should find a file named wxAdditions_setup.exe in your temp folder if my thinking about file clean up is correct. On a completed setup this would NOT be there.

Can we move this discussion over to the wxFormBuilder Forum.
That way we aren't taking up Code::Blocks forum. Thanks ;)
« Last Edit: August 16, 2006, 11:44:06 pm by RJP Computing »
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB