Author Topic: The 03 august 2006 build is out.  (Read 8283 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5229
The 03 august 2006 build is out.
« on: August 03, 2006, 10:11:20 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26_gcc_cb_wx2.6.3p2.7z

The 03 August 2006 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20060803_rev2811_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20060803_rev2811_Ubuntu6.06.deb
         http://prdownload.berlios.de/codeblocks/CB_20060803_rev2811_fc4+5.rpm


Resolved Fixed:

  • [ Patch #1177 ] Mac OS X some simple mac compile fixes (slightly adjusted including fix)
  • Implemented improved debugger evaluation tooltip window
  • Fixed bad memory addresses reported in debugger's MemoryDump window
  • Added missing #include
  • Forfeit input and error streams when aborting build
  • Fixed bug in template-code parsing for debugger tooltips
  • Fixed bug in function-signature parsing for debugger tooltips
  • Fixed broken linux build
  • Yet another autotools fix

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • there are several issues with Code Completion (is being redesigned : work in progress)
  • menu items with icon not correctly aligned (since wx263)

« Last Edit: August 03, 2006, 11:02:05 pm by killerbot »

Offline rjmyst3

  • Multiple posting newcomer
  • *
  • Posts: 117
    • wxFormBuilder
Re: The 03 august 2006 build is out.
« Reply #1 on: August 04, 2006, 12:09:24 am »
Hi, I'm a long time listener, first time caller  :D.
Just wanted to say thank you for such a great app.

Especially the ubuntu .deb packages and all the recent work on the debugger.
Especially the debugger.
Especially the debugger.
Especially the debugger.
Especially the debugger.

THANKS!!!

 :D

Offline RJP Computing

  • Almost regular
  • **
  • Posts: 135
    • RJP Computing
Re: The 03 august 2006 build is out.
« Reply #2 on: August 04, 2006, 02:37:11 am »
  • Implemented improved debugger evaluation tooltip window
  • Fixed bad memory addresses reported in debugger's MemoryDump window
  • Fixed bug in template-code parsing for debugger tooltips
  • Fixed bug in function-signature parsing for debugger tooltips
Thanks for more debugger improvements.  :D

Can the dereferencing stuff be added to the watch window? That would make it really much easier.

Again Thanks!
- Ryan

Ubuntu/WinXP, AMD Athlon 64 3000+, 1000MB RAM, AC 97 Audio, ATI Radeon 9600XT 256MB

Offline Xaviou

  • Regular
  • ***
  • Posts: 311
    • X@v's wxStuff
Re: The 03 august 2006 build is out.
« Reply #3 on: August 04, 2006, 12:01:25 pm »
Quote
Regressions/Confirmed/Annoying/Common bugs:
menu items with icon not correctly aligned (since wx263)

I'm surprised that no-one has already founded the solution : just add a 1 pixel height all transparent bitmap to all menu entries that don't have an icon. I've tried it : it works fine.
Code: [Select]
/* XPM */
static char *emptyicon_xpm[] = {
/* columns rows colors chars-per-pixel */
"16 1 1 1",
"  c None",
/* pixels */
"                ",
};
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline BordRider

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: The 03 august 2006 build is out.
« Reply #4 on: August 04, 2006, 09:35:11 pm »
debuggerific!  can't wait for arrays defined in the watch window, and arrays bigger than 200!

really though this program is excellent...as far as i can see there really is no alternative

Edit:  My last build was 06/22...and this version seems to be running ALOT faster.  Keen.
« Last Edit: August 04, 2006, 09:41:53 pm by BordRider »

sethjackson

  • Guest
Re: The 03 august 2006 build is out.
« Reply #5 on: August 04, 2006, 09:40:37 pm »
Quote
Regressions/Confirmed/Annoying/Common bugs:
menu items with icon not correctly aligned (since wx263)

I'm surprised that no-one has already founded the solution : just add a 1 pixel height all transparent bitmap to all menu entries that don't have an icon. I've tried it : it works fine.
Code: [Select]
/* XPM */
static char *emptyicon_xpm[] = {
/* columns rows colors chars-per-pixel */
"16 1 1 1",
"  c None",
/* pixels */
"                ",
};

I wonder why you have to do that for it to work corrrectly though?

Offline Xaviou

  • Regular
  • ***
  • Posts: 311
    • X@v's wxStuff
Re: The 03 august 2006 build is out.
« Reply #6 on: August 05, 2006, 12:28:30 pm »
Quote
I wonder why you have to do that for it to work corrrectly though?

It is not for it to work correctly. Just to have correctly aligned menus.
And it is not only for C::B, but for all wxWidgets applications based on version 2.6.3
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

sethjackson

  • Guest
Re: The 03 august 2006 build is out.
« Reply #7 on: August 05, 2006, 02:33:07 pm »
Quote
I wonder why you have to do that for it to work corrrectly though?

It is not for it to work correctly. Just to have correctly aligned menus.
And it is not only for C::B, but for all wxWidgets applications based on version 2.6.3

Well maybe I should rephrase the question. I wonder why you have to do this to have correctly aligned menus?
I wonder where the bug is in wx.......

Offline Xaviou

  • Regular
  • ***
  • Posts: 311
    • X@v's wxStuff
Re: The 03 august 2006 build is out.
« Reply #8 on: August 05, 2006, 07:36:45 pm »
Hum, sorry for my missunderstood  :? (english is not my native language)

It seems to be a wx2.6.3 bug. And it appears only on Ms Windows version.
Linux version does correclty align menuitems with or withou bitmaps
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

sethjackson

  • Guest
Re: The 03 august 2006 build is out.
« Reply #9 on: August 06, 2006, 02:29:20 am »
Hum, sorry for my missunderstood  :? (english is not my native language)

It seems to be a wx2.6.3 bug. And it appears only on Ms Windows version.
Linux version does correclty align menuitems with or withou bitmaps

Hmm ok. Maybe I can find out why.......