Author Topic: optimize problem  (Read 3368 times)

Offline aben

  • Single posting newcomer
  • *
  • Posts: 5
    • http://
optimize problem
« on: May 25, 2005, 11:42:05 am »
Hi,

I have made a project which uses the Ogre3D engine. It compiles and works perfectly - until I check one tiny little optimize check-box in the compilers target build options.
-Then I get this message:
Quote

...
..\..\Compile\Release\.objs\Main.o(.text$_ZN20ExampleFrameListener12frameStartedERKN4Ogre10FrameEventE[ExampleFrameListener::frameStarted(Ogre::FrameEvent const&)]+0xb7):Main.cpp: variable 'Ogre::Vector3::ZERO' can't be auto-imported. Please read the documentation for ld's --enable-auto-import for details.
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings


I'm using the GCC compiler.

Well, anyway, I read the documentation for Id's but it didn't help me - or I didn't understand it well enough.

My question:
Does this have a simple explanation (and solution) or should I update my compiler skills before I feel like checking any boxes in the future?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
optimize problem
« Reply #1 on: May 25, 2005, 12:19:40 pm »
Just make sure you have in the linker options the following:
Code: [Select]
-Wl,--enable-runtime-pseudo-reloc

Yiannis.
Be patient!
This bug will be fixed soon...

Offline aben

  • Single posting newcomer
  • *
  • Posts: 5
    • http://
optimize problem
« Reply #2 on: May 25, 2005, 01:59:20 pm »
It worked!

Now that I know what to look for I also found it in the documentation - but I don't think I would have figured it out without your help.

Thanks!