Author Topic: [solved] Ogre project fails to compile on WinXP with MingW  (Read 5936 times)

freakazoid

  • Guest
[solved] Ogre project fails to compile on WinXP with MingW
« on: July 25, 2006, 08:26:41 pm »
Hi everybody,

i'm lerning Ogre engine atm. In Code::Blocks i have had some problems with it.
After spending some time reading the Ogre Wiki i realized that the Ogre templat in code::blocks seems to be incorrect
(i dindn't even get the exaple code compiled).

So i modified the wizzard script a bit (as described in the Ogre Wiki) and now it works for the release target (the debug one gets compiled without errors, but crashes on start).
Maybe i'll get that fixed, too.

The modified script can be found here.

greetz
Marco

PS: i hope i'm right in this subsection?!
PPS: Admin, the Forum says somthing like "the uploadfolder is full" ...

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: [solved] Ogre project fails to compile on WinXP with MingW
« Reply #1 on: July 25, 2006, 10:25:45 pm »
So i modified the wizzard script a bit [...]
I've adopted the script acccordingly in SVN. It should work now with recent OGRE SDK's (I've used the OGRE SDK for C::B, version 1.2.1 to verify). Thanks!
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

alfalpha

  • Guest
Re: [solved] Ogre project fails to compile on WinXP with MingW
« Reply #2 on: August 17, 2006, 04:06:21 pm »
also make shure your NOT using RC2 as OGRE will absolutly not work with RC2 you have to use a nightly build of code::blocks

hope that helps

debug crashing on startup : do you have the DirectX 9.0c Feb 2006 SDK installed (the 300 meg SDK not the runtimes) ? debug requires them