Author Topic: Project wizards  (Read 7151 times)

sethjackson

  • Guest
Project wizards
« on: July 18, 2006, 12:20:50 am »
Hi I think I may have found a bug.

1. File -> New -> Project - > wxWidgets application
2. Next
3. Fill in a project name
4. Next
5. Take the default value
6. Next
7. C::B asks you define the global variable
8. Select a valid location
9. Bug

This only happens if you have not already defined the global variable.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: Project wizards
« Reply #1 on: July 18, 2006, 07:25:34 am »
8. Select a valid location
Hmmm... I cannot reproduce - it works just fine for me. What do you mean by "Select a valid location"? Is this the wizard's message?
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Project wizards
« Reply #2 on: July 18, 2006, 11:41:05 am »
i got a script-error when i used the project wizard to generate a C::B-plugin project.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: Project wizards
« Reply #3 on: July 18, 2006, 02:13:21 pm »
i got a script-error when i used the project wizard to generate a C::B-plugin project.
Ok... which one?! :roll: :D
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Project wizards
« Reply #4 on: July 18, 2006, 02:21:21 pm »
i got a script-error when i used the project wizard to generate a C::B-plugin project.
Ok... which one?! :roll: :D

this one :D

sethjackson

  • Guest
Re: Project wizards
« Reply #5 on: July 18, 2006, 02:31:35 pm »
This only happens if you have not already defined the global variable.

;)

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Project wizards
« Reply #6 on: July 18, 2006, 02:36:45 pm »
This only happens if you have not already defined the global variable.
which global variable ??? does it have a specific name ??? tell it me !!!

sethjackson

  • Guest
Re: Project wizards
« Reply #7 on: July 18, 2006, 02:41:06 pm »
This only happens if you have not already defined the global variable.
which global variable ??? does it have a specific name ??? tell it me !!!

Any. It doesn't matter. What happens is that when the wizard asks you for a GV, and you have not already defined it it asks you for the GV. Ok no big deal that is correct behavior. Then when you hit next (after closing the GV dialog), you get the bug. Code::Blocks tells you it is not a valid location (even though you gave it a valid location). :P

Maybe I could make some screenshots....

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: Project wizards
« Reply #8 on: July 18, 2006, 02:41:20 pm »
this one :D
...then you know, what to do. Of course the affected line should read:
Code: [Select]
DebugSymbolsOn instead of
Code: [Select]
DebugingSymbolsOnI'll commit this later.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: Project wizards
« Reply #9 on: July 18, 2006, 02:42:40 pm »
Maybe I could make some screenshots....
You don't need to, I could reproduce. The fix can be done inside the wizard, I'm trying... ;-)
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Project wizards
« Reply #10 on: July 18, 2006, 02:44:56 pm »
This only happens if you have not already defined the global variable.
which global variable ??? does it have a specific name ??? tell it me !!!

Any. ...

seems that my error wasn't related to your GV theory :D

sethjackson

  • Guest
Re: Project wizards
« Reply #11 on: July 18, 2006, 02:45:26 pm »
This only happens if you have not already defined the global variable.
which global variable ??? does it have a specific name ??? tell it me !!!

Any. ...

seems that my error wasn't related to your GV theory :D

No it wasn't....

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9592
Re: Project wizards
« Reply #12 on: July 18, 2006, 03:05:43 pm »
Ok, there are a couple of things not very nice on second thoughts. Unfortunately nearly all wizards are affected. I'm in the process of correcting this - so please give me some time. mandrav: If you read this I hope you are not working on this, too... ;-)
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

sethjackson

  • Guest
Re: Project wizards
« Reply #13 on: July 18, 2006, 03:32:22 pm »
Ok, there are a couple of things not very nice on second thoughts. Unfortunately nearly all wizards are affected. I'm in the process of correcting this - so please give me some time. mandrav: If you read this I hope you are not working on this, too... ;-)

You are the wizard man aren't you.  8) Thanks for looking at it. :)

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2214
Re: Project wizards
« Reply #14 on: July 18, 2006, 06:41:00 pm »
You are the wizard man aren't you.  8) Thanks for looking at it. :)

Ah,  The Wizard of OS?  :)

Pay no attention to that man behind the curtain!
« Last Edit: July 18, 2006, 06:44:53 pm by Pecan »

sethjackson

  • Guest
Re: Project wizards
« Reply #15 on: July 19, 2006, 02:08:07 am »
You are the wizard man aren't you.  8) Thanks for looking at it. :)

Ah,  The Wizard of OS?  :)

Pay no attention to that man behind the curtain!

The Wizard of OS.  :lol:

Nice.  :lol: