Author Topic: Set Program Arguments  (Read 2300 times)

Offline BordRider

  • Multiple posting newcomer
  • *
  • Posts: 12
Set Program Arguments
« on: June 21, 2006, 07:30:24 pm »
So, this is most likely a stupid question, but I searched the forum and couldn't find an answer.  It probably has to do with my limited understanding of the debugger.

Recently, something went very wrong with my project (it wouldn't compile, it seemed like the compiler was throwing fits about spaces in file names), but after several uninstalls/installs I realized that creating a new project solved the problem.  However, somewhere in the process I installed the June 20th nightly and now for some reason I am unable to debug my program. 

Let me explain further.  I have an executable that needs command line arguments, and they are specified correctly.  However, when the debugger is called it uses the following syntax:

Code: [Select]
"C:\directory\executable.exe" arg1 arg2
Normally, this would be fine, but "arg2" does not reside in the directory calling the program, but rather:

Code: [Select]
C:\directory\
Therefore when the program executes it reports that it is not able to open "arg2".  Which makes sense, because it is not in the caller's directory.  If I use the same syntax used in the debugger on the command line, unless I am in the correct directory the program exhibits the same behavior.

I have not had this problem before, and I don't know where the problem could be.  I tried including the directory the file is in in Project -> Build Options -> Directories tab, but this did not solve the problem.  I have a hunch it is a small error on my part, but I have no idea where.

On a brighter note, I'd like to thank the community here for the continued effort put into this project.  Furthermore, it's so nice that I don't have to deal with M$ tech support  :D.  Thanks in advance.