Author Topic: Important changes to the nightly builds  (Read 148800 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5040
Important changes to the nightly builds
« on: June 09, 2006, 04:40:40 pm »
1) wxWidgets 2.6.3  (09 June 2006)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.6.3pl2. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

2) wxWidgets 2.8.3 (25 April 2007)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.3. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

3) wxWidgets 2.8.4 (May 2007)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.4. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

4) wxWidgets 2.8.6 and MinGW-GCC 4.2.1 (November 2007)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.6. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.
Next to this change the binaries are now build with MinGW GCC version 4.2.1. You might need to download the new version of mingw10m.dll  : link provided in the announcement of the nightly build.

5) wxWidgets 2.8.7 (28 November 2007)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.7. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

6) wxWidgets 2.8.8 (19 July 2008)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.8. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

7) wxWidgets 2.8.9 (18 October 2008)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.9. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

8) wxWidgets 2.8.10 (28 March 2009)
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.10. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

9) all is now build with TDM-GCC 4.4.1 (27 February 2010)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.4.1 compiler.

10) all is now build with TDM-GCC 4.5.1 (28 December 2010)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.5.1 compiler.

11) all is now build with TDM-GCC 4.5.2, wxWidgets 2.8.12 (02 April 2011)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.5.2 compiler (sjlj flavor).
From this date on the windows nightly builds will depend/based upon wxWidgets 2.8.12. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.

12) all is now build with TDM-GCC 4.7.1, wxWidgets 2.8.12 (28 October 2012)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.7.1 compiler (sjlj flavor).

13) all is now build with TDM-GCC 4.8.1, wxWidgets 2.8.12 (25 January 2014)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.8.1 compiler (sjlj flavor).

14) all is now build with TDM-GCC 4.9.2, wxWidgets 2.8.12 (17 February 2015)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 4.9.2 compiler (sjlj flavor).

15) all is now build with TDM-GCC 5.1.0, wxWidgets 2.8.12 (11 April 2016)
Therefor it is advised to also redownload the mingwm dll and the wx dll. Since these have also been rebuild with the TDM GCC 5.1.0 compiler (sjlj flavor).

16) wxWidgets 3.0.3 and 64 bit executables (28 October 2017)
From this date on the windows nightly builds will depend/based upon wxWidgets 3.0.3. Therefor you will need to download a newer version of the wx dll : link provided in the announcement of the nightly build.
And we have switched to a 64 bit application, no more 32 bit builds will be made.
« Last Edit: October 29, 2017, 07:17:14 am by killerbot »