Author Topic: Differnet wxWidgets problem  (Read 4701 times)

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Differnet wxWidgets problem
« on: June 09, 2006, 02:36:18 am »
I think I got wxWidgets to compile, but I can't gett code::blocks to work with it. I fixed some of the problems by copying the include and lib files to my compiler directory, but I still get one error it says:
cannot find -lwxmsw26

Thanks.

sethjackson

  • Guest
Re: Differnet wxWidgets problem
« Reply #1 on: June 09, 2006, 02:40:58 am »
I think I got wxWidgets to compile, but I can't gett code::blocks to work with it. I fixed some of the problems by copying the include and lib files to my compiler directory, but I still get one error it says:
cannot find -lwxmsw26

Thanks.

You don't need to copy those lib, and include files to your compiler directory.  :shock:

Put them back, and then tell C::B where you installed wxWidgets. :D

Oh BTW you really should try a nightly build if you haven't already done so.



Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #2 on: June 09, 2006, 02:44:22 am »
I got errors before I copied them. I had defined the global variable wx and set it to C:\wxWidgets-2.6.3
I also tried going into the compiler sttings and adding the paths of the include and
lib path, but it didn't work.
Am I doing this wrong?
Oh and also. I am currently using a nightly build.

sethjackson

  • Guest
Re: Differnet wxWidgets problem
« Reply #3 on: June 09, 2006, 02:47:01 am »
I got errors before I copied them. I had defined the global variable wx and set it to C:\wxWidgets-2.6.3
Oh and also. I am currently using a nightly build.

Well I know it won't work after you copy them because C::B will be look in C:\wxWidgets-2.6.3 (or wherever you told C::B to look), and the files aren't there (because you moved them) so it won't be able to compile or link.

Anyways could you post the errors you get, and your project file (*.cbp)?

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #4 on: June 09, 2006, 02:51:59 am »
I said it didn't work before I copied them not after. I am using the built in wxWidgets project, and I already posted the error, but I will post it again:
cannot find -lwxmsw26
« Last Edit: June 09, 2006, 03:00:08 am by TeddyKrulewich »

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #5 on: June 09, 2006, 03:00:21 am »
I found out where most of the errors were coming from before I moved them. So i put everything back how it was before I moved the files, then I coppied setup.h to C:/wxWidgets-2.6.3/include/wx , but I still get the cannot fine -lwxmsw26 error.

sethjackson

  • Guest
Re: Differnet wxWidgets problem
« Reply #6 on: June 09, 2006, 03:04:24 am »
I found out where most of the errors were coming from before I moved them. So i put everything back how it was before I moved the files, then I coppied setup.h to C:/wxWidgets-2.6.3/include/wx , but I still get the cannot fine -lwxmsw26 error.

Hmm could you post what you have in your project linker options?

They can be found here:

Project -> Build options -> Directories -> Linker

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #7 on: June 09, 2006, 03:05:19 am »
This is what it says:
wxmsw26

Edit:
Also, you helped me yesterday, and I told you I was using dev-cpp's compiler. I am not anymore I downloaded mingw.
The version is
GNU Make 3.80

And one more thing I'm not using them, but I have visual toolkit 2003 and ms vc++ express edition 2005. They work great with code::blocks.
« Last Edit: June 09, 2006, 03:11:33 am by TeddyKrulewich »

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #8 on: June 09, 2006, 04:16:15 am »
I got the wxWidget project to compile when I used the wizard. I was using the other thing instead before. That's strange isn't it? Only the wizard works. One question though. Is the program supposed to do nothing.

b2

  • Guest
Re: Differnet wxWidgets problem
« Reply #9 on: June 09, 2006, 04:19:03 am »
You may be use -lwxmsw instead.

There are libwxmsw26.a in my C:\wxWidgets-2.6.2\lib\gcc_lib directory,
but if it's name is libwxmsw.a you have to link with -lwxmsw not -lwxmsw26

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #10 on: June 09, 2006, 04:28:48 am »
That's not the problem.

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Differnet wxWidgets problem
« Reply #11 on: June 09, 2006, 04:46:50 am »
TeddyKrulewich: do you mean that you got the wizard working with the GCC compiler but not with the MSVC compiler?

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Differnet wxWidgets problem
« Reply #12 on: June 09, 2006, 02:44:19 pm »
No. I got something to compile with the gcc compiler, but I don't think It was working. And I haven't even tried the MSVC compiler.

edit:
I said that I got it to compile, but I didn't think it ran right. Well, for some reason it makes me compile every wxWidget project twice.
ps. I just noticed there was a typo in the subject name. What is differnet?
« Last Edit: June 09, 2006, 03:04:02 pm by TeddyKrulewich »