Author Topic: wxWidgets  (Read 3525 times)

Teddy

  • Guest
wxWidgets
« on: June 08, 2006, 02:50:14 am »
I tried the instructions to insall wxWidgets, but I can't get it to work. It might be that the instructions are for 2.6.2 and I'm using 2.6.3.

sethjackson

  • Guest
Re: wxWidgets
« Reply #1 on: June 08, 2006, 03:25:23 am »
I tried the instructions to insall wxWidgets, but I can't get it to work. It might be that the instructions are for 2.6.2 and I'm using 2.6.3.

Well you didn't tell us what OS or errors you get.....

Anyways the instructions on the wiki will work for 2.6.3. :)

http://wiki.codeblocks.org/index.php?title=Compiling_wxWidgets_2.6.2_to_develop_Code::Blocks_%28MSW%29

Teddy

  • Guest
Re: wxWidgets
« Reply #2 on: June 08, 2006, 03:38:37 am »
I am using windows xp home edition.
Here is the command I typed:
mingw32-make -f makefile.gcc MONOLITHIC=1 SHARED=1 UNICODE=1 BUILD=release

Teddy

  • Guest
Re: wxWidgets
« Reply #3 on: June 08, 2006, 03:39:52 am »
Sorry for double posting but the error message is here. www.redtrumpet.info/error.bmp

sethjackson

  • Guest
Re: wxWidgets
« Reply #4 on: June 08, 2006, 03:41:48 am »
I am using windows xp home edition.
Here is the command I typed:
mingw32-make -f makefile.gcc MONOLITHIC=1 SHARED=1 UNICODE=1 BUILD=release


Something is wrong with your compiler installation......

How did you install GCC (MinGW)?

Teddy

  • Guest
Re: wxWidgets
« Reply #5 on: June 08, 2006, 03:52:18 am »
i am using dev-cpp which has a mingw compiler

Teddy

  • Guest
Re: wxWidgets
« Reply #6 on: June 08, 2006, 03:57:01 am »
Sorry I posted again but I meant to say I am using dev-cpp's compiler not using it.
ps is there an edit button.

Offline TeddyKrulewich

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: wxWidgets
« Reply #7 on: June 08, 2006, 05:19:27 am »
I fixed it. I accidentally skipped a step. Sorry I even posted. :(
But thanks, because I never would have known I missed a step if you hadn't given me that link.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: wxWidgets
« Reply #8 on: June 08, 2006, 10:38:15 am »
I fixed it. I accidentally skipped a step. Sorry I even posted. :(
But thanks, because I never would have known I missed a step if you hadn't given me that link.

Hello,

Just for info, you can build wxWidgets by using until GCC 4.0.3. But it did not work with GCC 4.1.0.

Best wishes,
Michael

sethjackson

  • Guest
Re: wxWidgets
« Reply #9 on: June 08, 2006, 02:27:59 pm »
I fixed it. I accidentally skipped a step. Sorry I even posted. :(
But thanks, because I never would have known I missed a step if you hadn't given me that link.

Cool glad it works now. :D