Author Topic: Forbidden  (Read 7516 times)

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Forbidden
« on: June 07, 2006, 12:33:01 am »
When I try to reply to the "Linker Problems" thread:

Forbidden
You don't have permission to access /index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/1.3.36 Server at forums.codeblocks.org Port 80

sethjackson

  • Guest
Re: Forbidden
« Reply #1 on: June 07, 2006, 03:17:37 am »
When I try to reply to the "Linker Problems" thread:

Forbidden
You don't have permission to access /index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


--------------------------------------------------------------------------------

Apache/1.3.36 Server at forums.codeblocks.org Port 80


Hmm could you try again?

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #2 on: June 07, 2006, 10:53:05 am »
Heh, tried that... several times.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Forbidden
« Reply #3 on: June 07, 2006, 11:42:16 am »
If you 're trying to paste a shell script (you know, beginning with "# ! / bin / bash"), remove this very line and try again. It looks like a hack attempt to the system.
Be patient!
This bug will be fixed soon...

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #4 on: June 07, 2006, 10:34:08 pm »
I don't know what a shell script is... I looked over what I was pasting and I'm pretty sure none of it has the line that you mentioned or even any part of it.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2173
Re: Forbidden
« Reply #5 on: June 08, 2006, 12:18:46 am »
I don't know what a shell script is... I looked over what I was pasting and I'm pretty sure none of it has the line that you mentioned or even any part of it.

If any line has the chars "/ bin" put a space between
the "/" and the "bin".

Are there any "/"s in your pasted text? If so, put a space
after them.

Are there any "./"s in the text? Put spaces around the "/"s

« Last Edit: June 08, 2006, 12:24:50 am by Pecan »

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #6 on: June 08, 2006, 08:43:17 am »
There are no '/'s, but there's alot of '\'s.

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #7 on: June 10, 2006, 06:47:44 am »
I tried Pecan's advice with my '\'s, but it didn't help.

Admin?
« Last Edit: June 10, 2006, 06:52:26 am by xLordRADx »

Offline kkez

  • Almost regular
  • **
  • Posts: 153
    • WinapiZone
Re: Forbidden
« Reply #8 on: June 10, 2006, 11:08:01 am »
Paste what you're trying to post in a file and attach it to your post. That should work fine!

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #9 on: June 13, 2006, 11:19:01 pm »
Here is the post I tried to make:



[attachment deleted by admin]

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
Re: Forbidden
« Reply #10 on: June 13, 2006, 11:36:54 pm »
.objs\newJourney.o:newJourney.cpp:(.text+0x186): undefined reference to `creature::creature()'
.objs\newJourney.o:newJourney.cpp:(.text+0x1ee): undefined reference to `creature::setName(std::string)'
It's written there: The linker cannot find thre methods creature::creature() and creature::setName(std::string). So what you've done wrong could be:
1.) You forgot to link to a library (or object file) that provides the implementation of these methods
2.) Your link order is wrong - the library providing the implementation of these methods is linked after the library (or object file) that refers to it.
3.) You really did forget to implement these methods. Thus e.g. the definition is in the header file but there is no implementation in the implementation file.
Could you check for that?
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2173
Re: Forbidden
« Reply #11 on: June 13, 2006, 11:54:42 pm »
Here is the post I tried to make:

It appears that the forum server does not like any lib names.

If, for example, the spaces were taken out of l i b d p l a y x,
I'll get a 404 with a warning:

Code: [Select]
Forbidden
You don't have permission to access /index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.36 Server at forums.codeblocks.org Port 80

[/quote]
Code: [Select]
l i b d p l a y x

Offline xLordRADx

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Forbidden
« Reply #12 on: June 14, 2006, 03:12:29 am »
Thanks to both of you, you each solved one of my problems.

Offline liuke520

  • Single posting newcomer
  • *
  • Posts: 8
CodeBlocks RC3 + MinGW strongly request the use of GCC4.0 and above version!

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9496
CodeBlocks RC3 + MinGW strongly request the use of GCC4.0 and above version!
Could one on the admins ban this guy? It's not funny anymore. :?
(BTW: It's not even a sentence...?!) :lol:
« Last Edit: June 14, 2006, 08:05:33 am by MortenMacFly »
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ