Author Topic: Plugins that failed to load: libcompiler.so - Solved  (Read 8196 times)

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Plugins that failed to load: libcompiler.so - Solved
« on: May 17, 2006, 03:47:15 pm »
Hi

Just compiled from SVN - which all worked - but I run I get the following messages:

Code: [Select]
Manager initialized
Configured 0 tools
Scanning for plugins in /usr/local/share/codeblocks/plugins...
Found 9 plugins
Plugins that failed to load: libcompiler.so
Loading: AStylePlugin Autosave ClassWizard CodeCompletion Debugger FilesExtensionHandler PluginWizard Wizard ToDoList

The file appears to exist

Code: [Select]
:/usr/local/share/codeblocks/plugins$ ll
total 17232
-rwxr-xr-x  1 root root    1048 2006-05-17 23:29 libastyle.la
-rwxr-xr-x  1 root root 1361363 2006-05-17 23:29 libastyle.so
-rwxr-xr-x  1 root root    1060 2006-05-17 23:29 libautosave.la
-rwxr-xr-x  1 root root  399899 2006-05-17 23:29 libautosave.so
-rwxr-xr-x  1 root root    1078 2006-05-17 23:29 libclasswizard.la
-rwxr-xr-x  1 root root  518356 2006-05-17 23:29 libclasswizard.so
-rwxr-xr-x  1 root root    1096 2006-05-17 23:29 libcodecompletion.la
-rwxr-xr-x  1 root root 3936839 2006-05-17 23:29 libcodecompletion.so
-rwxr-xr-x  1 root root    1060 2006-05-17 23:29 libcompiler.la
-rwxr-xr-x  1 root root 3913099 2006-05-17 23:29 libcompiler.so
-rwxr-xr-x  1 root root    1078 2006-05-17 23:29 libdebuggergdb.la
-rwxr-xr-x  1 root root 3543639 2006-05-17 23:29 libdebuggergdb.so
-rwxr-xr-x  1 root root    1120 2006-05-17 23:29 libdefaultmimehandler.la
-rwxr-xr-x  1 root root  638041 2006-05-17 23:29 libdefaultmimehandler.so
-rwxr-xr-x  1 root root    1084 2006-05-17 23:29 libpluginwizard.la
-rwxr-xr-x  1 root root  842118 2006-05-17 23:29 libpluginwizard.so
-rwxr-xr-x  1 root root    1090 2006-05-17 23:29 libprojectwizard.la
-rwxr-xr-x  1 root root 1313821 2006-05-17 23:29 libprojectwizard.so
-rwxr-xr-x  1 root root    1036 2006-05-17 23:29 libtodo.la
-rwxr-xr-x  1 root root 1075601 2006-05-17 23:29 libtodo.so

What can I do to get the compiler working.  I'm not able to even open a project without this plugin !

Thanks
« Last Edit: May 20, 2006, 06:01:58 am by Gibbon »

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Plugins that failed to load: libcompiler.so
« Reply #1 on: May 17, 2006, 11:15:58 pm »
Hello,

Which revision? Which OS?

Did you get some warnings when building C::B?

Best wishes,
Michael

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #2 on: May 18, 2006, 12:38:52 am »
Which revision? Which OS?

Did you get some warnings when building C::B?


Hi

It was a SVN build - so whatever the latest source version is.

OS - Ubuntu 5.10

No warnings - it was a clean compile.

Prior to doing the build, I was using the .deb package from 9 May - but it kept crashing - so I thought I'd do a source build to get the latest version.

Thanks

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Plugins that failed to load: libcompiler.so
« Reply #3 on: May 18, 2006, 10:45:22 am »
It was a SVN build - so whatever the latest source version is.

Yes, but whith svn you can check the revision number. This is always helpful.

OS - Ubuntu 5.10

No warnings - it was a clean compile.

But something goes wrong. Did you uninstall the .deb package, before installing C::B?

Also check if you do not have more than one codeblocks libraries in your system. May be you have a conflict between libraries.

Prior to doing the build, I was using the .deb package from 9 May - but it kept crashing - so I thought I'd do a source build to get the latest version.

Which crash? The two worst crashes have been fixed and I did not remark any other crash.

Best wishes,
Michael

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #4 on: May 18, 2006, 01:20:30 pm »

You were right - I already had a older version installed - the svn version must have been referencing the older libraries.

I'm now running the 9th May version - but would still like to build from source.

Now I get the following errors:

Code: [Select]
Checked out revision 2472.

[email protected]:~/cb/trunk$ ./bootstrap
/usr/share/aclocal/mozilla-thunderbird-nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal

[email protected]:~/cb/trunk$ ./configure > /tmp/cb.log
[email protected]:~/cb/trunk$ make >> /tmp/cb.log
libtool: link: warning: `-version-info/-version-number' is ignored for convenience libraries
printdlg.h:16: error: ‚PrintColourMode‚ does not name a type
main.cpp: In member function ‚void MainFrame::CreateMenubar()‚:
main.cpp:607: error: ‚EditorColourSet‚ was not declared in this scope
main.cpp:607: error: ‚theme‚ was not declared in this scope
main.cpp:607: error: ‚class EditorManager‚ has no member named ‚GetColourSet‚
main.cpp: In member function ‚void MainFrame::OnFilePrint(wxCommandEvent&)‚:
main.cpp:1906: error: ‚class PrintDialog‚ has no member named ‚GetPrintColourMode‚
main.cpp: In member function ‚void MainFrame::OnEditHighlightMode(wxCommandEvent&)‚:
main.cpp:2244: error: ‚EditorColourSet‚ was not declared in this scope
main.cpp:2244: error: ‚theme‚ was not declared in this scope
main.cpp:2244: error: ‚class EditorManager‚ has no member named ‚GetColourSet‚
make[3]: *** [main.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Plugins that failed to load: libcompiler.so
« Reply #5 on: May 18, 2006, 01:24:20 pm »
Quote
[email protected]:~/cb/trunk$ ./bootstrap
/usr/share/aclocal/mozilla-thunderbird-nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
Something is seriously screwed up in your system...

Quote
main.cpp: In member function void MainFrame::CreateMenubar()
Also, it seems your terminal and your compiler use different character encodings.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #6 on: May 18, 2006, 02:08:19 pm »
Something is seriously screwed up in your system...

Not anymore :D

Also, it seems your terminal and your compiler use different character encodings.

I'm ssh'd in from a laptop - working from the terminal works ok.

Still can't compile however---

Code: [Select]
if g++ -DHAVE_CONFIG_H -I. -I. -I../../src/sdk -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA   -I../../src/sdk/wxscintilla/include -I../../src/sdk -I../../src/sdk/wxFlatNotebook -I../../src/src/wxAUI -DENABLE_BINRELOC -DAPP_PREFIX="\"/usr/local\"" -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA  -O2 -ffast-math -g -O2 -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -MT main.o -MD -MP -MF ".deps/main.Tpo" -c -o main.o main.cpp; \
then mv -f ".deps/main.Tpo" ".deps/main.Po"; else rm -f ".deps/main.Tpo"; exit 1; fi
printdlg.h:16: error: ‚PrintColourMode‚ does not name a type
main.cpp: In member function ‚void MainFrame::CreateMenubar()‚:
main.cpp:607: error: ‚EditorColourSet‚ was not declared in this scope
main.cpp:607: error: ‚theme‚ was not declared in this scope
main.cpp:607: error: ‚class EditorManager‚ has no member named ‚GetColourSet‚
main.cpp: In member function ‚void MainFrame::OnFilePrint(wxCommandEvent&)‚:
main.cpp:1906: error: ‚class PrintDialog‚ has no member named ‚GetPrintColourMode‚
main.cpp: In member function ‚void MainFrame::OnEditHighlightMode(wxCommandEvent&)‚:
main.cpp:2244: error: ‚EditorColourSet‚ was not declared in this scope
main.cpp:2244: error: ‚theme‚ was not declared in this scope
main.cpp:2244: error: ‚class EditorManager‚ has no member named ‚GetColourSet‚
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/home/dberry/cb/trunk/src/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dberry/cb/trunk/src/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dberry/cb/trunk/src'
make: *** [all-recursive] Error 1

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Plugins that failed to load: libcompiler.so
« Reply #7 on: May 18, 2006, 02:44:08 pm »
Hello,

Do you have any character encoding problem? Look at here:

Quote
printdlg.h:16: error: PrintColourMode does not name a type

This is not normal.

Best wishes,
Michael

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #8 on: May 19, 2006, 12:09:14 am »
Do you have any character encoding problem? Look at here:

No - as mentioned, I was ssh'ing into the box - when I compile from a local terminal I still get the same errors:

Code: [Select]
make[3]: Entering directory `/home/dberry/cb/trunk/src/src'
if g++ -DHAVE_CONFIG_H -I. -I. -I../../src/sdk -I/usr/lib/wx/include/gtk2-unicod e-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFF SET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA   -I../../src/s dk/wxscintilla/include -I../../src/sdk -I../../src/sdk/wxFlatNotebook -I../../sr c/src/wxAUI -DENABLE_BINRELOC -DAPP_PREFIX="\"/usr/local\"" -I/usr/lib/wx/includ e/gtk2-unicode-release-2.6 -I/usr/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK_ _ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA  - O2 -ffast-math -g -O2 -I/usr/lib/wx/include/gtk2-unicode-release-2.6 -I/usr/incl ude/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILE S -D_LARGEFILE_SOURCE=1 -DNO_GCC_PRAGMA -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC - MT main.o -MD -MP -MF ".deps/main.Tpo" -c -o main.o main.cpp; \
then mv -f ".deps/main.Tpo" ".deps/main.Po"; else rm -f ".deps/main.Tpo"; exit 1 ; fi
printdlg.h:16: error: ĎPrintColourModeí does not name a type
main.cpp: In member function Ďvoid MainFrame::CreateMenubar()í:
main.cpp:607: error: ĎEditorColourSetí was not declared in this scope
main.cpp:607: error: Ďthemeí was not declared in this scope
main.cpp:607: error: Ďclass EditorManagerí has no member named ĎGetColourSetí
main.cpp: In member function Ďvoid MainFrame::OnFilePrint(wxCommandEvent&)í:
main.cpp:1906: error: Ďclass PrintDialogí has no member named ĎGetPrintColourMod eí
main.cpp: In member function Ďvoid MainFrame::OnEditHighlightMode(wxCommandEvent &)í:
main.cpp:2244: error: ĎEditorColourSetí was not declared in this scope
main.cpp:2244: error: Ďthemeí was not declared in this scope
main.cpp:2244: error: Ďclass EditorManagerí has no member named ĎGetColourSetí
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/home/dberry/cb/trunk/src/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/dberry/cb/trunk/src/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dberry/cb/trunk/src'
make: *** [all-recursive] Error 1

Will this help

Code: [Select]
[email protected]:~/cb/trunk$ gcc --version
gcc (GCC) 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)

Code: [Select]
Linux opteron 2.6.12-10-k7-smp #1 SMP Fri Apr 28 14:17:26 UTC 2006 i686 GNU/Linux

Code: [Select]
[email protected]:~/cb/trunk$ echo $PATH
/usr/local/bin:/usr/local/sbin:/sbin:/usr/sbin:/bin:/usr/bin:/usr/bin/X11:/usr/games

Thanks.

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Plugins that failed to load: libcompiler.so
« Reply #9 on: May 19, 2006, 09:51:54 am »
Did you try a clean rebuild, including removing all precompiled headers etc? It does not seem to find things like EditorColourSet, so it may be that it still uses an old precompiled header.

Also, this is a bit strange, but that could be an artefact due to copying from your terminal, too:
g++ [...] -I/usr/lib/wx/include/gtk2-unicod e-release-2.6 [...] -I../../src/s dk/wxscintilla/include -I../../src/sdk [...] -I../../sr c/src/wxAUI
If you have those odd space chars on the original console too, then the compiler will of course not find one include file.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #10 on: May 20, 2006, 12:54:13 am »
Did you try a clean rebuild, including removing all precompiled headers etc? It does not seem to find things like EditorColourSet, so it may be that it still uses an old precompiled header.

Ok - What's the best way to do that? I tried a 'make uninstall' - is that enough?

Thanks

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Plugins that failed to load: libcompiler.so
« Reply #11 on: May 20, 2006, 12:57:12 am »
Actually it should be just fine if you do:
make clean && make
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Gibbon

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Plugins that failed to load: libcompiler.so
« Reply #12 on: May 20, 2006, 06:01:13 am »
Actually it should be just fine if you do:
make clean && make

That was it - works fine now.

Compiled with no problems - ran it and got the

Code: [Select]
/usr/local/bin/codeblocks: error while loading shared libraries: libcodeblocks.so.0: cannot open shared object file: No such file or directory

But that was fixed by running ldconfig again.

Thanks