Author Topic: GCC 4.0.3 for MinGW  (Read 7004 times)

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
GCC 4.0.3 for MinGW
« on: May 07, 2006, 02:41:08 am »
Well, here's just another precompiled version of GCC for Windows, so now you can try both the 4.0.x and 4.1.x branches.

4.0.3 is more recent than 4.1.0, it's supposed to have an optimised C++ parser while 4.1.0 an optimised C parser, but I think it's still as slow as usual.

Right now I'm compiling wxWidgets 2.6.3 (patch 2) to see if it's at least more usable than 4.1.0. The link will be added to my signature shortly.

The installation process is still the same: just overwrite.

Well, that said, I'll start uploading and then change my signature...

Enjoy.

[edit]
OK, it's done.

BTW, wxWidgets compiled without problems.
[/edit]
« Last Edit: May 07, 2006, 02:52:36 am by Ceniza »

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: GCC 4.0.3 for MinGW
« Reply #1 on: May 07, 2006, 03:21:50 am »
Cool 8).

Thank you very much :D.

Did you try to build 4.2?

Best wishes,
Michael

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: GCC 4.0.3 for MinGW
« Reply #2 on: May 07, 2006, 04:02:00 am »
Quote from: Michael
Did you try to build 4.2?

Nop. I don't have plans to compile it any time soon either.

Let me know if you get to compile wxWidgets too :)

This version looks promising: it didn't fail the build process neither building wxWidgets. I'll just keep it for a while :D

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: GCC 4.0.3 for MinGW
« Reply #3 on: May 07, 2006, 04:06:00 am »
Quote from: Michael
Did you try to build 4.2?

Nop. I don't have plans to compile it any time soon either.

Let me know if you get to compile wxWidgets too :)

This version looks promising: it didn't fail the build process neither building wxWidgets. I'll just keep it for a while :D

Hello,

wxWidgets 2.6.3 with Patch 2 builds fine.

But not C::B :?.

I get:

Quote
sdk\wxscintilla\src\PlatWX.cpp:1423: internal compiler error: output_operand: invalid expression as operand
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
{standard input}: Assembler messages:
{standard input}:5491: Warning: partial line at end of file ignored
Process terminated with status 1 (0 minutes, 15 seconds)
1 errors, 207 warnings

Quite strange :(.

Best wishes,
Michael

Offline Ceniza

  • Developer
  • Lives here!
  • *****
  • Posts: 1442
    • CenizaSOFT
Re: GCC 4.0.3 for MinGW
« Reply #4 on: May 07, 2006, 04:28:47 am »
Really bad news :(

GCC 4.1.0 was at least able to compile Code::Blocks but failed to compile wxWidgets. Now it's the other way around.

Thanks for that info. I'll just go back to 3.4.5.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: GCC 4.0.3 for MinGW
« Reply #5 on: May 07, 2006, 04:31:33 am »
Really bad news :(

GCC 4.1.0 was at least able to compile Code::Blocks but failed to compile wxWidgets. Now it's the other way around.

Thanks for that info. I'll just go back to 3.4.5.

May be it is just a local problem, but I think not. GCC 4.1.0 is building C::B fine.

Anyway, now I have wxWidgets 2.6.3 with Patch2 built with 4.0.3 :). This is not bad.

Best wishes,
Michael