Author Topic: Error when building the .deb package (rev2430)  (Read 3714 times)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Error when building the .deb package (rev2430)
« on: May 09, 2006, 01:07:53 pm »
Hello,

I have a problem when building the .deb package for rev2430:

Quote
creating libenvvars.la
(cd .libs && rm -f libenvvars.la && ln -s ../libenvvars.la libenvvars.la)
make[5]: *** No rule to make target `envvars.zip', needed by `all-am'.  Stop.
make[5]: Leaving directory `/home/michael/devel/trunk/src/plugins/contrib/envvars'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/michael/devel/trunk/src/plugins/contrib'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/michael/devel/trunk/src/plugins'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/michael/devel/trunk/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/michael/devel/trunk'
make: *** [build-stamp] Error 2

Best wishes,
Michael

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9524
Re: Error when building the .deb package (rev2430)
« Reply #1 on: May 09, 2006, 01:17:43 pm »
I have a problem when building the .deb package for rev2430:
...I have no access to a linux box but from my limited knowledge you have to change the Makefile.am in plugins\contrib\envvars like this:
OLD:
Code: [Select]
codestat.zip:
PWD=`pwd` cd $(srcdir) && zip $(PWD)/envvars.zip *.xrc > /dev/null
NEW:
Code: [Select]
envvars.zip:
PWD=`pwd` cd $(srcdir) && zip $(PWD)/envvars.zip *.xrc > /dev/null
...let me know if it works.
Thanks - Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Error when building the .deb package (rev2430)
« Reply #2 on: May 09, 2006, 01:22:13 pm »
Ah yes, stupid copy-paste issue :)
Have you commited the fix Morten?
Be patient!
This bug will be fixed soon...

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Error when building the .deb package (rev2430)
« Reply #3 on: May 09, 2006, 01:31:53 pm »
I have a problem when building the .deb package for rev2430:
...I have no access to a linux box but from my limited knowledge you have to change the Makefile.am in plugins\contrib\envvars like this:
OLD:
Code: [Select]
codestat.zip:
PWD=`pwd` cd $(srcdir) && zip $(PWD)/envvars.zip *.xrc > /dev/null
NEW:
Code: [Select]
envvars.zip:
PWD=`pwd` cd $(srcdir) && zip $(PWD)/envvars.zip *.xrc > /dev/null
...let me know if it works.
Thanks - Morten.

Hello,

I will change it and try again. I will let you know in 60-90 minutes if it works.

Thank you very much :).

Ah yes, stupid copy-paste issue :)

No problems :). Such things could happen.

Best wishes,
Michael
« Last Edit: May 09, 2006, 01:33:25 pm by Michael »

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9524
Re: Error when building the .deb package (rev2430)
« Reply #4 on: May 09, 2006, 02:24:04 pm »
Have you commited the fix Morten?
...done.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Error when building the .deb package (rev2430)
« Reply #5 on: May 09, 2006, 07:26:28 pm »
Hello,

All it's fine now :).

Thanks.

Best wishes,
Michael