Author Topic: The 28 april 2006 build is out.  (Read 38043 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 28 april 2006 build is out.
« on: April 28, 2006, 08:07:45 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 28 April 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060428_rev2395_win32.7z
  - Linux :
         http://download.berlios.de/codeblocks/CB_20060428_rev2395_ubuntu.deb
         http://download.berlios.de/codeblocks/CB_20060428_rev2395_fc4+5.rpm

Resolved Fixed:

  • wxSmith redesign: Removed timers in wxsDrawingWindow - it should now work without flickering
  • Removed copying manifest file around (not needed and confuses people)
  • Patch #1019 : Fixes bug #7275 ("lost keywords")

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • there are several issues with Code Completion (is being redesigned : work in progress)

« Last Edit: April 29, 2006, 10:10:21 am by killerbot »

Offline lubos

  • Almost regular
  • **
  • Posts: 131
Re: The 28 april 2006 build is out.
« Reply #1 on: April 28, 2006, 08:50:16 pm »
can't download - file doesn'n exist :?

Offline cprgmswr2

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: The 28 april 2006 build is out.
« Reply #2 on: April 28, 2006, 08:50:46 pm »
Is there a reason this link doesn't work?
   http://download.berlios.de/codeblocks/CB_20060428_rev2391_win32.7z

sethjackson

  • Guest
Re: The 28 april 2006 build is out.
« Reply #3 on: April 28, 2006, 09:03:33 pm »
Wait a little bit longer.... It should be up soon.....

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 28 april 2006 build is out.
« Reply #4 on: April 28, 2006, 09:53:20 pm »
woops my mistake : fixed now

Offline cprgmswr2

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: The 28 april 2006 build is out.
« Reply #5 on: April 28, 2006, 09:58:00 pm »
Why is the manifest file still included in the download if its no longer needed?

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: The 28 april 2006 build is out.
« Reply #6 on: April 28, 2006, 09:59:25 pm »
Just to make you wonder.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline cprgmswr2

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: The 28 april 2006 build is out.
« Reply #7 on: April 28, 2006, 10:00:28 pm »
LOL

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 28 april 2006 build is out.
« Reply #8 on: April 28, 2006, 10:03:45 pm »
Why is the manifest file still included in the download if its no longer needed?
Just to make you wonder.

 8) 8) because update.bat does what it says, updating, it does not remove stuff no longer needed.  :lol:

Offline nu-kinetix

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 28 april 2006 build is out.
« Reply #9 on: April 28, 2006, 10:27:15 pm »
I haven't used a "nightly build" code:blocks version since sometime in january. I just tried this one and, I must be doing something very stupid, but while everything seems to work fine ... the code editor just doesnt' come up! When I double click on a project file (C source) nothing happens, but the open file list indicates that it's open.

Any ideas?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 28 april 2006 build is out.
« Reply #10 on: April 28, 2006, 10:28:45 pm »
Try "View->Layouts->Delete current"...
Be patient!
This bug will be fixed soon...

Offline nu-kinetix

  • Single posting newcomer
  • *
  • Posts: 3
Re: The 28 april 2006 build is out.
« Reply #11 on: April 28, 2006, 10:31:56 pm »
Thanks mate, it's working now :)

acercpp

  • Guest
Re: The 28 april 2006 build is out.
« Reply #12 on: April 29, 2006, 09:27:16 am »
I tent to change use Dev-Cpp to C::B, but when I was import a project from a .dev file, I found that I can not import all the settings for that particular project. Is C::B could or not do that?

By the way, I feel the auto code completion is inconvenient in C::B, the editor always loses the focus. Also I think this feature is not so important, How is your plan? Personally, I prefered to use the feature in MS-VS. Hopefully we can see your new version ASAP. :P

Offline Tjaalie

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: The 28 april 2006 build is out.
« Reply #13 on: April 29, 2006, 11:15:21 am »
toolbar-images-not-changing-state (is a wx problem/Win XP problem)

For some reason this bug dissapeard for me in the prev nightly build and is also gone in this one.
I only noticed it a few minutes ago.

Offline grosem

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 28 april 2006 build is out.
« Reply #14 on: April 29, 2006, 11:31:29 am »
Hi,
I liked to try Code:Blocks, but I have the same error with every nightly build. When I try to start a new project it's always crashing :-/

I use Fedora Core 5 and get the following report:

Quote
<?xml version="1.0" encoding="utf-8"?>
<report version="1.0" kind="exception">
  <system description="Linux 2.6.16-1.2096_FC5 i686"/>
  <modules>
    <module path="[vdso]" address="005b5000" size="00001000"/>
    <module path="[heap]" address="0986c000" size="00d5c000"/>
    <module path="/SYSV00000000" address="b44eb000" size="00063000"/>
    <module path="/SYSV00000000" address="b7b8d000" size="00060000"/>
  </modules>
  <stack>
    <frame level="2" function="wxStackWalker::Walk(unsigned int)" offset="00000036"/>
    <frame level="3" function="wxDebugReport::AddContext(wxDebugReport::Context)" offset="00000b33"/>
    <frame level="4" function="wxDebugReport::AddAll(wxDebugReport::Context)" offset="00000018"/>
    <frame level="5" function="wxHtmlWindow::LoadPage(wxString const&amp;)" offset="00000d1a"/>
    <frame level="6" function="wxFatalSignalHandler" offset="00000026"/>
    <frame level="7"/>
    <frame level="8" function="NewFromTemplateDlg::BuildCategories()" offset="000000ea"/>
    <frame level="9" function="NewFromTemplateDlg::NewFromTemplateDlg(ProjectTemplateArray const&amp;, wxArrayString const&amp;)" offset="0000020a"/>
    <frame level="10" function="TemplateManager::NewProject()" offset="000002e8"/>
    <frame level="11" function="MainFrame::OnProjectNew(wxCommandEvent&amp;)" offset="00000030"/>
    <frame level="12" function="wxAppConsole::HandleEvent(wxEvtHandler*, void (wxEvtHandler::*)(wxEvent&amp;), wxEvent&amp;) const" offset="00000035"/>
    <frame level="13" function="wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&amp;, wxEvtHandler*, wxEvent&amp;)" offset="00000092"/>
    <frame level="14" function="wxEventHashTable::HandleEvent(wxEvent&amp;, wxEvtHandler*)" offset="0000007d"/>
    <frame level="15" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="000000cf"/>
    <frame level="16" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="17" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="18" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="19" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="20" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="21" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="22" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="23" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="24" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="25" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="26" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="27" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="28" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="29" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="30" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="31" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="32" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="33" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="34" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="35" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="36" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="37" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="38" function="wxEvtHandler::ProcessEvent(wxEvent&amp;)" offset="0000006e"/>
    <frame level="39"/>
    <frame level="40" function="g_cclosure_marshal_VOID__VOID" offset="00000049"/>
    <frame level="41" function="g_closure_invoke" offset="0000011d"/>
    <frame level="42"/>
    <frame level="43" function="g_signal_emit_valist" offset="000008c7"/>
    <frame level="44" function="g_signal_emit" offset="00000029"/>
    <frame level="45" function="gtk_widget_activate" offset="00000094"/>
    <frame level="46" function="gtk_menu_shell_activate_item" offset="00000118"/>
    <frame level="47"/>
    <frame level="48"/>
    <frame level="49"/>
    <frame level="50"/>
    <frame level="51" function="g_closure_invoke" offset="0000011d"/>
    <frame level="52"/>
    <frame level="53" function="g_signal_emit_valist" offset="0000068f"/>
    <frame level="54" function="g_signal_emit" offset="00000029"/>
    <frame level="55"/>
    <frame level="56" function="gtk_propagate_event" offset="00000183"/>
    <frame level="57" function="gtk_main_do_event" offset="00000317"/>
    <frame level="58"/>
    <frame level="59" function="g_main_context_dispatch" offset="0000016d"/>
    <frame level="60"/>
    <frame level="61" function="g_main_loop_run" offset="000001a9"/>
    <frame level="62" function="gtk_main" offset="000000b4"/>
    <frame level="63" function="wxEventLoop::Run()" offset="0000005b"/>
    <frame level="64" function="wxAppBase::MainLoop()" offset="0000004c"/>
    <frame level="65" function="wxAppBase::OnRun()" offset="00000021"/>
    <frame level="66"/>
    <frame level="67" function="wxEntry(int&amp;, wchar_t**)" offset="0000006a"/>
    <frame level="68" function="wxEntry(int&amp;, char**)" offset="00000036"/>
    <frame level="69" function="EditorBase::CreateContextSubMenu(int)" offset="000002c2"/>
  </stack>
</report>

I'm sorry if this is a known bug.

Grosem

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 28 april 2006 build is out.
« Reply #15 on: April 29, 2006, 11:47:04 am »
For some reason this bug dissapeard for me in the prev nightly build and is also gone in this one.
I only noticed it a few minutes ago.

Look at the Save and Print button. In my system (Win x64 Pro, latest nightly) those always look like they're enabled even if they shouldn't be. The same problem is in the menus too, e.g. File - Save graphic always looks like it's enabled.

Hi,
I liked to try Code:Blocks, but I have the same error with every nightly build. When I try to start a new project it's always crashing :-/

I use Fedora Core 5 and get the following report:

What plugins do you have enabled?
« Last Edit: April 29, 2006, 11:51:15 am by artoj »

Offline grosem

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 28 april 2006 build is out.
« Reply #16 on: April 29, 2006, 11:52:23 am »


Hi,
I liked to try Code:Blocks, but I have the same error with every nightly build. When I try to start a new project it's always crashing :-/

I use Fedora Core 5 and get the following report:

Quote
<frame level="69" function="EditorBase::CreateContextSubMenu(int)" offset="000002c2"/>

That line looks interesting, what plugins do you have enabled?
[/quote]

I just use Codeblocks out of the box without having changed anything.

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #17 on: April 29, 2006, 11:56:55 am »
Same with FC4 :?

I only tested the build by switching through the menus, but never tried to create a new project. :(

@artoj: enabled plugins:
Quote
Found 16 plugins
Loading: Wizard wxSmith wxSmithMime wxSmithWizard AStylePlugin CodeStatistics ToDoList FilesExtensionHandler cbKeyBinder Compiler PluginWizard DragScroll Debugger Source Exporter CBProfiler ClassWizard HelpPlugin CodeCompletion
Nightly builds for openSUSE

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 28 april 2006 build is out.
« Reply #18 on: April 29, 2006, 12:02:51 pm »
I just use Codeblocks out of the box without having changed anything.

Could you disable all plugins except Compiler, Debugger, File extensions handler, Generic wizard.

Also, at what point the crashing happens? Do you see the new project dialog? If you see the New project dialog, could you check the "Show file-based templates" checkbox and then select "Console Application" and try to create it.

Offline grosem

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 28 april 2006 build is out.
« Reply #19 on: April 29, 2006, 12:17:16 pm »
I just use Codeblocks out of the box without having changed anything.

Could you disable all plugins except Compiler, Debugger, File extensions handler, Generic wizard.

Also, at what point the crashing happens? Do you see the new project dialog? If you see the New project dialog, could you check the "Show file-based templates" checkbox and then select "Console Application" and try to create it.

I disabled the plugins but it's still the same error. I don't see the "New Project Dialog" :-/

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 28 april 2006 build is out.
« Reply #20 on: April 29, 2006, 12:54:58 pm »
I disabled the plugins but it's still the same error. I don't see the "New Project Dialog" :-/

OK, this might be a GTK error, so we need more information.

Could you type this to terminal and tell us what it outputs:

Code: [Select]
wx-config --version-full

----

You were able to disable the plugins so you can see other dialogs, could you test if you can see these dialogs:

- Settings -> Enviroment|Editor|Compiler and Debugger
- Tools -> Configure tools

If you can see the Settings -> Enviroment dialog, go to View and disable the "Start here" page and test to create a project again.

----

And last, could you download this simple project file, extract it ("unzip TestConsole.zip") and try to open it from:
- Code::Blocks -> File -> Open
- From terminal "codeblocks TestConsole.cbp"

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #21 on: April 29, 2006, 01:18:21 pm »
No, I don't see the New project dialog, only a dialog saying smth
OK, this might be a GTK error, so we need more information.

Could you type this to terminal and tell us what it outputs:

Code: [Select]
wx-config --version-full
Code: [Select]
wx-config --version-full
2.6.2.1
You were able to disable the plugins so you can see other dialogs, could you test if you can see these dialogs:

- Settings -> Enviroment|Editor|Compiler and Debugger
- Tools -> Configure tools
I can see them.
If you can see the Settings -> Enviroment dialog, go to View and disable the "Start here" page and test to create a project again.
Crash is still there.
And last, could you download this simple project file, extract it ("unzip TestConsole.zip") and try to open it from:
- Code::Blocks -> File -> Open
- From terminal "codeblocks TestConsole.cbp"
The project opens correctly (only a warning that the format is an older one v1.3 instead of v1.4)
Nightly builds for openSUSE

Offline grosem

  • Single posting newcomer
  • *
  • Posts: 4
Re: The 28 april 2006 build is out.
« Reply #22 on: April 29, 2006, 01:26:19 pm »
Exactly the same here, except:

wx-config --version-full
2.6.3.1

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #23 on: April 29, 2006, 01:37:41 pm »
I'm currently installing the debuginfo packages for wxGTK and codeblocks (it hasn't been uploaded because it's too big, 25 MB). Will start codeblocks with gdb and look whether there is a bit more information.
Nightly builds for openSUSE

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #24 on: April 29, 2006, 02:13:31 pm »
I attached the whole gdb output and also the codeblocks debug report.

I hope that will bring light into darkness  :lol:

[attachment deleted by admin]
Nightly builds for openSUSE

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 28 april 2006 build is out.
« Reply #25 on: April 29, 2006, 02:42:59 pm »
OK, mandrav created the new project wizard april 18th.

Does the crash happen in nightly builds before april 18th?

Could you test older builds than that also?

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #26 on: April 29, 2006, 02:57:18 pm »
OK, mandrav created the new project wizard april 18th.

Does the crash happen in nightly builds before april 18th?

Could you test older builds than that also?
I'll test through a few older builds and report which doesn't work and which does.
Nightly builds for openSUSE

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 28 april 2006 build is out.
« Reply #27 on: April 29, 2006, 03:01:55 pm »
It's obvious that once again we 're talking about missing resources.
Before building your packages, run "make clean-zipfiles" first...
Be patient!
This bug will be fixed soon...

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #28 on: April 29, 2006, 03:18:18 pm »
ok, will do this.

Is there no possibility to make the resources dependent on the source files they belong to. So that make creates a new zipfile if the source changed ?

EDIT: Will upload a rebuilt package in half an hour.
« Last Edit: April 29, 2006, 03:22:29 pm by daniel2000 »
Nightly builds for openSUSE

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: The 28 april 2006 build is out.
« Reply #29 on: April 29, 2006, 04:33:14 pm »
Rebuilt fedora package is uploaded.

At the moment "file doesn't exist" appears when downloading. But it should be available in some time.
Nightly builds for openSUSE

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 28 april 2006 build is out.
« Reply #30 on: April 29, 2006, 04:47:01 pm »
Rebuilt fedora package is uploaded.

At the moment "file doesn't exist" appears when downloading. But it should be available in some time.
I am afraid it will never pop up again. In the admin, it claims to be added, but then it should give the file in the download, and it doesn't :-(

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
Re: The 28 april 2006 build is out.
« Reply #31 on: April 29, 2006, 05:56:04 pm »
fixed (updated) rpm back available

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: The 28 april 2006 build is out.
« Reply #32 on: April 29, 2006, 06:20:20 pm »
wxSmith wizard project doesn't work my system is WinXP wxWidgets 2.6.3 and use the latest SVN revision (2396) with the new wxSmith
I hit the button that says "Start Wizard" and noting happen what is the reason

for the note I built CB by myself from source
« Last Edit: April 29, 2006, 07:24:18 pm by PsYhLo »

Offline artoj

  • Almost regular
  • **
  • Posts: 206
  • Location: Supporting my team
    • http://ajonsson.kapsi.fi/
Re: The 28 april 2006 build is out.
« Reply #33 on: April 29, 2006, 06:32:12 pm »
wxSmith wizard poject doesn't work my system is WinXP wxWidgets 2.6.3 and use the latest SVN revision (2396) with the new wxSmith
I hit the button that says "Start Wizard" and noting happen what is the reason

I think you should post the information to this thread instead.

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: The 28 april 2006 build is out.
« Reply #34 on: April 29, 2006, 06:39:04 pm »
@artoj you are right :)

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: The 28 april 2006 build is out.
« Reply #35 on: April 29, 2006, 09:44:01 pm »
toolbar-images-not-changing-state (is a wx problem/Win XP problem)

For some reason this bug dissapeard for me in the prev nightly build and is also gone in this one.
I only noticed it a few minutes ago.

IIRC, it was fixed sometimes ago. Anyway, not in the debug menu.

Best wishes,
Michael

Offline Tjaalie

  • Multiple posting newcomer
  • *
  • Posts: 40
Re: The 28 april 2006 build is out.
« Reply #36 on: April 30, 2006, 01:00:38 pm »
toolbar-images-not-changing-state (is a wx problem/Win XP problem)

For some reason this bug dissapeard for me in the prev nightly build and is also gone in this one.
I only noticed it a few minutes ago.

IIRC, it was fixed sometimes ago. Anyway, not in the debug menu.

Best wishes,
Michael


It works fine for me in all menu's, maby it has something to do with the fact that i changed my color settings? First the grip color of my menu's was gray (and I had the bug) now I changed it to the default windows color and it works fine. I know this may sound very stupit but it works just like it has to do here and if other people still have this bug it some even more wierd.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: The 28 april 2006 build is out.
« Reply #37 on: April 30, 2006, 10:00:15 pm »
toolbar-images-not-changing-state (is a wx problem/Win XP problem)

For some reason this bug dissapeard for me in the prev nightly build and is also gone in this one.
I only noticed it a few minutes ago.

IIRC, it was fixed sometimes ago. Anyway, not in the debug menu.

Best wishes,
Michael


It works fine for me in all menu's, maby it has something to do with the fact that i changed my color settings? First the grip color of my menu's was gray (and I had the bug) now I changed it to the default windows color and it works fine. I know this may sound very stupit but it works just like it has to do here and if other people still have this bug it some even more wierd.

Ok, thanks for the info :).

I should switch from 2.6.3-RC1 to 2.6.3 (with patches) and do a full rebuild :).

Best wishes,
Michael