Author Topic: Fixed bug in Code Profiler [wxNO]  (Read 5041 times)

PChris

  • Guest
Fixed bug in Code Profiler [wxNO]
« on: April 26, 2006, 05:43:06 pm »
Hello!

I fixed the bug in the Profiler plugin, related to the incorrect usage of wxNO.
This bug caused a misbehaviour, if no profile file can be found, clicking NO on the dialog has no effect.
cbMessageBox uses wxMessageDialog, so instead of wxNO, wxID_NO is used now ;)

The fixed file is attached.

PChris

BTW: Is there some place, where everybody can upload such fixes?

[attachment deleted by admin]

sethjackson

  • Guest
Re: Fixed bug in Code Profiler [wxNO]
« Reply #1 on: April 26, 2006, 05:55:13 pm »
Yes. Right here (No zip file upload though).

http://developer.berlios.de/patch/?group_id=5358

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: Fixed bug in Code Profiler [wxNO]
« Reply #2 on: April 26, 2006, 06:01:57 pm »
Yes. Right here (No zip file upload though).

http://developer.berlios.de/patch/?group_id=5358
but the .tar.gz and .tar.bz2 are allowed

PChris

  • Guest
Re: Fixed bug in Code Profiler [wxNO]
« Reply #3 on: April 26, 2006, 06:06:35 pm »
Well, thanks I will use it next time ;)

sethjackson

  • Guest
Re: Fixed bug in Code Profiler [wxNO]
« Reply #4 on: April 26, 2006, 07:34:56 pm »

PChris

  • Guest
Re: Fixed bug in Code Profiler [wxNO]
« Reply #5 on: April 26, 2006, 07:50:22 pm »
Is there any chance, that this fix will appear in the svn repository?

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5164
Re: Fixed bug in Code Profiler [wxNO]
« Reply #6 on: April 26, 2006, 08:00:39 pm »
looking at it right now

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5164
Re: Fixed bug in Code Profiler [wxNO]
« Reply #7 on: April 26, 2006, 08:07:59 pm »
fixed, thanks for the help !!!

PChris

  • Guest
Re: Fixed bug in Code Profiler [wxNO]
« Reply #8 on: April 26, 2006, 08:14:46 pm »
There are some more fixes in progress ;)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5164
Re: Fixed bug in Code Profiler [wxNO]
« Reply #9 on: April 26, 2006, 08:22:07 pm »
There are some more fixes in progress ;)
superb