Author Topic: The 25 april 2006 build is out.  (Read 7107 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 25 april 2006 build is out.
« on: April 25, 2006, 08:32:58 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml
A link to the unicode windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26u_gcc_cb.7z
For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://download.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://download.berlios.de/codeblocks/wxmsw26_gcc_cb.7z

The 25 April 2006 build is out.
  - Windows : http://download.berlios.de/codeblocks/CB_20060425_rev2380_win32.7z
  - Linux :
         http://download.berlios.de/codeblocks/CB_20060425_rev2380_ubuntu.deb
         http://download.berlios.de/codeblocks/CB_20060425_rev2380_fc4+5.rpm

Resolved Fixed:

  • Added SetBestFittingSize() to compiler and debugger toolbars
  • wxSmith redesign: wxsDrawingWindow updates
  • Folded code block doesn't unfold from search results [ Bug #7210 ] fixed

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • there are several issues with Code Completion (is being redesigned : work in progress)

« Last Edit: April 26, 2006, 03:14:44 pm by killerbot »

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 25 april 2006 build is out.
« Reply #1 on: April 25, 2006, 09:59:49 pm »
Hello,

I've inserted another two SetBestFittingSize() for good.
Don't know if that fixes the Windows 2000 problem, but it might as well. In any case, it does not make things worse :)

I have the same problem than before with the toolbar on Windows 2000 sp4  :(
See http://forums.codeblocks.org/index.php?topic=2960.msg23322#msg23322

I hope you could correct that behavior one day.

Thanks and have a nice day

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: The 25 april 2006 build is out.
« Reply #2 on: April 25, 2006, 11:18:01 pm »
why the wxSmith project wizard doesn't work
i try to create a new project and noting happen

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: The 25 april 2006 build is out.
« Reply #3 on: April 25, 2006, 11:31:03 pm »
why the wxSmith project wizard doesn't work
i try to create a new project and noting happen
That happened to me before, I don't remember what was the problem, but fixed it by doing a clean rebuild.

Offline Escorter

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 25 april 2006 build is out.
« Reply #4 on: April 26, 2006, 12:18:39 am »
I have problems with the nightly builds: they can't handle Visual Studio solutions correctly.

I imported the Delta3D engine solution. I start to compile the core lib, but it stopped, with a missing header file. But the header file is in its correct place, and I added its path in Directories->Compiler. It's only compiles if I modify:

Code: [Select]
#include "noise1.h"
to

Code: [Select]
#include "..\..\..\inc\dtUtil\noise1.h"
I never experienced this with the old stable version of C::B.

In a nutshell: I need to add the full path of the header file.
« Last Edit: April 26, 2006, 02:25:14 am by Escorter »

Offline adam

  • Single posting newcomer
  • *
  • Posts: 7
Re: The 25 april 2006 build is out.
« Reply #5 on: April 26, 2006, 02:45:57 am »
By using " " in the include your saying for the linker to check the local directory, relative or absolute. Try using < > which will tell it to check the search directories.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: The 25 april 2006 build is out.
« Reply #6 on: April 26, 2006, 08:40:50 am »
Quote
I imported the Delta3D engine solution. I start to compile the core lib, but it stopped, with a missing header file. But the header file is in its correct place, and I added its path in Directories->Compiler.

Go to "Settings->Compiler & Debugger->Global compiler settings->Other" and put a checkmark in the two checkboxes there.
If this doesn't help, go to "Project->Properties" and select "Source dir" for PCH mode.
Be patient!
This bug will be fixed soon...